diff mbox series

[meta-python,2/5] python3-anyio: add recipe for v4.2.0

Message ID 20240205125829.152301-3-dev@g0hl1n.net
State Accepted
Headers show
Series Add python3-httpx support | expand

Commit Message

Richard Leitner Feb. 5, 2024, 12:58 p.m. UTC
High level compatibility layer for multiple asynchronous event loop
implementations.

This recipe is currently provided without trio support, as the author
has no use for it and it would require to add a new python3-trio recipe.

This recipe uses pypi as source:

    https://pypi.org/project/anyio

Signed-off-by: Richard Leitner <dev@g0hl1n.net>
---
 .../python/python3-anyio_4.2.0.bb             | 23 +++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb b/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
new file mode 100644
index 000000000..0bf907de7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "High level compatibility layer for multiple asynchronous event loop implementations"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f"
+
+inherit pypi python_setuptools_build_meta
+
+SRC_URI[sha256sum] = "e1875bb4b4e2de1669f4bc7869b6d3f54231cdced71605e6e64c9be77e3be50f"
+
+DEPENDS += " \
+	python3-setuptools-scm-native \
+"
+
+# Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently.
+# If somebody needs this please feel free to add python3-trio and enable the
+# packageconfig below:
+#PACKAGECONFIG ??= ""
+#PACKAGECONFIG[trio] = ",,,python3-trio"
+
+RDEPENDS:${PN} += "\
+    python3-idna \
+    python3-sniffio \
+"