Patchwork qt4: add missing libglu dependency

login
register
mail settings
Submitter Ross Burton
Date Nov. 5, 2012, 10:31 a.m.
Message ID <1352111511-22618-1-git-send-email-ross.burton@intel.com>
Download mbox | patch
Permalink /patch/38783/
State New
Headers show

Comments

Ross Burton - Nov. 5, 2012, 10:31 a.m.
Qt4 needs to explicitly depend on libglu now that it's been split out of the
Mesa recipe.

Signed-off-by: Ross Burton <ross.burton@intel.com>
---
 meta/recipes-qt/qt4/qt4-x11-free.inc |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
Martin Jansa - Nov. 5, 2012, 5:09 p.m.
On Mon, Nov 05, 2012 at 10:31:51AM +0000, Ross Burton wrote:
> Qt4 needs to explicitly depend on libglu now that it's been split out of the
> Mesa recipe.

I'll try to remove -lGLU from our linux.conf which seems to be only
reason why we depend on it.
./linux.conf:QMAKE_LIBS_OPENGL     = -lGLU -lGL

Upstream has only -lGL in QMAKE_LIBS_OPENGL.

Cheers,

> 
> Signed-off-by: Ross Burton <ross.burton@intel.com>
> ---
>  meta/recipes-qt/qt4/qt4-x11-free.inc |    4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/meta/recipes-qt/qt4/qt4-x11-free.inc b/meta/recipes-qt/qt4/qt4-x11-free.inc
> index 20ad30c..ef3ff81 100644
> --- a/meta/recipes-qt/qt4/qt4-x11-free.inc
> +++ b/meta/recipes-qt/qt4/qt4-x11-free.inc
> @@ -3,11 +3,11 @@ require qt4.inc
>  DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the X11 version."
>  HOMEPAGE = "http://qt.nokia.com"
>  SECTION = "x11/libs"
> -DEPENDS += "virtual/libgl virtual/libx11 fontconfig libxft libxext libxrender libxrandr libxcursor"
> +DEPENDS += "virtual/libgl libglu virtual/libx11 fontconfig libxft libxext libxrender libxrandr libxcursor"
>  PROVIDES += "qt4-x11"
>  QT4DEPENDS = ""
>  
> -INC_PR = "r47"
> +INC_PR = "r48"
>  
>  QT_GLFLAGS ?= "${@base_contains('DISTRO_FEATURES', 'opengl', '-opengl', '-no-opengl', d)} "
>  QT_GLFLAGS_qemux86 = "-opengl"
> -- 
> 1.7.10
> 
> 
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core

Patch

diff --git a/meta/recipes-qt/qt4/qt4-x11-free.inc b/meta/recipes-qt/qt4/qt4-x11-free.inc
index 20ad30c..ef3ff81 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free.inc
+++ b/meta/recipes-qt/qt4/qt4-x11-free.inc
@@ -3,11 +3,11 @@  require qt4.inc
 DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the X11 version."
 HOMEPAGE = "http://qt.nokia.com"
 SECTION = "x11/libs"
-DEPENDS += "virtual/libgl virtual/libx11 fontconfig libxft libxext libxrender libxrandr libxcursor"
+DEPENDS += "virtual/libgl libglu virtual/libx11 fontconfig libxft libxext libxrender libxrandr libxcursor"
 PROVIDES += "qt4-x11"
 QT4DEPENDS = ""
 
-INC_PR = "r47"
+INC_PR = "r48"
 
 QT_GLFLAGS ?= "${@base_contains('DISTRO_FEATURES', 'opengl', '-opengl', '-no-opengl', d)} "
 QT_GLFLAGS_qemux86 = "-opengl"