diff mbox series

rpm: override curl executable search with just 'curl'

Message ID 20240202132352.2185807-1-alex@linutronix.de
State Accepted, archived
Commit 785c39701ea17e6a539709b9ae905f7b0667bceb
Headers show
Series rpm: override curl executable search with just 'curl' | expand

Commit Message

Alexander Kanavin Feb. 2, 2024, 1:23 p.m. UTC
rpm is searching for curl executable at do_configure time
and result is non-deterministic, depending on whether curl
is in native sysroot or not:
https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20240201-8dcic6ea/packages/diff-html/

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-devtools/rpm/rpm_4.19.1.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/rpm/rpm_4.19.1.bb b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
index af11dec5ef3..086f100229b 100644
--- a/meta/recipes-devtools/rpm/rpm_4.19.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
@@ -51,6 +51,7 @@  S = "${WORKDIR}/git"
 DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3 sqlite3 zstd"
 DEPENDS:append:class-native = " file-replacement-native bzip2-replacement-native"
 
+EXTRA_OECMAKE:append = " -D__CURL:FILEPATH=curl"
 EXTRA_OECMAKE:append:libc-musl = " -DENABLE_NLS=OFF -DENABLE_OPENMP=OFF"
 
 # --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs