diff mbox series

[meta-python] python3-aiohttp: upgrade 3.9.1 -> 3.9.2

Message ID 20240129065614.38288-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-aiohttp: upgrade 3.9.1 -> 3.9.2 | expand

Commit Message

Alper Ak Jan. 29, 2024, 6:56 a.m. UTC
Updated RDEPENDS accordingly setup.cfg

Changelog:

Bug fixes
---------

- Fixed server-side websocket connection leak.

  *Related issues and pull requests on GitHub:*
  :issue:`7978`.

- Fixed ``web.FileResponse`` doing blocking I/O in the event loop.

  *Related issues and pull requests on GitHub:*
  :issue:`8012`.

- Fixed double compress when compression enabled and compressed file exists in server file responses.

  *Related issues and pull requests on GitHub:*
  :issue:`8014`.

- Added runtime type check for ``ClientSession`` ``timeout`` parameter.

  *Related issues and pull requests on GitHub:*
  :issue:`8021`.

- Fixed an unhandled exception in the Python HTTP parser on header lines starting with a colon -- by :user:`pajod`.

  Invalid request lines with anything but a dot between the HTTP major and minor version are now rejected.
  Invalid header field names containing question mark or slash are now rejected.
  Such requests are incompatible with :rfc:`9110#section-5.6.2` and are not known to be of any legitimate use.

  *Related issues and pull requests on GitHub:*
  :issue:`8074`.

- Improved validation of paths for static resources requests to the server -- by :user:`bdraco`.

  *Related issues and pull requests on GitHub:*
  :issue:`8079`.

Features
--------

- Added support for passing :py:data:`True` to ``ssl`` parameter in ``ClientSession`` while
  deprecating :py:data:`None` -- by :user:`xiangyan99`.

  *Related issues and pull requests on GitHub:*
  :issue:`7698`.

Breaking changes
----------------

- Fixed an unhandled exception in the Python HTTP parser on header lines starting with a colon -- by :user:`pajod`.

  Invalid request lines with anything but a dot between the HTTP major and minor version are now rejected.
  Invalid header field names containing question mark or slash are now rejected.
  Such requests are incompatible with :rfc:`9110#section-5.6.2` and are not known to be of any legitimate use.

  *Related issues and pull requests on GitHub:*
  :issue:`8074`.

Improved documentation
----------------------

- Fixed examples of ``fallback_charset_resolver`` function in the :doc:`client_advanced` document. -- by :user:`henry0312`.

  *Related issues and pull requests on GitHub:*
  :issue:`7995`.

- The Sphinx setup was updated to avoid showing the empty
  changelog draft section in the tagged release documentation
  builds on Read The Docs -- by :user:`webknjaz`.

  *Related issues and pull requests on GitHub:*
  :issue:`8067`.

Packaging updates and notes for downstreams
-------------------------------------------

- The changelog categorization was made clearer. The
  contributors can now mark their fragment files more
  accurately -- by :user:`webknjaz`.

  The new category tags are:

      * ``bugfix``

      * ``feature``

      * ``deprecation``

      * ``breaking`` (previously, ``removal``)

      * ``doc``

      * ``packaging``

      * ``contrib``

      * ``misc``

  *Related issues and pull requests on GitHub:*
  :issue:`8066`.

Contributor-facing changes
--------------------------

- Updated :ref:`contributing/Tests coverage <aiohttp-contributing>` section to show how we use ``codecov`` -- by :user:`Dreamsorcerer`.

  *Related issues and pull requests on GitHub:*
  :issue:`7916`.

- The changelog categorization was made clearer. The
  contributors can now mark their fragment files more
  accurately -- by :user:`webknjaz`.

  The new category tags are:

      * ``bugfix``

      * ``feature``

      * ``deprecation``

      * ``breaking`` (previously, ``removal``)

      * ``doc``

      * ``packaging``

      * ``contrib``

      * ``misc``

  *Related issues and pull requests on GitHub:*
  :issue:`8066`.

Miscellaneous internal changes
------------------------------

- Replaced all ``tmpdir`` fixtures with ``tmp_path`` in test suite.

  *Related issues and pull requests on GitHub:*
  :issue:`3551`.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 ...iohttp_3.9.1.bb => python3-aiohttp_3.9.2.bb} | 17 +++++------------
 1 file changed, 5 insertions(+), 12 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-aiohttp_3.9.1.bb => python3-aiohttp_3.9.2.bb} (56%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-aiohttp_3.9.1.bb b/meta-python/recipes-devtools/python/python3-aiohttp_3.9.2.bb
similarity index 56%
rename from meta-python/recipes-devtools/python/python3-aiohttp_3.9.1.bb
rename to meta-python/recipes-devtools/python/python3-aiohttp_3.9.2.bb
index 566417047..42fe66908 100644
--- a/meta-python/recipes-devtools/python/python3-aiohttp_3.9.1.bb
+++ b/meta-python/recipes-devtools/python/python3-aiohttp_3.9.2.bb
@@ -4,24 +4,17 @@  HOMEPAGE = "https://github.com/aio-libs/aiohttp"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=748073912af33aa59430d3702aa32d41"
 
-SRC_URI[sha256sum] = "8fc49a87ac269d4529da45871e2ffb6874e87779c3d0e2ccd813c0899221239d"
+SRC_URI[sha256sum] = "b0ad0a5e86ce73f5368a164c10ada10504bf91869c05ab75d982c6048217fbf7"
 
 PYPI_PACKAGE = "aiohttp"
 inherit python_setuptools_build_meta pypi
 
 RDEPENDS:${PN} = "\
+    ${PYTHON_PN}-aiohappyeyeballs \
+    ${PYTHON_PN}-aiosignal \
     ${PYTHON_PN}-async-timeout \
-    ${PYTHON_PN}-attrs \
-    ${PYTHON_PN}-chardet \
-    ${PYTHON_PN}-html \
-    ${PYTHON_PN}-idna-ssl \
-    ${PYTHON_PN}-json \
-    ${PYTHON_PN}-misc \
+    ${PYTHON_PN}-frozenlist \
     ${PYTHON_PN}-multidict \
-    ${PYTHON_PN}-netserver \
-    ${PYTHON_PN}-typing-extensions \
     ${PYTHON_PN}-yarl \
-    ${PYTHON_PN}-cchardet \
-    ${PYTHON_PN}-charset-normalizer \
-    ${PYTHON_PN}-aiosignal \
+    ${PYTHON_PN}-aiodns \
 "