diff mbox series

[meta-python] python3-netaddr: upgrade 0.10.0 -> 0.10.1

Message ID 20240126055147.8810-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-netaddr: upgrade 0.10.0 -> 0.10.1 | expand

Commit Message

Alper Ak Jan. 26, 2024, 5:51 a.m. UTC
Changelog:

Fixed:

    Get rid of some warnings

Deprecated:

    Deprecate the flag shorthands: N, P and Z. Use NOHOST, INET_PTON and ZEROFILL instead.

    Deprecate importing objects from netaddr subpackages. Only importing things from the top-level netaddr namespace is supported, everything else is considered private.

    This has already been the case but we can use a reminder.

    Deprecate permissive-by-default IPv4 parsing in valid_ipv4(). The inet_pton() semantics (with leading zeros always disallowed) will become the default. Use INET_ATON and/or ZEROFILL flags if you need the legacy behavior.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../{python3-netaddr_0.10.0.bb => python3-netaddr_0.10.1.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-netaddr_0.10.0.bb => python3-netaddr_0.10.1.bb} (75%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-netaddr_0.10.0.bb b/meta-python/recipes-devtools/python/python3-netaddr_0.10.1.bb
similarity index 75%
rename from meta-python/recipes-devtools/python/python3-netaddr_0.10.0.bb
rename to meta-python/recipes-devtools/python/python3-netaddr_0.10.1.bb
index 15350e942..ce16cc178 100644
--- a/meta-python/recipes-devtools/python/python3-netaddr_0.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-netaddr_0.10.1.bb
@@ -2,7 +2,7 @@  SUMMARY = "A network address manipulation library for Python."
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e6345d695ffe3776f68a56fe7962db44"
 
-SRC_URI[sha256sum] = "4c30c54adf4ea4318b3c055ea3d8c7f6554a50aa2cd8aea4605a23caa0b0229e"
+SRC_URI[sha256sum] = "f4da4222ca8c3f43c8e18a8263e5426c750a3a837fdfeccf74c68d0408eaa3bf"
 
 inherit pypi setuptools3