diff mbox series

[master,1/2] libcamera: drop old 0.0.5 version

Message ID 20240124220708.2031475-1-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [master,1/2] libcamera: drop old 0.0.5 version | expand

Commit Message

Denys Dmytriyenko Jan. 24, 2024, 10:07 p.m. UTC
From: Denys Dmytriyenko <denys@konsulko.com>

This version no longer works with Python 3.12

Version 0.1.0 from meta-openembedded/meta-multimedia has a workaround patch.

Upstream 0.2.0 version has this fixed and the update patch has been submitted:
https://patchwork.yoctoproject.org/project/oe/patch/20240124215938.2030548-1-denis@denix.org/

Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 .../0001-simple-Support-TI-CSI-RX.patch       | 32 ---------
 .../libcamera/libcamera_0.0.5.bb              | 72 -------------------
 2 files changed, 104 deletions(-)
 delete mode 100644 meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
 delete mode 100644 meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch b/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
deleted file mode 100644
index e1c30b61..00000000
--- a/meta-arago-extras/recipes-multimedia/libcamera/libcamera/0001-simple-Support-TI-CSI-RX.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From d0e4f4f224671e9fc992d39e7beb9c486303ede1 Mon Sep 17 00:00:00 2001
-From: Jai Luthra <j-luthra@ti.com>
-Date: Thu, 23 Mar 2023 11:38:46 +0530
-Subject: [PATCH] simple: Support TI CSI-RX
-
-Add support for TI's CSI-RX pixel grabber device for the simple
-pipeline.
-
-The driver is not yet merged, but v7 is posted [1] upstream.
-
-Link: https://lore.kernel.org/all/20230314115516.667-1-vaishnav.a@ti.com/ [1]
-Upstream-Status: Pending
-Signed-off-by: Jai Luthra <j-luthra@ti.com>
----
- src/libcamera/pipeline/simple/simple.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/libcamera/pipeline/simple/simple.cpp b/src/libcamera/pipeline/simple/simple.cpp
-index e1f8b989..520405a1 100644
---- a/src/libcamera/pipeline/simple/simple.cpp
-+++ b/src/libcamera/pipeline/simple/simple.cpp
-@@ -194,6 +194,8 @@ static const SimplePipelineInfo supportedDevices[] = {
-	{ "mxc-isi", {} },
-	{ "qcom-camss", {} },
-	{ "sun6i-csi", {} },
-+	{ "j721e-csi2rx", {} },
-+
- };
-
- } /* namespace */
---
-2.41.0
diff --git a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb b/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
deleted file mode 100644
index f4290320..00000000
--- a/meta-arago-extras/recipes-multimedia/libcamera/libcamera_0.0.5.bb
+++ /dev/null
@@ -1,72 +0,0 @@ 
-SUMMARY = "Linux libcamera framework"
-SECTION = "libs"
-
-LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
-
-LIC_FILES_CHKSUM = "\
-    file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \
-    file://LICENSES/LGPL-2.1-or-later.txt;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \
-"
-
-SRC_URI = " \
-        git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \
-        file://0001-simple-Support-TI-CSI-RX.patch \
-"
-
-SRCREV = "fb44403f1c5571549ac128c21daee9761eb9249c"
-
-PE = "1"
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "python3-pyyaml-native python3-jinja2-native python3-ply-native python3-jinja2-native udev gnutls chrpath-native libevent libyaml"
-DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
-
-PACKAGES =+ "${PN}-gst"
-
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[gst] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"
-
-LIBCAMERA_PIPELINES ??= "auto"
-
-EXTRA_OEMESON = " \
-    -Dpipelines=${LIBCAMERA_PIPELINES} \
-    -Dv4l2=true \
-    -Dcam=enabled \
-    -Dlc-compliance=disabled \
-    -Dtest=false \
-    -Ddocumentation=disabled \
-"
-
-RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
-
-inherit meson pkgconfig python3native
-
-do_configure:prepend() {
-    sed -i -e 's|py_compile=True,||' ${S}/utils/ipc/mojo/public/tools/mojom/mojom/generate/template_expander.py
-}
-
-do_install:append() {
-    chrpath -d ${D}${libdir}/libcamera.so
-    chrpath -d ${D}${libdir}/v4l2-compat.so
-}
-
-addtask do_recalculate_ipa_signatures_package after do_package before do_packagedata
-do_recalculate_ipa_signatures_package() {
-    local modules
-    for module in $(find ${PKGD}/usr/lib/libcamera -name "*.so.sign"); do
-        module="${module%.sign}"
-        if [ -f "${module}" ] ; then
-            modules="${modules} ${module}"
-        fi
-    done
-
-    ${S}/src/ipa/ipa-sign-install.sh ${B}/src/ipa-priv-key.pem "${modules}"
-}
-
-FILES:${PN} += " ${libdir}/v4l2-compat.so"
-FILES:${PN}-gst = "${libdir}/gstreamer-1.0"
-
-# libcamera-v4l2 explicitly sets _FILE_OFFSET_BITS=32 to get access to
-# both 32 and 64 bit file APIs.
-GLIBC_64BIT_TIME_FLAGS = ""