diff mbox series

[meta-python] python3-absl: upgrade 2.0.0 -> 2.1.0

Message ID 1705973466-25412-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-absl: upgrade 2.0.0 -> 2.1.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 23, 2024, 1:31 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
=========
-Added absl.flags.override_value function to provide FlagHolder with a construct
 to modify values.
-Added a new method absltest.TestCase.assertDataclassEqual that tests equality
 of dataclass.dataclass objects with better error messages when the assert fails.
-absl.flags.argparse_flags.ArgumentParser now correctly inherits an empty
 instance of FlagValues to ensure that absl flags, such as --flagfile, --undefok
 are supported.
-Do not exit 5 if tests were skipped on Python 3.12. This follows the CPython
 change in python/cpython#113856.
-The flag foo no longer retains the value bar after FLAGS.foo = bar fails due to
 a validation error.
-Fixed an issue caused by this Python 3.12.1 change where the test reporter
 crashes when all tests are skipped.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-absl_2.0.0.bb => python3-absl_2.1.0.bb}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-absl_2.0.0.bb => python3-absl_2.1.0.bb} (76%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-absl_2.0.0.bb b/meta-python/recipes-devtools/python/python3-absl_2.1.0.bb
similarity index 76%
rename from meta-python/recipes-devtools/python/python3-absl_2.0.0.bb
rename to meta-python/recipes-devtools/python/python3-absl_2.1.0.bb
index 42c7f3f84..5bdb83175 100644
--- a/meta-python/recipes-devtools/python/python3-absl_2.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-absl_2.1.0.bb
@@ -4,7 +4,7 @@  SECTION = "devel/python"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-SRC_URI[sha256sum] = "d9690211c5fcfefcdd1a45470ac2b5c5acd45241c3af71eed96bc5441746c0d5"
+SRC_URI[sha256sum] = "7820790efbb316739cde8b4e19357243fc3608a152024288513dd968d7d959ff"
 
 PYPI_PACKAGE = "absl-py"