diff mbox series

[2/2] mdadm: Disable ptest

Message ID 20240122085443.637472-4-pavel@zhukoff.net
State New
Headers show
Series [1/2] mdamd: Switch to git recipe | expand

Commit Message

Pavel Zhukov Jan. 22, 2024, 8:54 a.m. UTC
mdadm tests are flaky and cause a lot of failures on autobuilder.
Disable them for now. Keeping ptest code in the recipe to fix/enable
in the future

Signed-off-by: Pavel Zhukov <pavel@zhukoff.net>
---
 meta/recipes-extended/mdadm/mdadm_git.bb | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Alexander Kanavin Jan. 22, 2024, 10:21 a.m. UTC | #1
On Mon, 22 Jan 2024 at 09:55, Pavel Zhukov <pavel@zhukoff.net> wrote:
> mdadm tests are flaky and cause a lot of failures on autobuilder.
> Disable them for now. Keeping ptest code in the recipe to fix/enable
> in the future
>  SRC_URI = "git://git.kernel.org/pub/scm/utils/mdadm/mdadm.git;protocol=https;branch=master \
> -           file://run-ptest \
> +# Disable ptests for now as they're flaky
> +# but keeping ptest code in case we want to enable them in the future
> +PTEST_ENABLED="0"
> +SRC_URI:append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' file://run-ptest', '', d)}"

The correct way to do this is to modify
conf/distro/include/ptest-packagelists.inc. There's a specific
exclusion list made for that purpose in there at the end.

Alex
Yoann Congal Jan. 22, 2024, 10:24 a.m. UTC | #2
Le lun. 22 janv. 2024 à 11:21, Alexander Kanavin <alex.kanavin@gmail.com> a
écrit :

> On Mon, 22 Jan 2024 at 09:55, Pavel Zhukov <pavel@zhukoff.net> wrote:
> > mdadm tests are flaky and cause a lot of failures on autobuilder.
> > Disable them for now. Keeping ptest code in the recipe to fix/enable
> > in the future
> >  SRC_URI = "git://
> git.kernel.org/pub/scm/utils/mdadm/mdadm.git;protocol=https;branch=master
> \
> > -           file://run-ptest \
> > +# Disable ptests for now as they're flaky
> > +# but keeping ptest code in case we want to enable them in the future
> > +PTEST_ENABLED="0"
> > +SRC_URI:append = "${@bb.utils.contains('PTEST_ENABLED', '1', '
> file://run-ptest', '', d)}"
>
> The correct way to do this is to modify
> conf/distro/include/ptest-packagelists.inc. There's a specific
> exclusion list made for that purpose in there at the end.
>

(Oops I've previously answered to Pavel in private, sorry :( )
I guess you are talking about PTESTS_PROBLEMS =>
https://git.openembedded.org/openembedded-core/tree/meta/conf/distro/include/ptest-packagelists.inc#n142

Regards,

Alex
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#194135):
> https://lists.openembedded.org/g/openembedded-core/message/194135
> Mute This Topic: https://lists.openembedded.org/mt/103882792/4316185
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> yoann.congal@smile.fr]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Pavel Zhukov Jan. 22, 2024, 10:28 a.m. UTC | #3
Yes, Yoann has mentioned this already.
Seems like recipes use both PTEST_ENABLED and PTESTS_PROBLEMS for this purposes and I've not found any documentation. I'll update the patch to use PTESTS_PROBLEMS instead
Alexander Kanavin Jan. 22, 2024, 10:32 a.m. UTC | #4
None of the recipes in oe-core set PTEST_ENABLED, they only read it to
determine build settings. If recipes in other layers do that, it's a
mistake.

Alex

On Mon, 22 Jan 2024 at 11:28, Pavel Zhukov <pavel@zhukoff.net> wrote:
>
> Yes, Yoann has mentioned this already.
> Seems like recipes use both PTEST_ENABLED and PTESTS_PROBLEMS for this purposes and I've not found any documentation. I'll update the patch to use PTESTS_PROBLEMS instead
>
> --
> Pavel
>
> On Mon, Jan 22, 2024, at 11:21, Alexander Kanavin wrote:
>
> On Mon, 22 Jan 2024 at 09:55, Pavel Zhukov <pavel@zhukoff.net> wrote:
> > mdadm tests are flaky and cause a lot of failures on autobuilder.
> > Disable them for now. Keeping ptest code in the recipe to fix/enable
> > in the future
> >  SRC_URI = "git://git.kernel.org/pub/scm/utils/mdadm/mdadm.git;protocol=https;branch=master \
> > -           file://run-ptest \
> > +# Disable ptests for now as they're flaky
> > +# but keeping ptest code in case we want to enable them in the future
> > +PTEST_ENABLED="0"
> > +SRC_URI:append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' file://run-ptest', '', d)}"
>
> The correct way to do this is to modify
> conf/distro/include/ptest-packagelists.inc. There's a specific
> exclusion list made for that purpose in there at the end.
>
> Alex
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#194135): https://lists.openembedded.org/g/openembedded-core/message/194135
> Mute This Topic: https://lists.openembedded.org/mt/103882792/6390638
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [pavel@zhukoff.net]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/mdadm/mdadm_git.bb b/meta/recipes-extended/mdadm/mdadm_git.bb
index 53574dfdc3..d95df66af5 100644
--- a/meta/recipes-extended/mdadm/mdadm_git.bb
+++ b/meta/recipes-extended/mdadm/mdadm_git.bb
@@ -10,7 +10,6 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
 
 
 SRC_URI = "git://git.kernel.org/pub/scm/utils/mdadm/mdadm.git;protocol=https;branch=master \
-           file://run-ptest \
            file://mdadm-3.3.2_x32_abi_time_t.patch \
            file://0001-mdadm.h-Undefine-dprintf-before-redefining.patch \
            file://0001-Fix-the-path-of-corosync-and-dlm-header-files-check.patch \
@@ -31,6 +30,11 @@  S = "${WORKDIR}/git"
 
 inherit autotools-brokensep ptest systemd
 
+# Disable ptests for now as they're flaky
+# but keeping ptest code in case we want to enable them in the future
+PTEST_ENABLED="0"
+SRC_URI:append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' file://run-ptest', '', d)}"
+
 DEPENDS = "udev"
 
 SYSTEMD_SERVICE:${PN} = "mdmonitor.service"