Patchwork [meta-oe] libftdi: Change to use GPLv2 intead of GPLv2-REL

login
register
mail settings
Submitter Martin Ertsaas
Date Oct. 9, 2012, 12:04 p.m.
Message ID <1349784265-25901-1-git-send-email-mertsas@cisco.com>
Download mbox | patch
Permalink /patch/38023/
State Superseded
Headers show

Comments

Martin Ertsaas - Oct. 9, 2012, 12:04 p.m.
According to http://www.intra2net.com/en/developer/libftdi/, libftdi itself is licensed under LGPLv2,
with some parts (eeprom programmer) is licensed under GPLv2. There doesn't seem to be any part licensed
under a GPLv2-REL variation of GPLv2, and so we should use GPLv2 instead of GPLv2-REL.

Signed-off-by: Martin Ertsaas <mertsas@cisco.com>
---
 meta-oe/recipes-support/libftdi/libftdi_0.19.bb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
Koen Kooi - Oct. 9, 2012, 2:17 p.m.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Op 09-10-12 14:04, Martin Ertsaas schreef:
> According to http://www.intra2net.com/en/developer/libftdi/, libftdi
> itself is licensed under LGPLv2, with some parts (eeprom programmer) is
> licensed under GPLv2. There doesn't seem to be any part licensed under a
> GPLv2-REL variation of GPLv2, and so we should use GPLv2 instead of
> GPLv2-REL.
> 
> Signed-off-by: Martin Ertsaas <mertsas@cisco.com> --- 
> meta-oe/recipes-support/libftdi/libftdi_0.19.bb |    2 +- 1 files
> changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
> b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb index 2dba3f4..0842aaf
> 100644 --- a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb +++
> b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb @@ -4,7 +4,7 @@
> including the popular bitbang mode." HOMEPAGE =
> "http://www.intra2net.com/en/developer/libftdi/" SECTION = "libs"
> 
> -LICENSE = "LGPLv2.1 GPLv2-RLE" +LICENSE = "LGPLv2.1 GPLv2" 
> LIC_FILES_CHKSUM=
> "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \ 
> file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \ "

Since LICENSE ends up in the package: missing PR bump.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (Darwin)
Comment: GPGTools - http://gpgtools.org

iD8DBQFQdDIGMkyGM64RGpERAlaLAKCCNbr1Tcydi+Re/9Wdoc/zKVibKwCgi2bH
MOFVynH6iiHafgC1/70Fq/M=
=PGD4
-----END PGP SIGNATURE-----
Martin Jansa - Oct. 9, 2012, 5:27 p.m.
On Tue, Oct 09, 2012 at 02:04:25PM +0200, Martin Ertsaas wrote:
> According to http://www.intra2net.com/en/developer/libftdi/, libftdi itself is licensed under LGPLv2,
> with some parts (eeprom programmer) is licensed under GPLv2. There doesn't seem to be any part licensed
> under a GPLv2-REL variation of GPLv2, and so we should use GPLv2 instead of GPLv2-REL.

Is it REL or RLE? Your subject and body says REL while LICENSE says RLE.

Cheers,
 
> Signed-off-by: Martin Ertsaas <mertsas@cisco.com>
> ---
>  meta-oe/recipes-support/libftdi/libftdi_0.19.bb |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
> index 2dba3f4..0842aaf 100644
> --- a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
> +++ b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
> @@ -4,7 +4,7 @@ including the popular bitbang mode."
>  HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
>  SECTION = "libs"
>  
> -LICENSE = "LGPLv2.1 GPLv2-RLE"
> +LICENSE = "LGPLv2.1 GPLv2"
>  LIC_FILES_CHKSUM= "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
>                     file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \
>                    "
> -- 
> 1.7.8.6
> 
> 
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
Martin Ertsaas - Oct. 10, 2012, 5:50 a.m.
On 10/09/12 19:27, Martin Jansa wrote:
> On Tue, Oct 09, 2012 at 02:04:25PM +0200, Martin Ertsaas wrote:
>> According to http://www.intra2net.com/en/developer/libftdi/, libftdi itself is licensed under LGPLv2,
>> with some parts (eeprom programmer) is licensed under GPLv2. There doesn't seem to be any part licensed
>> under a GPLv2-REL variation of GPLv2, and so we should use GPLv2 instead of GPLv2-REL.
> Is it REL or RLE? Your subject and body says REL while LICENSE says RLE.
>
> Cheers,
Damn, didn't see that typo. I'll push a new one asap.

- Martin
>  
>> Signed-off-by: Martin Ertsaas <mertsas@cisco.com>
>> ---
>>  meta-oe/recipes-support/libftdi/libftdi_0.19.bb |    2 +-
>>  1 files changed, 1 insertions(+), 1 deletions(-)
>>
>> diff --git a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
>> index 2dba3f4..0842aaf 100644
>> --- a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
>> +++ b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
>> @@ -4,7 +4,7 @@ including the popular bitbang mode."
>>  HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
>>  SECTION = "libs"
>>  
>> -LICENSE = "LGPLv2.1 GPLv2-RLE"
>> +LICENSE = "LGPLv2.1 GPLv2"
>>  LIC_FILES_CHKSUM= "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
>>                     file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \
>>                    "
>> -- 
>> 1.7.8.6
>>
>>
>> _______________________________________________
>> Openembedded-devel mailing list
>> Openembedded-devel@lists.openembedded.org
>> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
>
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel

Patch

diff --git a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
index 2dba3f4..0842aaf 100644
--- a/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
+++ b/meta-oe/recipes-support/libftdi/libftdi_0.19.bb
@@ -4,7 +4,7 @@  including the popular bitbang mode."
 HOMEPAGE = "http://www.intra2net.com/en/developer/libftdi/"
 SECTION = "libs"
 
-LICENSE = "LGPLv2.1 GPLv2-RLE"
+LICENSE = "LGPLv2.1 GPLv2"
 LIC_FILES_CHKSUM= "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe \
                    file://COPYING.LIB;md5=db979804f025cf55aabec7129cb671ed \
                   "