diff mbox series

[meta-oe] spdlog: upgrade 1.12 -> 1.13

Message ID 20240115122426.766281-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-oe] spdlog: upgrade 1.12 -> 1.13 | expand

Commit Message

alperak Jan. 15, 2024, 12:24 p.m. UTC
Dropped SPDLOG_BUILD_TESTS and SPDLOG_BUILD_BENCH from EXTRA_OECMAKE because already OFF

License-Update: Use upstream's LICENSE file instead of Poky's MIT license.

Changelog:

Enhancements

    Qt Sink: Allow for darker colors for light backgrounds
    Set CMAKE_BUILD_TYPE only for single-config generators
    Provide spdlog_header_only in build directory export
    Add SPDLOG_TO_VERSION to compare spdlog version
    Support async_overflow_policy::discard_new
    Make syslog_sink.h's syslog_prio_from_level protected
    Fix OS availability check of pthread_threadid_np for iOS
    Add .git-blame-ignore-revs to ignore clang-format related commits
    Match SPDLOG_CONSTEXPR_FUNC to FMT_CONSTEXPR

Bug Fixes

    Check fd_ is not nullptr in file_helper to prevent possible crash if disk is full
    Fix encoding issue in qt_sinks
    Fix wrong thread_id (TID) in systemd_sink.h
    Update example.cpp to fix the vector issue in bin_example
    Fix MSVC compile flag for no exceptions
    Fix bug in circular_q::size()
    Fix link to fmt license file

Maintenance

    Added and updated various tests for circular_q.
    Removed obsolete part from CMake configuration files
    Removed policy_max from cmake_minimum_required(..).
    Updated clang-format to google style and updated various formatting scripts.
    Bumped to catch2

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../spdlog/{spdlog_1.12.0.bb => spdlog_1.13.0.bb}   | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)
 rename meta-oe/recipes-support/spdlog/{spdlog_1.12.0.bb => spdlog_1.13.0.bb} (58%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/spdlog/spdlog_1.12.0.bb b/meta-oe/recipes-support/spdlog/spdlog_1.13.0.bb
similarity index 58%
rename from meta-oe/recipes-support/spdlog/spdlog_1.12.0.bb
rename to meta-oe/recipes-support/spdlog/spdlog_1.13.0.bb
index c7d8ff8f3..c6a0881db 100644
--- a/meta-oe/recipes-support/spdlog/spdlog_1.12.0.bb
+++ b/meta-oe/recipes-support/spdlog/spdlog_1.13.0.bb
@@ -1,17 +1,18 @@ 
 DESCRIPTION = "Very fast, header only, C++ logging library."
 HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9573510928429ad0cbe5ba4de77546e9"
 
-SRCREV = "7e635fca68d014934b4af8a1cf874f63989352b7"
+SRCREV = "7c02e204c92545f869e2f04edaab1f19fe8b19fd"
 SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x"
 
-DEPENDS += "fmt"
+DEPENDS = "fmt"
 
 S = "${WORKDIR}/git"
 
-BBCLASSEXTEND = "native"
+inherit cmake
+
 # no need to build example & tests & benchmarks on pure yocto
-EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
+EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_FMT_EXTERNAL=on"
 
-inherit cmake
+BBCLASSEXTEND = "native"