diff mbox series

python3-pycryptodomex: upgrade 3.19.1 -> 3.20.0

Message ID 1705310697-24692-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit d4cc93966eece06ed4b146922d244104cb7e15da
Headers show
Series python3-pycryptodomex: upgrade 3.19.1 -> 3.20.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 15, 2024, 9:24 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Added support for TurboSHAKE128 and TurboSHAKE256.
-Added method Crypto.Hash.new() to generate a hash object given a hash name.
-Added support for AES-GCM encryption of PBES2 and PKCS#8 containers.
-Added support for SHA-2 and SHA-3 algorithms in PBKDF2 when creating PBES2
 and PKCS#8 containers.
-Export of RSA keys accepts the prot_params dictionary as parameter to control
 the number of iterations for PBKDF2 and scrypt.
-C unit tests also run on non-x86 architectures.
-GH#787: Fixed autodetect logic for GCC 14 in combination with LTO.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...-pycryptodomex_3.19.1.bb => python3-pycryptodomex_3.20.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-pycryptodomex_3.19.1.bb => python3-pycryptodomex_3.20.0.bb} (69%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pycryptodomex_3.19.1.bb b/meta/recipes-devtools/python/python3-pycryptodomex_3.20.0.bb
similarity index 69%
rename from meta/recipes-devtools/python/python3-pycryptodomex_3.19.1.bb
rename to meta/recipes-devtools/python/python3-pycryptodomex_3.20.0.bb
index d6e5c6d3ee..2673ea8326 100644
--- a/meta/recipes-devtools/python/python3-pycryptodomex_3.19.1.bb
+++ b/meta/recipes-devtools/python/python3-pycryptodomex_3.20.0.bb
@@ -1,7 +1,7 @@ 
 require python-pycryptodome.inc
 inherit setuptools3
 
-SRC_URI[sha256sum] = "0b7154aff2272962355f8941fd514104a88cb29db2d8f43a29af900d6398eb1c"
+SRC_URI[sha256sum] = "7a710b79baddd65b806402e14766c721aee8fb83381769c27920f26476276c1e"
 
 FILES:${PN}-tests = " \
     ${PYTHON_SITEPACKAGES_DIR}/Cryptodome/SelfTest/ \