diff mbox series

[1/2] python3-attrs: upgrade 23.1.0 -> 23.2.0

Message ID 20240105181452.1488396-1-tim.orling@konsulko.com
State New
Headers show
Series [1/2] python3-attrs: upgrade 23.1.0 -> 23.2.0 | expand

Commit Message

Tim Orling Jan. 5, 2024, 6:14 p.m. UTC
https://www.attrs.org/en/stable/changelog.html

23.2.0 - 2023-12-31

Changes
* The type annotation for attrs.resolve_types() is now correct. #1141
* Type stubs now use typing.dataclass_transform to decorate dataclass-like
  decorators, instead of the non-standard __dataclass_transform__ special
  form, which is only supported by Pyright. #1158
* Fixed serialization of namedtuple fields using attrs.asdict/astuple() with
  retain_collection_types=True. #1165
* attrs.AttrsInstance is now a typing.Protocol in both type hints and code.
  This allows you to subclass it along with another Protocol. #1172
* If attrs detects that __attrs_pre_init__ accepts more than just self, it
  will call it with the same arguments as __init__ was called. This allows
  you to, for example, pass arguments to super().__init__(). #1187
* Slotted classes now transform functools.cached_property decorated methods
  to support equivalent semantics. #1200
* Added class_body argument to attrs.make_class() to provide additional
  attributes for newly created classes. It is, for example, now possible to
  attach methods. #1203

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
Requires python3-hatch-fancy-pypi-readme upgrade beyond 23.1.0
https://patchwork.yoctoproject.org/project/oe-core/patch/1704180223-8624-1-git-send-email-wangmy@fujitsu.com/

 .../python/{python3-attrs_23.1.0.bb => python3-attrs_23.2.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-attrs_23.1.0.bb => python3-attrs_23.2.0.bb} (82%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-attrs_23.1.0.bb b/meta/recipes-devtools/python/python3-attrs_23.2.0.bb
similarity index 82%
rename from meta/recipes-devtools/python/python3-attrs_23.1.0.bb
rename to meta/recipes-devtools/python/python3-attrs_23.2.0.bb
index 314053de081..e00e1520156 100644
--- a/meta/recipes-devtools/python/python3-attrs_23.1.0.bb
+++ b/meta/recipes-devtools/python/python3-attrs_23.2.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "http://www.attrs.org/"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=5e55731824cf9205cfabeab9a0600887"
 
-SRC_URI[sha256sum] = "6279836d581513a26f1bf235f9acd333bc9115683f14f7e8fae46c98fc50e015"
+SRC_URI[sha256sum] = "935dc3b529c262f6cf76e50877d35a4bd3c1de194fd41f47a2b7ae8f19971f30"
 
 inherit pypi python_hatchling