diff mbox series

gawk: Add coreutils to rdeps for ptests package

Message ID 20240105071224.28619-1-raj.khem@gmail.com
State Accepted, archived
Commit ddcf27939625d96ee44e9c2297d5b17fa6cf46a0
Headers show
Series gawk: Add coreutils to rdeps for ptests package | expand

Commit Message

Khem Raj Jan. 5, 2024, 7:12 a.m. UTC
newer gawk 5.3.0+ added a new testcase test/cmdlinefsbacknl2.sh which
use od utility with -An option which is not available in busybox
provided od applet. Replacing -An is not possible because default output
for od is octal and the test wants to use none for radix thats why it
uses -An.

Fixes test/cmdlinefsbacknl2.sh failures in ptests

which fails like below

   Usage: od [-aBbcDdeFfHhIiLlOovXx] [FILE]
    od: unrecognized option: A
    BusyBox v1.36.1 () multi-call binary.

Sadly, this prolongs depchain if ptest distro feature is used but there
is no other option if this test has to execute. Perhaps its best to
report this to upstream gawk and request to fix the testcase to not
hard depend on coreutils/od utility

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-extended/gawk/gawk_5.3.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-extended/gawk/gawk_5.3.0.bb b/meta/recipes-extended/gawk/gawk_5.3.0.bb
index 3d652da6e5c..d7a0fc616d3 100644
--- a/meta/recipes-extended/gawk/gawk_5.3.0.bb
+++ b/meta/recipes-extended/gawk/gawk_5.3.0.bb
@@ -79,7 +79,7 @@  do_install_ptest:append:libc-musl() {
 	done
 }
 
-RDEPENDS:${PN}-ptest += "make locale-base-en-us"
+RDEPENDS:${PN}-ptest += "make locale-base-en-us coreutils"
 
 RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us.iso-8859-1"
 RDEPENDS:${PN}-ptest:append:libc-musl = " musl-locales"