diff mbox series

[meta-python] python3-pytest-cov: add missing python3-coverage dependency

Message ID 20240103095602.2737711-1-dev@g0hl1n.net
State Accepted
Headers show
Series [meta-python] python3-pytest-cov: add missing python3-coverage dependency | expand

Commit Message

Richard Leitner Jan. 3, 2024, 9:56 a.m. UTC
As reported by "pip3 check" python3-pytest-cov depends on
python3-coverage:

	$ pip3 check
	pytest-cov 4.1.0 requires coverage, which is not installed.

This patch fixes this problem by adding python3-coverage to RDEPENDS

Signed-off-by: Richard Leitner <dev@g0hl1n.net>
---
 meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Khem Raj Jan. 8, 2024, 2:47 a.m. UTC | #1
On Wed, 03 Jan 2024 10:56:02 +0100, Richard Leitner wrote:
> As reported by "pip3 check" python3-pytest-cov depends on
> python3-coverage:
> 
> 	$ pip3 check
> 	pytest-cov 4.1.0 requires coverage, which is not installed.
> 
> This patch fixes this problem by adding python3-coverage to RDEPENDS
> 
> [...]

Applied, thanks!

[1/1] python3-pytest-cov: add missing python3-coverage dependency
      commit: b56ab3d10999f77cb429881b73b52fe2991ad4e3

Best regards,
Yoann Congal Jan. 16, 2024, 4:53 p.m. UTC | #2
Le 08/01/2024 à 03:47, Khem Raj a écrit :
> 
> On Wed, 03 Jan 2024 10:56:02 +0100, Richard Leitner wrote:
>> As reported by "pip3 check" python3-pytest-cov depends on
>> python3-coverage:
>>
>> 	$ pip3 check
>> 	pytest-cov 4.1.0 requires coverage, which is not installed.
>>
>> This patch fixes this problem by adding python3-coverage to RDEPENDS
>>
>> [...]
> 
> Applied, thanks!
> 
> [1/1] python3-pytest-cov: add missing python3-coverage dependency
>       commit: b56ab3d10999f77cb429881b73b52fe2991ad4e3

Hi,

This caused https://autobuilder.yoctoproject.org/typhoon/#/builders/156/builds/206:
  stdio: WARNING: Nothing RPROVIDES 'nativesdk-python3-coverage' (but virtual:nativesdk:/home/pokybuild/yocto-worker/meta-oe-mirror/build/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb RDEPENDS on or otherwise requires it)
  stdio: WARNING: Nothing RPROVIDES 'python3-coverage-native' (but virtual:native:/home/pokybuild/yocto-worker/meta-oe-mirror/build/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb RDEPENDS on or otherwise requires it)

python3-pytest-cov does BBCLASSEXTEND = "native nativesdk" does the new dependency python3-coverage does not.

So, python3-pytest-cov-native and nativesdk-python3-pytest-cov do become unbuildable. We can either :
* keep the dependency and remove the BBCLASSEXTEND
* add the necessary BBCLASSEXTEND to the python3-pytest-cov dependencies (recursively) starting with python3-coverage

Regards,
Yoann Congal Jan. 17, 2024, 8:28 a.m. UTC | #3
Le 16/01/2024 à 17:53, Yoann Congal a écrit :
> Le 08/01/2024 à 03:47, Khem Raj a écrit :
>>
>> On Wed, 03 Jan 2024 10:56:02 +0100, Richard Leitner wrote:
>>> As reported by "pip3 check" python3-pytest-cov depends on
>>> python3-coverage:
>>>
>>> 	$ pip3 check
>>> 	pytest-cov 4.1.0 requires coverage, which is not installed.
>>>
>>> This patch fixes this problem by adding python3-coverage to RDEPENDS
>>>
>>> [...]
>>
>> Applied, thanks!
>>
>> [1/1] python3-pytest-cov: add missing python3-coverage dependency
>>       commit: b56ab3d10999f77cb429881b73b52fe2991ad4e3
> 
> Hi,
> 
> This caused https://autobuilder.yoctoproject.org/typhoon/#/builders/156/builds/206:
>   stdio: WARNING: Nothing RPROVIDES 'nativesdk-python3-coverage' (but virtual:nativesdk:/home/pokybuild/yocto-worker/meta-oe-mirror/build/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb RDEPENDS on or otherwise requires it)
>   stdio: WARNING: Nothing RPROVIDES 'python3-coverage-native' (but virtual:native:/home/pokybuild/yocto-worker/meta-oe-mirror/build/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb RDEPENDS on or otherwise requires it)
> 
> python3-pytest-cov does BBCLASSEXTEND = "native nativesdk" does the new dependency python3-coverage does not.
> 
> So, python3-pytest-cov-native and nativesdk-python3-pytest-cov do become unbuildable. We can either :
> * keep the dependency and remove the BBCLASSEXTEND
I sent a patch to do that: https://lists.openembedded.org/g/openembedded-devel/message/108324

> * add the necessary BBCLASSEXTEND to the python3-pytest-cov dependencies (recursively) starting with python3-coverage
> 
> Regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
index 1ff3e75cb..3a68011f4 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
@@ -10,5 +10,6 @@  SRC_URI[sha256sum] = "3904b13dfbfec47f003b8e77fd5b589cd11904a21ddf1ab38a64f204d6
 inherit pypi setuptools3
 
 DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS:${PN} += "python3-coverage"
 
 BBCLASSEXTEND = "native nativesdk"