diff mbox series

elfutils: Correct LICENSE line in the recipe

Message ID 20240102164023.3392969-1-William.Lyu@windriver.com
State New
Headers show
Series elfutils: Correct LICENSE line in the recipe | expand

Commit Message

Lyu, William Jan. 2, 2024, 4:40 p.m. UTC
From: William Lyu <William.Lyu@windriver.com>

Correct the LICENSE line in the recipe to match the license information
as described in the upstream website [1]:

"License. The libraries and backends are dual GPLv2+/LGPLv3+. The
utilities are GPLv3+."

[1] https://sourceware.org/elfutils

Signed-off-by: William Lyu <William.Lyu@windriver.com>
---
 meta/recipes-devtools/elfutils/elfutils_0.189.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Jan. 2, 2024, 9:46 p.m. UTC | #1
On Tue, Jan 2, 2024 at 8:40 AM Lyu, William via lists.openembedded.org
<william.lyu=windriver.com@lists.openembedded.org> wrote:
>
> From: William Lyu <William.Lyu@windriver.com>
>
> Correct the LICENSE line in the recipe to match the license information
> as described in the upstream website [1]:
>
> "License. The libraries and backends are dual GPLv2+/LGPLv3+. The
> utilities are GPLv3+."
>
> [1] https://sourceware.org/elfutils
>
> Signed-off-by: William Lyu <William.Lyu@windriver.com>
> ---
>  meta/recipes-devtools/elfutils/elfutils_0.189.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-devtools/elfutils/elfutils_0.189.bb b/meta/recipes-devtools/elfutils/elfutils_0.189.bb
> index 220f747cb9..1bf1c366ae 100644
> --- a/meta/recipes-devtools/elfutils/elfutils_0.189.bb
> +++ b/meta/recipes-devtools/elfutils/elfutils_0.189.bb
> @@ -2,7 +2,7 @@ SUMMARY = "Utilities and libraries for handling compiled object files"
>  HOMEPAGE = "https://sourceware.org/elfutils"
>  DESCRIPTION = "elfutils is a collection of utilities and libraries to read, create and modify ELF binary files, find and handle DWARF debug data, symbols, thread state and stacktraces for processes and core files on GNU/Linux."
>  SECTION = "base"
> -LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-3.0-or-later & GPL-3.0-or-later"
> +LICENSE = "( GPL-2.0-or-later | LGPL-3.0-or-later ) & GPL-3.0-or-later"

Its resulting in
ERROR: elfutils-0.189-r0 do_package_qa: QA Issue: LICENSE:libdw
includes licenses (GPL-2.0-only) that are not listed in LICENSE
[unlisted-pkg-lics]
ERROR: elfutils-0.189-r0 do_package_qa: QA Issue: LICENSE:libelf
includes licenses (GPL-2.0-only) that are not listed in LICENSE
[unlisted-pkg-lics]
ERROR: elfutils-0.189-r0 do_package_qa: QA Issue: LICENSE:libasm
includes licenses (GPL-2.0-only) that are not listed in LICENSE
[unlisted-pkg-lics]
ERROR: elfutils-0.189-r0 do_package_qa: Fatal QA errors were found,
failing task.

because there is setting of LICENSE for individual output packages as
well, which needs to be addressed as well

>  LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
>                      file://debuginfod/debuginfod-client.c;endline=28;md5=f0a7c3170776866ee94e8f9225a6ad79 \
>                      "
> --
> 2.43.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#193244): https://lists.openembedded.org/g/openembedded-core/message/193244
> Mute This Topic: https://lists.openembedded.org/mt/103484710/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Lyu, William Jan. 4, 2024, 6:48 p.m. UTC | #2
>> From: William Lyu <William.Lyu@windriver.com>
>>
>> Correct the LICENSE line in the recipe to match the license information
>> as described in the upstream website [1]:
>>
>> "License. The libraries and backends are dual GPLv2+/LGPLv3+. The
>> utilities are GPLv3+."
>>
>> [1] https://sourceware.org/elfutils
>>
>> Signed-off-by: William Lyu <William.Lyu@windriver.com>
>> ---
>>  meta/recipes-devtools/elfutils/elfutils_0.189.bb | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/meta/recipes-devtools/elfutils/elfutils_0.189.bb b/meta/recipes-devtools/elfutils/elfutils_0.189.bb
>> index 220f747cb9..1bf1c366ae 100644
>> --- a/meta/recipes-devtools/elfutils/elfutils_0.189.bb
>> +++ b/meta/recipes-devtools/elfutils/elfutils_0.189.bb
>> @@ -2,7 +2,7 @@ SUMMARY = "Utilities and libraries for handling compiled object files"
>>  HOMEPAGE = "https://sourceware.org/elfutils"
>>  DESCRIPTION = "elfutils is a collection of utilities and libraries to read, create and modify ELF binary files, find and handle DWARF debug data, symbols, thread state and stacktraces for processes and core files on GNU/Linux."
>>  SECTION = "base"
>> -LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-3.0-or-later & GPL-3.0-or-later"
>> +LICENSE = "( GPL-2.0-or-later | LGPL-3.0-or-later ) & GPL-3.0-or-later"
> 
> Its resulting in
> ERROR: elfutils-0.189-r0 do_package_qa: QA Issue: LICENSE:libdw
> includes licenses (GPL-2.0-only) that are not listed in LICENSE
> [unlisted-pkg-lics]
> ERROR: elfutils-0.189-r0 do_package_qa: QA Issue: LICENSE:libelf
> includes licenses (GPL-2.0-only) that are not listed in LICENSE
> [unlisted-pkg-lics]
> ERROR: elfutils-0.189-r0 do_package_qa: QA Issue: LICENSE:libasm
> includes licenses (GPL-2.0-only) that are not listed in LICENSE
> [unlisted-pkg-lics]
> ERROR: elfutils-0.189-r0 do_package_qa: Fatal QA errors were found,
> failing task.

I will send a new patch to update the licensing information for separately listed pakcage utilities and package libraries.

-- William

> 
> because there is setting of LICENSE for individual output packages as
> well, which needs to be addressed as well
> 
>>  LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
>>                      file://debuginfod/debuginfod-client.c;endline=28;md5=f0a7c3170776866ee94e8f9225a6ad79 \
>>                      "
>> --
>> 2.43.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#193244): https://lists.openembedded.org/g/openembedded-core/message/193244
>> Mute This Topic: https://lists.openembedded.org/mt/103484710/1997914
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/elfutils/elfutils_0.189.bb b/meta/recipes-devtools/elfutils/elfutils_0.189.bb
index 220f747cb9..1bf1c366ae 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.189.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.189.bb
@@ -2,7 +2,7 @@  SUMMARY = "Utilities and libraries for handling compiled object files"
 HOMEPAGE = "https://sourceware.org/elfutils"
 DESCRIPTION = "elfutils is a collection of utilities and libraries to read, create and modify ELF binary files, find and handle DWARF debug data, symbols, thread state and stacktraces for processes and core files on GNU/Linux."
 SECTION = "base"
-LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-3.0-or-later & GPL-3.0-or-later"
+LICENSE = "( GPL-2.0-or-later | LGPL-3.0-or-later ) & GPL-3.0-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
                     file://debuginfod/debuginfod-client.c;endline=28;md5=f0a7c3170776866ee94e8f9225a6ad79 \
                     "