diff mbox series

debugedit: add UPSTREAM_CHECK settings

Message ID 20240102083755.316126-1-Qi.Chen@windriver.com
State New
Headers show
Series debugedit: add UPSTREAM_CHECK settings | expand

Commit Message

ChenQi Jan. 2, 2024, 8:37 a.m. UTC
From: Chen Qi <Qi.Chen@windriver.com>

Add UPSTREAM_CHECK_URI(REGEX) to allow for checking new releases
for debugedit recipe.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 meta/recipes-devtools/debugedit/debugedit_5.0.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Alexander Kanavin Jan. 2, 2024, 4:54 p.m. UTC | #1
The check already works, at least for me it correctly checks both the
top level directory and the 'latest' directory:
...
--2024-01-02 16:51:30--  https://sourceware.org/ftp/debugedit/
...
--2024-01-02 16:51:30--  https://sourceware.org/ftp/debugedit/5.0/
...
INFO: debugedit                 5.0             MATCH           Chen
Qi <Qi.Chen@windriver.com>

What does devtool output for you, without the patch?

Alex

On Tue, 2 Jan 2024 at 09:38, Chen Qi via lists.openembedded.org
<Qi.Chen=windriver.com@lists.openembedded.org> wrote:
>
> From: Chen Qi <Qi.Chen@windriver.com>
>
> Add UPSTREAM_CHECK_URI(REGEX) to allow for checking new releases
> for debugedit recipe.
>
> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
> ---
>  meta/recipes-devtools/debugedit/debugedit_5.0.bb | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/meta/recipes-devtools/debugedit/debugedit_5.0.bb b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
> index 63ad7babd9..3a596f5fea 100644
> --- a/meta/recipes-devtools/debugedit/debugedit_5.0.bb
> +++ b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
> @@ -9,6 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
>                      file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
>                      file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
>
> +UPSTREAM_CHECK_URI = "https://sourceware.org/ftp/debugedit/"
> +UPSTREAM_CHECK_REGEX = "(?P<pver>(\d\.\d))/"
> +
>  SRC_URI = "https://sourceware.org/ftp/debugedit/${PV}/debugedit-${PV}.tar.xz"
>
>  SRC_URI:append:libc-musl = "\
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#193220): https://lists.openembedded.org/g/openembedded-core/message/193220
> Mute This Topic: https://lists.openembedded.org/mt/103478272/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
ChenQi Jan. 3, 2024, 2:47 a.m. UTC | #2
On 1/3/24 00:54, Alexander Kanavin wrote:
> The check already works, at least for me it correctly checks both the
> top level directory and the 'latest' directory:
> ...
> --2024-01-02 16:51:30--  https://sourceware.org/ftp/debugedit/
> ...
> --2024-01-02 16:51:30--  https://sourceware.org/ftp/debugedit/5.0/
> ...
> INFO: debugedit                 5.0             MATCH           Chen
> Qi <Qi.Chen@windriver.com>
>
> What does devtool output for you, without the patch?
>
> Alex

The command and output are as below. Pure poky master. No local patches.

$ devtool check-upgrade-status debugedit
NOTE: Starting bitbake server...
NOTE: Reconnecting to bitbake server...
NOTE: Retrying server connection (#1)... (18:44:43.533538)
Loading cache: 100% 
|###########################################################################################################################| 
Time: 0:00:00
Loaded 1848 entries from dependency cache.
--2024-01-02 18:44:46--  https://sourceware.org/ftp/debugedit/
Resolving sourceware.org (sourceware.org)... 8.43.85.97, 
2620:52:3:1:0:246e:9693:128c
Connecting to sourceware.org (sourceware.org)|8.43.85.97|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2602 (2.5K) [text/html]
Saving to: ‘/tmp/wget-index-e1dsj90e/wget-listing-vrofeac4’


2024-01-02 18:44:46 (330 MB/s) - 
‘/tmp/wget-index-e1dsj90e/wget-listing-vrofeac4’ saved [2602/2602]

--2024-01-02 18:44:46--  https://sourceware.org/ftp/debugedit/5.0/
Resolving sourceware.org (sourceware.org)... 8.43.85.97, 
2620:52:3:1:0:246e:9693:128c
Connecting to sourceware.org (sourceware.org)|8.43.85.97|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1353 (1.3K) [text/html]
Saving to: ‘/tmp/wget-index-qwu98rgj/wget-listing-8esd1gn0’


2024-01-02 18:44:47 (179 MB/s) - 
‘/tmp/wget-index-qwu98rgj/wget-listing-8esd1gn0’ saved [1353/1353]

--2024-01-02 18:44:47-- https://sourceware.org/ftp/debugedit/sha512/
Resolving sourceware.org (sourceware.org)... 8.43.85.97, 
2620:52:3:1:0:246e:9693:128c
Connecting to sourceware.org (sourceware.org)|8.43.85.97|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2024-01-02 18:44:47 ERROR 404: Not Found.


>
> On Tue, 2 Jan 2024 at 09:38, Chen Qi via lists.openembedded.org
> <Qi.Chen=windriver.com@lists.openembedded.org> wrote:
>> From: Chen Qi <Qi.Chen@windriver.com>
>>
>> Add UPSTREAM_CHECK_URI(REGEX) to allow for checking new releases
>> for debugedit recipe.
>>
>> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
>> ---
>>   meta/recipes-devtools/debugedit/debugedit_5.0.bb | 3 +++
>>   1 file changed, 3 insertions(+)
>>
>> diff --git a/meta/recipes-devtools/debugedit/debugedit_5.0.bb b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
>> index 63ad7babd9..3a596f5fea 100644
>> --- a/meta/recipes-devtools/debugedit/debugedit_5.0.bb
>> +++ b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
>> @@ -9,6 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
>>                       file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
>>                       file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
>>
>> +UPSTREAM_CHECK_URI = "https://sourceware.org/ftp/debugedit/"
>> +UPSTREAM_CHECK_REGEX = "(?P<pver>(\d\.\d))/"
>> +
>>   SRC_URI = "https://sourceware.org/ftp/debugedit/${PV}/debugedit-${PV}.tar.xz"
>>
>>   SRC_URI:append:libc-musl = "\
>> --
>> 2.34.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#193220): https://lists.openembedded.org/g/openembedded-core/message/193220
>> Mute This Topic: https://lists.openembedded.org/mt/103478272/1686489
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Alexander Kanavin Jan. 3, 2024, 7:21 a.m. UTC | #3
This works as expected. What made you think it’s broken and needs changing?

Alex

On Wed 3. Jan 2024 at 3.47, ChenQi <Qi.Chen@windriver.com> wrote:

> On 1/3/24 00:54, Alexander Kanavin wrote:
> > The check already works, at least for me it correctly checks both the
> > top level directory and the 'latest' directory:
> > ...
> > --2024-01-02 16:51:30--  https://sourceware.org/ftp/debugedit/
> > ...
> > --2024-01-02 16:51:30--  https://sourceware.org/ftp/debugedit/5.0/
> > ...
> > INFO: debugedit                 5.0             MATCH           Chen
> > Qi <Qi.Chen@windriver.com>
> >
> > What does devtool output for you, without the patch?
> >
> > Alex
>
> The command and output are as below. Pure poky master. No local patches.
>
> $ devtool check-upgrade-status debugedit
> NOTE: Starting bitbake server...
> NOTE: Reconnecting to bitbake server...
> NOTE: Retrying server connection (#1)... (18:44:43.533538)
> Loading cache: 100%
> |###########################################################################################################################|
>
> Time: 0:00:00
> Loaded 1848 entries from dependency cache.
> --2024-01-02 18:44:46--  https://sourceware.org/ftp/debugedit/
> Resolving sourceware.org (sourceware.org)... 8.43.85.97,
> 2620:52:3:1:0:246e:9693:128c
> Connecting to sourceware.org (sourceware.org)|8.43.85.97|:443...
> connected.
> HTTP request sent, awaiting response... 200 OK
> Length: 2602 (2.5K) [text/html]
> Saving to: ‘/tmp/wget-index-e1dsj90e/wget-listing-vrofeac4’
>
>
> 2024-01-02 18:44:46 (330 MB/s) -
> ‘/tmp/wget-index-e1dsj90e/wget-listing-vrofeac4’ saved [2602/2602]
>
> --2024-01-02 18:44:46--  https://sourceware.org/ftp/debugedit/5.0/
> Resolving sourceware.org (sourceware.org)... 8.43.85.97,
> 2620:52:3:1:0:246e:9693:128c
> Connecting to sourceware.org (sourceware.org)|8.43.85.97|:443...
> connected.
> HTTP request sent, awaiting response... 200 OK
> Length: 1353 (1.3K) [text/html]
> Saving to: ‘/tmp/wget-index-qwu98rgj/wget-listing-8esd1gn0’
>
>
> 2024-01-02 18:44:47 (179 MB/s) -
> ‘/tmp/wget-index-qwu98rgj/wget-listing-8esd1gn0’ saved [1353/1353]
>
> --2024-01-02 18:44:47-- https://sourceware.org/ftp/debugedit/sha512/
> Resolving sourceware.org (sourceware.org)... 8.43.85.97,
> 2620:52:3:1:0:246e:9693:128c
> Connecting to sourceware.org (sourceware.org)|8.43.85.97|:443...
> connected.
> HTTP request sent, awaiting response... 404 Not Found
> 2024-01-02 18:44:47 ERROR 404: Not Found.
>
>
> >
> > On Tue, 2 Jan 2024 at 09:38, Chen Qi via lists.openembedded.org
> > <Qi.Chen=windriver.com@lists.openembedded.org> wrote:
> >> From: Chen Qi <Qi.Chen@windriver.com>
> >>
> >> Add UPSTREAM_CHECK_URI(REGEX) to allow for checking new releases
> >> for debugedit recipe.
> >>
> >> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
> >> ---
> >>   meta/recipes-devtools/debugedit/debugedit_5.0.bb | 3 +++
> >>   1 file changed, 3 insertions(+)
> >>
> >> diff --git a/meta/recipes-devtools/debugedit/debugedit_5.0.bb
> b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
> >> index 63ad7babd9..3a596f5fea 100644
> >> --- a/meta/recipes-devtools/debugedit/debugedit_5.0.bb
> >> +++ b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
> >> @@ -9,6 +9,9 @@ LIC_FILES_CHKSUM =
> "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
> >>
>  file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
> >>
>  file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
> >>
> >> +UPSTREAM_CHECK_URI = "https://sourceware.org/ftp/debugedit/"
> >> +UPSTREAM_CHECK_REGEX = "(?P<pver>(\d\.\d))/"
> >> +
> >>   SRC_URI = "
> https://sourceware.org/ftp/debugedit/${PV}/debugedit-${PV}.tar.xz"
> >>
> >>   SRC_URI:append:libc-musl = "\
> >> --
> >> 2.34.1
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#193220):
> https://lists.openembedded.org/g/openembedded-core/message/193220
> >> Mute This Topic: https://lists.openembedded.org/mt/103478272/1686489
> >> Group Owner: openembedded-core+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
>
>
ChenQi Jan. 3, 2024, 7:44 a.m. UTC | #4
On 1/3/24 15:21, Alexander Kanavin via lists.openembedded.org wrote:
> This works as expected. What made you think it’s broken and needs 
> changing?
>
The 404 ERROR that 'devtool check-ugprade-status' prints out to me 
unconditionally, which is all upper case to catch people's notice and 
can't be avoided by any option.


> Alex
>
> On Wed 3. Jan 2024 at 3.47, ChenQi <Qi.Chen@windriver.com> wrote:
>
>     On 1/3/24 00:54, Alexander Kanavin wrote:
>     > The check already works, at least for me it correctly checks
>     both the
>     > top level directory and the 'latest' directory:
>     > ...
>     > --2024-01-02 16:51:30-- https://sourceware.org/ftp/debugedit/
>     > ...
>     > --2024-01-02 16:51:30-- https://sourceware.org/ftp/debugedit/5.0/
>     > ...
>     > INFO: debugedit                 5.0             MATCH          Chen
>     > Qi <Qi.Chen@windriver.com>
>     >
>     > What does devtool output for you, without the patch?
>     >
>     > Alex
>
>     The command and output are as below. Pure poky master. No local
>     patches.
>
>     $ devtool check-upgrade-status debugedit
>     NOTE: Starting bitbake server...
>     NOTE: Reconnecting to bitbake server...
>     NOTE: Retrying server connection (#1)... (18:44:43.533538)
>     Loading cache: 100%
>     |###########################################################################################################################|
>
>     Time: 0:00:00
>     Loaded 1848 entries from dependency cache.
>     --2024-01-02 18:44:46-- https://sourceware.org/ftp/debugedit/
>     Resolving sourceware.org <http://sourceware.org> (sourceware.org
>     <http://sourceware.org>)... 8.43.85.97,
>     2620:52:3:1:0:246e:9693:128c
>     Connecting to sourceware.org <http://sourceware.org>
>     (sourceware.org <http://sourceware.org>)|8.43.85.97|:443... connected.
>     HTTP request sent, awaiting response... 200 OK
>     Length: 2602 (2.5K) [text/html]
>     Saving to: ‘/tmp/wget-index-e1dsj90e/wget-listing-vrofeac4’
>
>
>     2024-01-02 18:44:46 (330 MB/s) -
>     ‘/tmp/wget-index-e1dsj90e/wget-listing-vrofeac4’ saved [2602/2602]
>
>     --2024-01-02 18:44:46-- https://sourceware.org/ftp/debugedit/5.0/
>     Resolving sourceware.org <http://sourceware.org> (sourceware.org
>     <http://sourceware.org>)... 8.43.85.97,
>     2620:52:3:1:0:246e:9693:128c
>     Connecting to sourceware.org <http://sourceware.org>
>     (sourceware.org <http://sourceware.org>)|8.43.85.97|:443... connected.
>     HTTP request sent, awaiting response... 200 OK
>     Length: 1353 (1.3K) [text/html]
>     Saving to: ‘/tmp/wget-index-qwu98rgj/wget-listing-8esd1gn0’
>
>
>     2024-01-02 18:44:47 (179 MB/s) -
>     ‘/tmp/wget-index-qwu98rgj/wget-listing-8esd1gn0’ saved [1353/1353]
>
>     --2024-01-02 18:44:47-- https://sourceware.org/ftp/debugedit/sha512/
>     Resolving sourceware.org <http://sourceware.org> (sourceware.org
>     <http://sourceware.org>)... 8.43.85.97,
>     2620:52:3:1:0:246e:9693:128c
>     Connecting to sourceware.org <http://sourceware.org>
>     (sourceware.org <http://sourceware.org>)|8.43.85.97|:443... connected.
>     HTTP request sent, awaiting response... 404 Not Found
>     2024-01-02 18:44:47 ERROR 404: Not Found.
>
>
>     >
>     > On Tue, 2 Jan 2024 at 09:38, Chen Qi via lists.openembedded.org
>     <http://lists.openembedded.org>
>     > <Qi.Chen=windriver.com@lists.openembedded.org> wrote:
>     >> From: Chen Qi <Qi.Chen@windriver.com>
>     >>
>     >> Add UPSTREAM_CHECK_URI(REGEX) to allow for checking new releases
>     >> for debugedit recipe.
>     >>
>     >> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
>     >> ---
>     >>   meta/recipes-devtools/debugedit/debugedit_5.0.bb
>     <http://debugedit_5.0.bb> | 3 +++
>     >>   1 file changed, 3 insertions(+)
>     >>
>     >> diff --git a/meta/recipes-devtools/debugedit/debugedit_5.0.bb
>     <http://debugedit_5.0.bb>
>     b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
>     <http://debugedit_5.0.bb>
>     >> index 63ad7babd9..3a596f5fea 100644
>     >> --- a/meta/recipes-devtools/debugedit/debugedit_5.0.bb
>     <http://debugedit_5.0.bb>
>     >> +++ b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
>     <http://debugedit_5.0.bb>
>     >> @@ -9,6 +9,9 @@ LIC_FILES_CHKSUM =
>     "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
>     >> file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
>     >> file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
>     >>
>     >> +UPSTREAM_CHECK_URI = "https://sourceware.org/ftp/debugedit/"
>     >> +UPSTREAM_CHECK_REGEX = "(?P<pver>(\d\.\d))/"
>     >> +
>     >>   SRC_URI =
>     "https://sourceware.org/ftp/debugedit/${PV}/debugedit-${PV}.tar.xz
>     <https://sourceware.org/ftp/debugedit/$%7BPV%7D/debugedit-$%7BPV%7D.tar.xz>"
>     >>
>     >>   SRC_URI:append:libc-musl = "\
>     >> --
>     >> 2.34.1
>     >>
>     >>
>     >>
>     >>
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#193272):https://lists.openembedded.org/g/openembedded-core/message/193272
> Mute This Topic:https://lists.openembedded.org/mt/103478272/3618072
> Group Owner:openembedded-core+owner@lists.openembedded.org
> Unsubscribe:https://lists.openembedded.org/g/openembedded-core/unsub  [Qi.Chen@windriver.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin Jan. 3, 2024, 8:28 a.m. UTC | #5
On Wed, 3 Jan 2024 at 08:45, Chen Qi via lists.openembedded.org
<Qi.Chen=windriver.com@lists.openembedded.org> wrote:
>
> On 1/3/24 15:21, Alexander Kanavin via lists.openembedded.org wrote:
>
> This works as expected. What made you think it’s broken and needs changing?
>
> The 404 ERROR that 'devtool check-ugprade-status' prints out to me unconditionally, which is all upper case to catch people's notice and can't be avoided by any option.

The version check detects if the tarball is in a versioned directory,
and if so, it goes one level up, and tries to list all subdirectories
from there, attempting to find a newer tarball. So the real issue is,
why is it trying to go into a non-existent 'sha512' directory? There's
a sha512.sum file in here:
https://sourceware.org/ftp/debugedit/
but it's a file.

If this patch is applied, on the other hand, it would only check the
names of those versioned directories, and not the actual tarballs.
Which could produce bogus results if for example 5.0/ directory would
contain 5.0.0, 5.0.1, etc tarballs.

It would also help to suppress the noisy output from wget altogether
by default, but last time I looked into it, it turned into invasive
changes at the heart of bitbake logging, so I abandoned the attempt.

Alex
ChenQi Jan. 3, 2024, 9:14 a.m. UTC | #6
On 1/3/24 16:28, Alexander Kanavin wrote:
> On Wed, 3 Jan 2024 at 08:45, Chen Qi via lists.openembedded.org
> <Qi.Chen=windriver.com@lists.openembedded.org> wrote:
>> On 1/3/24 15:21, Alexander Kanavin via lists.openembedded.org wrote:
>>
>> This works as expected. What made you think it’s broken and needs changing?
>>
>> The 404 ERROR that 'devtool check-ugprade-status' prints out to me unconditionally, which is all upper case to catch people's notice and can't be avoided by any option.
> The version check detects if the tarball is in a versioned directory,
> and if so, it goes one level up, and tries to list all subdirectories
> from there, attempting to find a newer tarball. So the real issue is,
> why is it trying to go into a non-existent 'sha512' directory? There's
> a sha512.sum file in here:
> https://sourceware.org/ftp/debugedit/
> but it's a file.
>
> If this patch is applied, on the other hand, it would only check the
> names of those versioned directories, and not the actual tarballs.
> Which could produce bogus results if for example 5.0/ directory would
> contain 5.0.0, 5.0.1, etc tarballs.
Sounds reasonable.
>
> It would also help to suppress the noisy output from wget altogether
> by default, but last time I looked into it, it turned into invasive
> changes at the heart of bitbake logging, so I abandoned the attempt.
>
> Alex

Thanks for the info.

Regards,

Qi
diff mbox series

Patch

diff --git a/meta/recipes-devtools/debugedit/debugedit_5.0.bb b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
index 63ad7babd9..3a596f5fea 100644
--- a/meta/recipes-devtools/debugedit/debugedit_5.0.bb
+++ b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
@@ -9,6 +9,9 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
                     file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
                     file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
 
+UPSTREAM_CHECK_URI = "https://sourceware.org/ftp/debugedit/"
+UPSTREAM_CHECK_REGEX = "(?P<pver>(\d\.\d))/"
+
 SRC_URI = "https://sourceware.org/ftp/debugedit/${PV}/debugedit-${PV}.tar.xz"
 
 SRC_URI:append:libc-musl = "\