diff mbox series

[meta-python] python3-flask: upgrade 2.3.3 -> 3.0.0

Message ID 1704179295-8140-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-flask: upgrade 2.3.3 -> 3.0.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 2, 2024, 7:08 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Remove previously deprecated code.
-Deprecate the __version__ attribute. Use feature detection,
 or importlib.metadata.version("flask"), instead.
-Restructure the code such that the Flask (app) and Blueprint classes have
 Sans-IO bases.
-Allow self as an argument to url_for.
-Require Werkzeug >= 3.0.0.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-flask_2.3.3.bb => python3-flask_3.0.0.bb}   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-flask_2.3.3.bb => python3-flask_3.0.0.bb} (89%)

Comments

Khem Raj Jan. 8, 2024, 2:46 a.m. UTC | #1
On Tue, 02 Jan 2024 15:08:15 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ============
> -Remove previously deprecated code.
> -Deprecate the __version__ attribute. Use feature detection,
>  or importlib.metadata.version("flask"), instead.
> -Restructure the code such that the Flask (app) and Blueprint classes have
>  Sans-IO bases.
> -Allow self as an argument to url_for.
> -Require Werkzeug >= 3.0.0.
> 
> [...]

Applied, thanks!

[1/1] python3-flask: upgrade 2.3.3 -> 3.0.0
      commit: a50b58f6268dc20cccf78f2586dccbb11f907ce7

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-flask_2.3.3.bb b/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-flask_2.3.3.bb
rename to meta-python/recipes-devtools/python/python3-flask_3.0.0.bb
index 99a61f136..e0afd3718 100644
--- a/meta-python/recipes-devtools/python/python3-flask_2.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb
@@ -6,7 +6,7 @@  HOMEPAGE = "https://github.com/mitsuhiko/flask/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
 
-SRC_URI[sha256sum] = "09c347a92aa7ff4a8e7f3206795f30d826654baf38b873d0744cd571ca609efc"
+SRC_URI[sha256sum] = "cfadcdb638b609361d29ec22360d6070a77d7463dcb3ab08d2c2f2f168845f58"
 
 UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Flask"
 UPSTREAM_CHECK_REGEX = "/Flask/(?P<pver>(\d+[\.\-_]*)+)"