diff mbox series

[v3,02/10] devtool: selftest: Fix test_devtool_modify_git_crates_subpath bbappend check

Message ID 20231228145917.18147-3-alex.kiernan@gmail.com
State Accepted, archived
Commit f14ce354890024a3a0a3d4c7efa53eab5db7a6b1
Headers show
Series Stepwise rust upgrade 1.71.1 -> 1.74.1 | expand

Commit Message

Alex Kiernan Dec. 28, 2023, 2:59 p.m. UTC
The recipe being tested is in `testrecipe`, use that rather than the
literal `zvariant`.

Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---

(no changes since v1)

 meta/lib/oeqa/selftest/cases/devtool.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/lib/oeqa/selftest/cases/devtool.py b/meta/lib/oeqa/selftest/cases/devtool.py
index d733dd158106..cc28731402e7 100644
--- a/meta/lib/oeqa/selftest/cases/devtool.py
+++ b/meta/lib/oeqa/selftest/cases/devtool.py
@@ -958,7 +958,7 @@  class DevtoolModifyTests(DevtoolBase):
         result = runCmd('devtool modify %s -x %s' % (testrecipe, tempdir))
         self.assertExists(os.path.join(tempdir, 'Cargo.toml'), 'Extracted source could not be found')
         self.assertExists(os.path.join(self.workspacedir, 'conf', 'layer.conf'), 'Workspace directory not created. devtool output: %s' % result.output)
-        matches = glob.glob(os.path.join(self.workspacedir, 'appends', 'zvariant_*.bbappend'))
+        matches = glob.glob(os.path.join(self.workspacedir, 'appends', '%s_*.bbappend' % testrecipe))
         self.assertTrue(matches, 'bbappend not created')
         # Test devtool status
         result = runCmd('devtool status')