diff mbox series

[meta-oe] c-ares: Move to tarballs, add ptest and static support

Message ID 20231220200805.27842-1-alex.kiernan@gmail.com
State Superseded
Headers show
Series [meta-oe] c-ares: Move to tarballs, add ptest and static support | expand

Commit Message

Alex Kiernan Dec. 20, 2023, 8:08 p.m. UTC
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---

 .../recipes-support/c-ares/c-ares/run-ptest   |  7 +++++++
 .../recipes-support/c-ares/c-ares_1.24.0.bb   | 19 ++++++++++++++-----
 2 files changed, 21 insertions(+), 5 deletions(-)
 create mode 100644 meta-oe/recipes-support/c-ares/c-ares/run-ptest

Comments

Khem Raj Dec. 20, 2023, 8:39 p.m. UTC | #1
On Wed, Dec 20, 2023 at 12:08 PM Alex Kiernan <alex.kiernan@gmail.com> wrote:
>
> Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
> ---
>
>  .../recipes-support/c-ares/c-ares/run-ptest   |  7 +++++++
>  .../recipes-support/c-ares/c-ares_1.24.0.bb   | 19 ++++++++++++++-----
>  2 files changed, 21 insertions(+), 5 deletions(-)
>  create mode 100644 meta-oe/recipes-support/c-ares/c-ares/run-ptest
>
> diff --git a/meta-oe/recipes-support/c-ares/c-ares/run-ptest b/meta-oe/recipes-support/c-ares/c-ares/run-ptest
> new file mode 100644
> index 000000000000..ec115a535217
> --- /dev/null
> +++ b/meta-oe/recipes-support/c-ares/c-ares/run-ptest
> @@ -0,0 +1,7 @@
> +#!/bin/sh
> +
> +if /usr/lib/c-ares/ptest/arestest; then

hardcoding /usr/lib might not work in all cases e.g. where baselib is
lib64 e.g. perhaps on ppc64 or multilib x86_64

> +       echo "PASS: c-ares"
> +else
> +       echo "FAIL: c-ares"
> +fi
> diff --git a/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb b/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
> index 2171002aa95e..3b3b2b83febc 100644
> --- a/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
> +++ b/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
> @@ -5,14 +5,23 @@ SECTION = "libs"
>  LICENSE = "MIT"
>  LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fdbc58a6da11a9f68aa73c453818decc"
>
> -SRC_URI = "git://github.com/c-ares/c-ares.git;branch=main;protocol=https"
> -SRCREV = "972f456f2808b4e4b1730c90ab506f6af5f4c725"
> +SRC_URI = "https://c-ares.org/download/c-ares-1.24.0.tar.gz \
> +           file://run-ptest"
> +SRC_URI[sha256sum] = "c517de6d5ac9cd55a9b72c1541c3e25b84588421817b5f092850ac09a8df5103"
>
> -UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"
> +PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
> +PACKAGECONFIG[manpages] = ""
> +PACKAGECONFIG[tests] = "-DCARES_BUILD_TESTS=ON,-DCARES_BUILD_TESTS=OFF,googletest"
>
> -S = "${WORKDIR}/git"
> +inherit cmake manpages pkgconfig ptest
>
> -inherit cmake pkgconfig
> +EXTRA_OECMAKE = "-DCARES_STATIC=${@ 'ON' if d.getVar('DISABLE_STATIC') == '' else 'OFF' }"
> +
> +do_install_ptest () {
> +       install -d ${D}${PTEST_PATH}
> +       install -m 0755 ${B}/bin/arestest ${D}${PTEST_PATH}
> +       install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}
> +}
>
>  PACKAGE_BEFORE_PN = "${PN}-utils"
>
> --
> 2.39.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107667): https://lists.openembedded.org/g/openembedded-devel/message/107667
> Mute This Topic: https://lists.openembedded.org/mt/103288008/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alex Kiernan Dec. 20, 2023, 8:42 p.m. UTC | #2
On Wed, Dec 20, 2023 at 8:40 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Wed, Dec 20, 2023 at 12:08 PM Alex Kiernan <alex.kiernan@gmail.com> wrote:
> >
> > Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
> > ---
> >
> >  .../recipes-support/c-ares/c-ares/run-ptest   |  7 +++++++
> >  .../recipes-support/c-ares/c-ares_1.24.0.bb   | 19 ++++++++++++++-----
> >  2 files changed, 21 insertions(+), 5 deletions(-)
> >  create mode 100644 meta-oe/recipes-support/c-ares/c-ares/run-ptest
> >
> > diff --git a/meta-oe/recipes-support/c-ares/c-ares/run-ptest b/meta-oe/recipes-support/c-ares/c-ares/run-ptest
> > new file mode 100644
> > index 000000000000..ec115a535217
> > --- /dev/null
> > +++ b/meta-oe/recipes-support/c-ares/c-ares/run-ptest
> > @@ -0,0 +1,7 @@
> > +#!/bin/sh
> > +
> > +if /usr/lib/c-ares/ptest/arestest; then
>
> hardcoding /usr/lib might not work in all cases e.g. where baselib is
> lib64 e.g. perhaps on ppc64 or multilib x86_64
>

I stupidly copied it from another recipe... I even thought that at the
time and then completely forgot :|

> > +       echo "PASS: c-ares"
> > +else
> > +       echo "FAIL: c-ares"
> > +fi
> > diff --git a/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb b/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
> > index 2171002aa95e..3b3b2b83febc 100644
> > --- a/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
> > +++ b/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
> > @@ -5,14 +5,23 @@ SECTION = "libs"
> >  LICENSE = "MIT"
> >  LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fdbc58a6da11a9f68aa73c453818decc"
> >
> > -SRC_URI = "git://github.com/c-ares/c-ares.git;branch=main;protocol=https"
> > -SRCREV = "972f456f2808b4e4b1730c90ab506f6af5f4c725"
> > +SRC_URI = "https://c-ares.org/download/c-ares-1.24.0.tar.gz \
> > +           file://run-ptest"
> > +SRC_URI[sha256sum] = "c517de6d5ac9cd55a9b72c1541c3e25b84588421817b5f092850ac09a8df5103"
> >
> > -UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"
> > +PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
> > +PACKAGECONFIG[manpages] = ""
> > +PACKAGECONFIG[tests] = "-DCARES_BUILD_TESTS=ON,-DCARES_BUILD_TESTS=OFF,googletest"
> >
> > -S = "${WORKDIR}/git"
> > +inherit cmake manpages pkgconfig ptest
> >
> > -inherit cmake pkgconfig
> > +EXTRA_OECMAKE = "-DCARES_STATIC=${@ 'ON' if d.getVar('DISABLE_STATIC') == '' else 'OFF' }"
> > +
> > +do_install_ptest () {
> > +       install -d ${D}${PTEST_PATH}
> > +       install -m 0755 ${B}/bin/arestest ${D}${PTEST_PATH}
> > +       install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}
> > +}
> >
> >  PACKAGE_BEFORE_PN = "${PN}-utils"
> >
> > --
> > 2.39.0
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#107667): https://lists.openembedded.org/g/openembedded-devel/message/107667
> > Mute This Topic: https://lists.openembedded.org/mt/103288008/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/c-ares/c-ares/run-ptest b/meta-oe/recipes-support/c-ares/c-ares/run-ptest
new file mode 100644
index 000000000000..ec115a535217
--- /dev/null
+++ b/meta-oe/recipes-support/c-ares/c-ares/run-ptest
@@ -0,0 +1,7 @@ 
+#!/bin/sh
+
+if /usr/lib/c-ares/ptest/arestest; then
+	echo "PASS: c-ares"
+else
+	echo "FAIL: c-ares"
+fi
diff --git a/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb b/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
index 2171002aa95e..3b3b2b83febc 100644
--- a/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
+++ b/meta-oe/recipes-support/c-ares/c-ares_1.24.0.bb
@@ -5,14 +5,23 @@  SECTION = "libs"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fdbc58a6da11a9f68aa73c453818decc"
 
-SRC_URI = "git://github.com/c-ares/c-ares.git;branch=main;protocol=https"
-SRCREV = "972f456f2808b4e4b1730c90ab506f6af5f4c725"
+SRC_URI = "https://c-ares.org/download/c-ares-1.24.0.tar.gz \
+           file://run-ptest"
+SRC_URI[sha256sum] = "c517de6d5ac9cd55a9b72c1541c3e25b84588421817b5f092850ac09a8df5103"
 
-UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"
+PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
+PACKAGECONFIG[manpages] = ""
+PACKAGECONFIG[tests] = "-DCARES_BUILD_TESTS=ON,-DCARES_BUILD_TESTS=OFF,googletest"
 
-S = "${WORKDIR}/git"
+inherit cmake manpages pkgconfig ptest
 
-inherit cmake pkgconfig
+EXTRA_OECMAKE = "-DCARES_STATIC=${@ 'ON' if d.getVar('DISABLE_STATIC') == '' else 'OFF' }"
+
+do_install_ptest () {
+	install -d ${D}${PTEST_PATH}
+	install -m 0755 ${B}/bin/arestest ${D}${PTEST_PATH}
+	install -m 0755 ${WORKDIR}/run-ptest ${D}${PTEST_PATH}
+}
 
 PACKAGE_BEFORE_PN = "${PN}-utils"