diff mbox series

orangepi-5-plus: Support Orange Pi 5 Plus single-board computer

Message ID 20231219114713.3883-1-abhisit.dev@gmail.com
State New
Headers show
Series orangepi-5-plus: Support Orange Pi 5 Plus single-board computer | expand

Commit Message

Abhisit Sangjan Dec. 19, 2023, 11:47 a.m. UTC
From: Abhisit Sangjan <abhisit.sangjan@gmail.com>

Being merged when the u-boot version is 2024.01-rc5 or newer and the Linux Kernel version is 6.7 or newer

Orange Pi 5 Plus is RK3588 based SBC featuring:
- 2x 2.5G ethernet ports – onboard NIC hooked to PCIe 2.0 interface
- 2x USB 2.0 host ports
- 2x USB 3.0 host ports (exposed over USB 3.0 hub)
- Type-C port featuring USB 2.0/3.0 and Alt-DP mode
- PCIe 2.0/USB 2.0/I2S/I2C/UART on E.KEY socket
- RTC
- ES8388 on-board sound codec – jack in/out, onboard mic, speaker amplifier
- SPI NOR flash
- RGB LED (R is always on)
- IR receiver
- PCIe 3.0 on the bottom for NVMe, etc.
- 40pin GPIO header (with gpio, I2C, SPI, PWM, UART)
- Power, recovery and Mask ROM buttons
- 2x HDMI out, 1x HDMI in
- Slots/connectors for eMMC, uSD card, fan, MIPI CSI/DSI
- 4 GB, 8 GB, 16 GB and 32 GB of RAM

Signed-off-by: Abhisit Sangjan <abhisit.sangjan@gmail.com>
---
 README                                        |  1 +
 conf/machine/orangepi-5-plus.conf             | 12 ++++++++++++
 recipes-bsp/rkbin/rockchip-rkbin_git.bb       |  2 +-
 recipes-kernel/linux/linux-yocto-dev.bbappend |  3 +++
 4 files changed, 17 insertions(+), 1 deletion(-)
 create mode 100644 conf/machine/orangepi-5-plus.conf

--
2.43.0

Comments

Abhisit Sangjan Dec. 19, 2023, 12:04 p.m. UTC | #1
Please ignore this patch and take this one instead [meta-rockchip] [PATCH v2 1/1] orangepi-5-plus: Support Orange Pi 5 Plus single-board computer. ( https://lists.yoctoproject.org/g/yocto/topics?p=recentpostdate,,,20,2,0,0#:~:text=%5Bmeta%2Drockchip%5D%20%5BPATCH%20v2%201/1%5D%20orangepi%2D5%2Dplus%3A%20Support%20Orange%20Pi%205%20Plus%20single%2Dboard%20computer )
diff mbox series

Patch

diff --git a/README b/README
index e5beaa0..c006cd9 100644
--- a/README
+++ b/README
@@ -34,6 +34,7 @@  Status of supported boards:
 		nanopi-r2s
 		nanopi-m4b
 		rock-pi-s
+		orangepi-5-plus
 	builds:
 		marsboard-rk3066
 		radxarock
diff --git a/conf/machine/orangepi-5-plus.conf b/conf/machine/orangepi-5-plus.conf
new file mode 100644
index 0000000..5e814e6
--- /dev/null
+++ b/conf/machine/orangepi-5-plus.conf
@@ -0,0 +1,12 @@ 
+#@TYPE: Machine
+#@NAME: Orange Pi 5 Plus
+#@DESCRIPTION: It is the 5th generation of single-board computer designed by Kunlong Co.,Limited.
+#http://www.orangepi.org/html/hardWare/computerAndMicrocontrollers/details/Orange-Pi-5-plus-32GB.html
+
+require conf/machine/include/rk3588.inc
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-dev"
+KERNEL_DEVICETREE = "rockchip/rk3588-orangepi-5-plus.dtb"
+MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
+
+UBOOT_MACHINE = "orangepi-5-plus-rk3588_defconfig"
diff --git a/recipes-bsp/rkbin/rockchip-rkbin_git.bb b/recipes-bsp/rkbin/rockchip-rkbin_git.bb
index f1609c7..b6642ce 100644
--- a/recipes-bsp/rkbin/rockchip-rkbin_git.bb
+++ b/recipes-bsp/rkbin/rockchip-rkbin_git.bb
@@ -14,7 +14,7 @@  S = "${WORKDIR}/git"

 COMPATIBLE_MACHINE = "^$"
 COMPATIBLE_MACHINE:rk3308 = "rk3308"
-COMPATIBLE_MACHINE:rk3588s = "rk3588s"
+COMPATIBLE_MACHINE:rk3588s = "rk3588s|rk3588"

 PACKAGE_ARCH = "${MACHINE_ARCH}"

diff --git a/recipes-kernel/linux/linux-yocto-dev.bbappend b/recipes-kernel/linux/linux-yocto-dev.bbappend
index 419ebc1..d98a107 100644
--- a/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,3 +1,6 @@ 
 FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
 COMPATIBLE_MACHINE:rock-5b = "rock-5b"
 SRC_URI:append:rock-5b = " file://rockchip-kmeta;type=kmeta;name=rockchip-kmeta;destsuffix=rockchip-kmeta"
+
+COMPATIBLE_MACHINE:orangepi-5-plus = "orangepi-5-plus"
+SRC_URI:append:orangepi-5-plus = " file://rockchip-kmeta;type=kmeta;name=rockchip-kmeta;destsuffix=rockchip-kmeta"