diff mbox series

libinput: Add packageconfig for tests

Message ID 20231218222348.4174140-1-JPEWhacker@gmail.com
State Accepted, archived
Commit d15b482a5858612c8c88c739b51de579945d7cb2
Headers show
Series libinput: Add packageconfig for tests | expand

Commit Message

Joshua Watt Dec. 18, 2023, 10:23 p.m. UTC
Add packageconfig to control if tests are installed or not. Doing this
allows the libcheck dependency to be optional. The packageconfig
defaults to having tests enabled when PTEST_ENABLED == 1 to match the
previous behavior

Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
---
 meta/recipes-graphics/wayland/libinput_1.24.0.bb | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-graphics/wayland/libinput_1.24.0.bb b/meta/recipes-graphics/wayland/libinput_1.24.0.bb
index 49a1da2b22c..26ab1adaea0 100644
--- a/meta/recipes-graphics/wayland/libinput_1.24.0.bb
+++ b/meta/recipes-graphics/wayland/libinput_1.24.0.bb
@@ -10,7 +10,7 @@  SECTION = "libs"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a"
 
-DEPENDS = "libevdev udev mtdev libcheck"
+DEPENDS = "libevdev udev mtdev"
 
 SRC_URI = "git://gitlab.freedesktop.org/libinput/libinput.git;protocol=https;branch=main \
            file://run-ptest \
@@ -30,15 +30,15 @@  do_configure:append() {
     fi
 }
 
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
 PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
 PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
+PACKAGECONFIG[tests] = "-Dtests=true -Dinstall-tests=true,-Dtests=false -Dinstall-tests=false,libcheck"
 
 UDEVDIR = "`pkg-config --variable=udevdir udev`"
 
 EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
                   -Ddocumentation=false \
-                  ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \
                   -Dzshcompletiondir=no"
 
 # package name changed in 1.8.1 upgrade: make sure package upgrades work