diff mbox series

[meta-python] python3-websocket-client: upgrade 1.6.4 -> 1.7.0

Message ID 1702600158-1901-1-git-send-email-wangmy@fujitsu.com
State Accepted
Headers show
Series [meta-python] python3-websocket-client: upgrade 1.6.4 -> 1.7.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 15, 2023, 12:29 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
- Renamed 'mask' variable in ABNF to prevent name collision with 'mask()' function
- Fixed old http import of HTTPStatus in _handshake.py
- Add 'send_text()' and 'send_bytes()' to _app.py
- Improved typehint support
- General readability improvements, made all string concatenations use f-strings
- Applied black formatting style to code

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...socket-client_1.6.4.bb => python3-websocket-client_1.7.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-websocket-client_1.6.4.bb => python3-websocket-client_1.7.0.bb} (84%)

Comments

Khem Raj Dec. 19, 2023, 6:27 a.m. UTC | #1
On Fri, 15 Dec 2023 08:29:18 +0800, wangmy@fujitsu.com wrote:
> Changelog:
> ===========
> - Renamed 'mask' variable in ABNF to prevent name collision with 'mask()' function
> - Fixed old http import of HTTPStatus in _handshake.py
> - Add 'send_text()' and 'send_bytes()' to _app.py
> - Improved typehint support
> - General readability improvements, made all string concatenations use f-strings
> - Applied black formatting style to code
> 
> [...]

Applied, thanks!

[1/1] python3-websocket-client: upgrade 1.6.4 -> 1.7.0
      commit: 3723fd45fa9d3c95446375136af657a929c963a0

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-websocket-client_1.6.4.bb b/meta-python/recipes-devtools/python/python3-websocket-client_1.7.0.bb
similarity index 84%
rename from meta-python/recipes-devtools/python/python3-websocket-client_1.6.4.bb
rename to meta-python/recipes-devtools/python/python3-websocket-client_1.7.0.bb
index 961cdb916..b202d6855 100644
--- a/meta-python/recipes-devtools/python/python3-websocket-client_1.6.4.bb
+++ b/meta-python/recipes-devtools/python/python3-websocket-client_1.7.0.bb
@@ -7,7 +7,7 @@  HOMEPAGE = "https://github.com/websocket-client/websocket-client"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=6eae3bb7247ccb2c3a087ea8de759c01"
 
-SRC_URI[sha256sum] = "b3324019b3c28572086c4a319f91d1dcd44e6e11cd340232978c684a7650d0df"
+SRC_URI[sha256sum] = "10e511ea3a8c744631d3bd77e61eb17ed09304c413ad42cf6ddfa4c7787e8fe6"
 
 inherit pypi setuptools3