diff mbox series

[PATCHv2,2/4] python3-qemu-qmp: Add recipe

Message ID e7c107503fb1a3cb60b8f91b1150099f8377ca86.1702499299.git.pidge@baylibre.com
State New
Headers show
Series Proof of concept for screenshot testcases | expand

Commit Message

Eilís 'pidge' Ní Fhlannagáin Dec. 13, 2023, 8:30 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

Add a recipe for python QEMU Monitor Protocol. This will be needed for
qemu screendumps for qemu screendump testing.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Eilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com>
---
 .../python/python3-qemu-qmp_0.0.2.bb               | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb

Comments

Richard Purdie Dec. 13, 2023, 9 p.m. UTC | #1
On Wed, 2023-12-13 at 20:30 +0000, Eilís 'pidge' Ní Fhlannagáin wrote:
> From: Ross Burton <ross.burton@arm.com>
> 
> Add a recipe for python QEMU Monitor Protocol. This will be needed for
> qemu screendumps for qemu screendump testing.
> 
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> Signed-off-by: Eilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com>
> ---
>  .../python/python3-qemu-qmp_0.0.2.bb               | 14 ++++++++++++++
>  1 file changed, 14 insertions(+)
>  create mode 100644 meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> 
> diff --git a/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> new file mode 100644
> index 00000000000..faa0cc69738
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> @@ -0,0 +1,14 @@
> +SUMMARY = "asyncio library for communicating with QEMU Monitor Protocol (QMP) servers"
> +LICENSE = "LGPLv2+ & GPLv2"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=4cf66a4984120007c9881cc871cf49db \
> +                    file://LICENSE_GPL2;md5=441c28d2cf86e15a37fa47e15a72fbac"
> +
> +SRC_URI[sha256sum] = "c918e9e3ae09abdf70c7ece67637a93ac4583d940bbf48d24ff77987f74f1b8b"
> +
> +inherit pypi python_setuptools_build_meta
> +
> +PYPI_PACKAGE = "qemu.qmp"
> +
> +DEPENDS += "python3-setuptools-scm-native"
> +
> +BBCLASSEXTEND = "native nativesdk"

None of the errors Alexandre reported originally from the autobuilder
have been fixed here :(

(HOMEPAGE, missing maintainer entry and so on)

Also, I'm not sure what qmp is doing on the target with this recipe?
Does qmp trigger remote command execution inside the guest? I'd
previously assumed the framedump was from the external presentation
rather than internal to the guest.

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
new file mode 100644
index 00000000000..faa0cc69738
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "asyncio library for communicating with QEMU Monitor Protocol (QMP) servers"
+LICENSE = "LGPLv2+ & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4cf66a4984120007c9881cc871cf49db \
+                    file://LICENSE_GPL2;md5=441c28d2cf86e15a37fa47e15a72fbac"
+
+SRC_URI[sha256sum] = "c918e9e3ae09abdf70c7ece67637a93ac4583d940bbf48d24ff77987f74f1b8b"
+
+inherit pypi python_setuptools_build_meta
+
+PYPI_PACKAGE = "qemu.qmp"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"