Patchwork [1/1] conf/tune: add tune-ppce300c3

login
register
mail settings
Submitter Bruce Ashfield
Date Sept. 7, 2012, 3:48 a.m.
Message ID <CADkTA4MK=YEBvA__7VMBvu-+um6FucHX_T9tD1ptfLF6EQ9+2Q@mail.gmail.com>
Download mbox | patch
Permalink /patch/36093/
State New
Headers show

Comments

Bruce Ashfield - Sept. 7, 2012, 3:48 a.m.
On Thu, Sep 6, 2012 at 7:32 PM, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
> On Thu, 2012-09-06 at 18:07 -0500, Mark Hatle wrote:
>> On 9/6/12 5:59 PM, Richard Purdie wrote:
>> > On Thu, 2012-09-06 at 17:35 -0500, Mark Hatle wrote:
>> >> On 9/6/12 5:20 PM, Bruce Ashfield wrote:
>> >>> On 12-09-06 6:19 PM, Richard Purdie wrote:
>> >>>> On Thu, 2012-09-06 at 14:43 -0400, Bruce Ashfield wrote:
>> >>>>> It has been pointed out several times that the yocto mpc8315e-rdb
>> >>>>> reference was using the wrong tuning (603e), since it is actually

<snip>

>> >> The problem is actually in the flac.  This recipe sees powerpc as the machine
>> >> type, and immediately enabled altivec.  By default altivec support is disabled
>> >> in OE-Core.
>> >>
>> >> Perhaps one way we could address this is add a tune flag that says if the tune
>> >> has altivec support or not.. then in the flac binary, disable it unless it's
>> >> enabled?
>> >
>> > I think having altivec in the tune_features would be ideal. I'd love to
>> > get this cleaned up too but I lack much knowledge about powerpc...
>>
>> My proposal then would be to accept Bruce's patch, with the understanding that
>> we need to add a tune flag of 'altivec' to the PowerPC tunings (where
>> appropriate) and then make the flac recipe respect that flag.
>>
>> Unfortunately I don't have the time to do that right now or I would.  Would an
>> enhancement bug in the Yocto Project bugzilla be enough to be sure the work is done?
>
> Please send something machine specific. Adding DEFAULTTUNE is a bad idea
> for several reasons, not least it might not be the selected tune.

Same branch (contrib zedd/ppc-tune), now has:


Everything else is the same.

Let me know if you want a full resend of the patch.

Cheers,

Bruce

>
> I took Matthew's original patch on the understanding this gets fixed and
> it hasn't happened but please do file the request.
>
> Cheers,
>
> Richard
>
>
>
>
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core

Patch

--- a/meta/recipes-multimedia/flac/flac_1.2.1.bb
+++ b/meta/recipes-multimedia/flac/flac_1.2.1.bb
@@ -39,6 +39,7 @@  EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
 EXTRA_OECONF_prepend_e500mc = "--disable-altivec "
 EXTRA_OECONF_prepend_e5500 = "--disable-altivec "
 EXTRA_OECONF_prepend_e5500-64b = "--disable-altivec "
+EXTRA_OECONF_prepend_mpc8315e-rdb = "--disable-altivec "

 PACKAGES += "libflac libflac++ liboggflac liboggflac++"
 FILES_${PN} = "${bindir}/*"