diff mbox series

[meta-multimedia,2/2] rygel: add x11 to DISTRO_FEATURES

Message ID 20231212125742.2494501-2-martin.jansa@gmail.com
State Accepted
Headers show
Series [meta-multimedia,1/2] rygel: fix build with gtk+3 PACKAGECONFIG disabled | expand

Commit Message

Martin Jansa Dec. 12, 2023, 12:57 p.m. UTC
* it was added in rygel-0.41.0 with:
  https://github.com/GNOME/rygel/commit/18cd2cff6f64b7a54156ac97e5c4f50eb8fd8d67

* it might need libx11 dependency as well which would probably
  be pulled by gtk+3 already when x11 is in DISTRO_FEATURES

* as shown in:
  http://errors.yoctoproject.org/Errors/Details/746017/
  it requires x11 even when gtk support is disabled, meson-log.txt:

Determining dependency 'x11' with pkg-config executable '/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot-native/usr/bin/pkg-config'
env[PKG_CONFIG_DIR]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot/usr/lib/pkgconfig
env[PKG_CONFIG_PATH]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot/usr/lib/pkgconfig:/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot/usr/share/pkgconfig
env[PKG_CONFIG_LIBDIR]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot/usr/lib/pkgconfig
env[PKG_CONFIG_DISABLE_UNINSTALLED]: yes
env[PKG_CONFIG_SYSROOT_DIR]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot
env[PKG_CONFIG_SYSTEM_LIBRARY_PATH]: /usr/lib:/usr/lib
env[PKG_CONFIG_SYSTEM_INCLUDE_PATH]: /usr/include
env[PKG_CONFIG]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot-native/usr/bin/pkg-config
-----------
Called: `/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot-native/usr/bin/pkg-config --modversion x11` -> 1
stderr:
Package x11 was not found in the pkg-config search path.
Perhaps you should add the directory containing `x11.pc'
to the PKG_CONFIG_PATH environment variable
No package 'x11' found
-----------
CMake binary for host machine is cached as not found
Dependency lookup for x11 with method 'cmake' failed: CMake binary for machine host machine not found. Giving up.
Run-time dependency x11 found: NO (tried pkgconfig)

../rygel-0.42.4/src/rygel/meson.build:9:80: ERROR: Dependency "x11" not found, tried pkgconfig

Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
---
 meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb      | 2 +-
 .../packagegroups/packagegroup-meta-multimedia.bb               | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
index 5212e78333..4fbdce0867 100644
--- a/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
+++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
@@ -18,7 +18,7 @@  RRECOMMENDS:${PN} = "rygel-plugin-media-export"
 inherit gnomebase features_check vala gobject-introspection gettext systemd
 
 # gobject-introspection is mandatory for libmediaart-2.0 and cannot be configured
-REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data x11"
 
 SRC_URI[archive.sha256sum] = "6310dfaa2d332b66119b9b020fad6a4bd27d9bc61faf780ca5ca0b62813303f7"
 
diff --git a/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb b/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
index b18ad6ad1b..672c8abc9a 100644
--- a/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
+++ b/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
@@ -62,7 +62,7 @@  RDEPENDS:packagegroup-meta-multimedia-connectivity = "\
     gupnp-dlna \
     ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gupnp-tools", "", d)} \
     libupnp \
-    ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "rygel", "", d)} \
+    ${@bb.utils.contains("DISTRO_FEATURES", "x11", bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "rygel", "", d), "", d)} \
 "
 RDEPENDS:packagegroup-meta-multimedia-dvb = "\
     oscam \