diff mbox series

[v3] elfutils: upgrade 0.189 -> 0.190

Message ID 20231212013801.3632055-1-zangruochen@loongson.cn
State New
Headers show
Series [v3] elfutils: upgrade 0.189 -> 0.190 | expand

Commit Message

臧若尘 Dec. 12, 2023, 1:38 a.m. UTC
From: Zang Ruochen <zangruochen@loongson.cn>

The following patches have been fixed:
0001-libasm-may-link-with-libbz2-if-found.patch

Refresh the following patch:
0001-dso-link-change.patch

Add srcfiles to TESTFILES because ptest needs it.

NEWS:
libelf: Add RELR support.
libdw: Recognize .debug_[ct]u_index sections
readelf: Support readelf -Ds, --use-dynamic --symbol.
         Support .gdb_index version 9
scrlines: New tool that compiles a list of source files associated
          with a specified dwarf/elf file.
debuginfod: Schema change (reindexing required, sorry!) for a 60%
            compression in filename representation, which was a large
            part of the sqlite index; also, more deliberate sqlite
            -wal management during scanning using the
            --scan-checkpoint option.
backends: Various LoongArch updates.

Signed-off-by: Zang Ruochen <zangruochen@loongson.cn>
---
 .../{elfutils_0.189.bb => elfutils_0.190.bb}  |  5 ++-
 .../elfutils/files/0001-dso-link-change.patch | 14 ++++----
 ...libasm-may-link-with-libbz2-if-found.patch | 36 -------------------
 3 files changed, 10 insertions(+), 45 deletions(-)
 rename meta/recipes-devtools/elfutils/{elfutils_0.189.bb => elfutils_0.190.bb} (97%)
 delete mode 100644 meta/recipes-devtools/elfutils/files/0001-libasm-may-link-with-libbz2-if-found.patch

Comments

Alexandre Belloni Dec. 14, 2023, 10:21 p.m. UTC | #1
Hello,

This still fail the ptests:

https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/5854/steps/12/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/6040/steps/12/logs/stdio

https://autobuilder.yocto.io/pub/non-release/20231214-20/testresults/qemux86-64-ptest/core-image-ptest-elfutils/log.do_testimage.4168180.20231214094628


On 11/12/2023 17:38:01-0800, Zang Ruochen wrote:
> From: Zang Ruochen <zangruochen@loongson.cn>
> 
> The following patches have been fixed:
> 0001-libasm-may-link-with-libbz2-if-found.patch
> 
> Refresh the following patch:
> 0001-dso-link-change.patch
> 
> Add srcfiles to TESTFILES because ptest needs it.
> 
> NEWS:
> libelf: Add RELR support.
> libdw: Recognize .debug_[ct]u_index sections
> readelf: Support readelf -Ds, --use-dynamic --symbol.
>          Support .gdb_index version 9
> scrlines: New tool that compiles a list of source files associated
>           with a specified dwarf/elf file.
> debuginfod: Schema change (reindexing required, sorry!) for a 60%
>             compression in filename representation, which was a large
>             part of the sqlite index; also, more deliberate sqlite
>             -wal management during scanning using the
>             --scan-checkpoint option.
> backends: Various LoongArch updates.
> 
> Signed-off-by: Zang Ruochen <zangruochen@loongson.cn>
> ---
>  .../{elfutils_0.189.bb => elfutils_0.190.bb}  |  5 ++-
>  .../elfutils/files/0001-dso-link-change.patch | 14 ++++----
>  ...libasm-may-link-with-libbz2-if-found.patch | 36 -------------------
>  3 files changed, 10 insertions(+), 45 deletions(-)
>  rename meta/recipes-devtools/elfutils/{elfutils_0.189.bb => elfutils_0.190.bb} (97%)
>  delete mode 100644 meta/recipes-devtools/elfutils/files/0001-libasm-may-link-with-libbz2-if-found.patch
> 
> diff --git a/meta/recipes-devtools/elfutils/elfutils_0.189.bb b/meta/recipes-devtools/elfutils/elfutils_0.190.bb
> similarity index 97%
> rename from meta/recipes-devtools/elfutils/elfutils_0.189.bb
> rename to meta/recipes-devtools/elfutils/elfutils_0.190.bb
> index d69828131e..0bd96c1e0f 100644
> --- a/meta/recipes-devtools/elfutils/elfutils_0.189.bb
> +++ b/meta/recipes-devtools/elfutils/elfutils_0.190.bb
> @@ -16,7 +16,6 @@ SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
>             file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \
>             file://0003-fixheadercheck.patch \
>             file://0006-Fix-build-on-aarch64-musl.patch \
> -           file://0001-libasm-may-link-with-libbz2-if-found.patch \
>             file://0001-libelf-elf_end.c-check-data_list.data.d.d_buf-before.patch \
>             file://0001-skip-the-test-when-gcc-not-deployed.patch \
>             file://ptest.patch \
> @@ -25,7 +24,7 @@ SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
>  SRC_URI:append:libc-musl = " \
>             file://0003-musl-utils.patch \
>             "
> -SRC_URI[sha256sum] = "39bd8f1a338e2b7cd4abc3ff11a0eddc6e690f69578a57478d8179b4148708c8"
> +SRC_URI[sha256sum] = "8e00a3a9b5f04bc1dc273ae86281d2d26ed412020b391ffcc23198f10231d692"
>  
>  inherit autotools gettext ptest pkgconfig
>  
> @@ -67,7 +66,7 @@ PTEST_PARALLEL_MAKE = ""
>  do_install_ptest() {
>  	if [ ${PTEST_ENABLED} = "1" ]; then
>  		# copy the files which needed by the cases
> -		TEST_FILES="strip strip.o addr2line elfcmp objdump readelf size.o nm.o nm elflint elfcompress elfclassify stack unstrip"
> +		TEST_FILES="strip strip.o addr2line elfcmp objdump readelf size.o nm.o nm elflint elfcompress elfclassify stack unstrip srcfiles"
>  		install -d -m 755                       ${D}${PTEST_PATH}/src
>  		install -d -m 755                       ${D}${PTEST_PATH}/lib
>  		install -d -m 755                       ${D}${PTEST_PATH}/libelf
> diff --git a/meta/recipes-devtools/elfutils/files/0001-dso-link-change.patch b/meta/recipes-devtools/elfutils/files/0001-dso-link-change.patch
> index 6acc036406..8ccfcb7bd5 100644
> --- a/meta/recipes-devtools/elfutils/files/0001-dso-link-change.patch
> +++ b/meta/recipes-devtools/elfutils/files/0001-dso-link-change.patch
> @@ -16,18 +16,18 @@ more details.
>  Rebase to 0.170
>  
>  Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
> -
> +Signed-off-by: Zang Ruochen <zangruochen@loongson.cn>
>  ---
>   src/Makefile.am   | 2 +-
>   tests/Makefile.am | 2 +-
>   2 files changed, 2 insertions(+), 2 deletions(-)
>  
>  diff --git a/src/Makefile.am b/src/Makefile.am
> -index 88d0ac8..c28d81f 100644
> +index d3d9d40..ea61616 100644
>  --- a/src/Makefile.am
>  +++ b/src/Makefile.am
>  @@ -45,7 +45,7 @@ libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) -ldl -lpthread
> - libelf = ../libelf/libelf.a -lz
> + libelf = ../libelf/libelf.a -lz $(zstd_LIBS)
>   else
>   libasm = ../libasm/libasm.so
>  -libdw = ../libdw/libdw.so
> @@ -36,11 +36,11 @@ index 88d0ac8..c28d81f 100644
>   endif
>   libebl = ../libebl/libebl.a ../backends/libebl_backends.a ../libcpu/libcpu.a
>  diff --git a/tests/Makefile.am b/tests/Makefile.am
> -index c145720..72afd0e 100644
> +index 7fb8efb..71c1a61 100644
>  --- a/tests/Makefile.am
>  +++ b/tests/Makefile.am
> -@@ -554,7 +554,7 @@ libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl -lpthread
> - libelf = ../libelf/libelf.a -lz
> +@@ -680,7 +680,7 @@ libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl -lpthread
> + libelf = ../libelf/libelf.a -lz $(zstd_LIBS)
>   libasm = ../libasm/libasm.a
>   else
>  -libdw = ../libdw/libdw.so
> @@ -48,3 +48,5 @@ index c145720..72afd0e 100644
>   libelf = ../libelf/libelf.so
>   libasm = ../libasm/libasm.so
>   endif
> +--
> +2.25.1
> diff --git a/meta/recipes-devtools/elfutils/files/0001-libasm-may-link-with-libbz2-if-found.patch b/meta/recipes-devtools/elfutils/files/0001-libasm-may-link-with-libbz2-if-found.patch
> deleted file mode 100644
> index 09c9d3ea24..0000000000
> --- a/meta/recipes-devtools/elfutils/files/0001-libasm-may-link-with-libbz2-if-found.patch
> +++ /dev/null
> @@ -1,36 +0,0 @@
> -From ed1975deeaa47f98d212fd144c8bda075b1a5d36 Mon Sep 17 00:00:00 2001
> -From: Khem Raj <raj.khem@gmail.com>
> -Date: Wed, 4 Oct 2017 22:30:46 -0700
> -Subject: [PATCH] libasm may link with libbz2 if found
> -
> -This can fail to link binaries like objdump
> -where indirect libraries may be not found by linker
> -
> -| /mnt/a/oe/build/tmp/work/riscv64-bec-linux/elfutils/0.170-r0/recipe-sysroot/usr/lib/libbz2.so.1: error adding symbols: DSO missing from command line
> -| collect2: error: ld returned 1 exit status
> -
> -Upstream-Status: Pending
> -Signed-off-by: Khem Raj <raj.khem@gmail.com>
> -
> ----
> - src/Makefile.am | 4 ++--
> - 1 file changed, 2 insertions(+), 2 deletions(-)
> -
> -diff --git a/src/Makefile.am b/src/Makefile.am
> -index c28d81f..951e978 100644
> ---- a/src/Makefile.am
> -+++ b/src/Makefile.am
> -@@ -40,11 +40,11 @@ EXTRA_DIST += make-debug-archive.in
> - CLEANFILES += make-debug-archive
> - 
> - if BUILD_STATIC
> --libasm = ../libasm/libasm.a
> -+libasm = ../libasm/libasm.a $(zip_LIBS)
> - libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) -ldl -lpthread
> - libelf = ../libelf/libelf.a -lz
> - else
> --libasm = ../libasm/libasm.so
> -+libasm = ../libasm/libasm.so $(zip_LIBS)
> - libdw = ../libdw/libdw.so $(zip_LIBS) $(libelf) $(libebl) -ldl
> - libelf = ../libelf/libelf.so
> - endif
> -- 
> 2.25.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192187): https://lists.openembedded.org/g/openembedded-core/message/192187
> Mute This Topic: https://lists.openembedded.org/mt/103122542/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/elfutils/elfutils_0.189.bb b/meta/recipes-devtools/elfutils/elfutils_0.190.bb
similarity index 97%
rename from meta/recipes-devtools/elfutils/elfutils_0.189.bb
rename to meta/recipes-devtools/elfutils/elfutils_0.190.bb
index d69828131e..0bd96c1e0f 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.189.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.190.bb
@@ -16,7 +16,6 @@  SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
            file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \
            file://0003-fixheadercheck.patch \
            file://0006-Fix-build-on-aarch64-musl.patch \
-           file://0001-libasm-may-link-with-libbz2-if-found.patch \
            file://0001-libelf-elf_end.c-check-data_list.data.d.d_buf-before.patch \
            file://0001-skip-the-test-when-gcc-not-deployed.patch \
            file://ptest.patch \
@@ -25,7 +24,7 @@  SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
 SRC_URI:append:libc-musl = " \
            file://0003-musl-utils.patch \
            "
-SRC_URI[sha256sum] = "39bd8f1a338e2b7cd4abc3ff11a0eddc6e690f69578a57478d8179b4148708c8"
+SRC_URI[sha256sum] = "8e00a3a9b5f04bc1dc273ae86281d2d26ed412020b391ffcc23198f10231d692"
 
 inherit autotools gettext ptest pkgconfig
 
@@ -67,7 +66,7 @@  PTEST_PARALLEL_MAKE = ""
 do_install_ptest() {
 	if [ ${PTEST_ENABLED} = "1" ]; then
 		# copy the files which needed by the cases
-		TEST_FILES="strip strip.o addr2line elfcmp objdump readelf size.o nm.o nm elflint elfcompress elfclassify stack unstrip"
+		TEST_FILES="strip strip.o addr2line elfcmp objdump readelf size.o nm.o nm elflint elfcompress elfclassify stack unstrip srcfiles"
 		install -d -m 755                       ${D}${PTEST_PATH}/src
 		install -d -m 755                       ${D}${PTEST_PATH}/lib
 		install -d -m 755                       ${D}${PTEST_PATH}/libelf
diff --git a/meta/recipes-devtools/elfutils/files/0001-dso-link-change.patch b/meta/recipes-devtools/elfutils/files/0001-dso-link-change.patch
index 6acc036406..8ccfcb7bd5 100644
--- a/meta/recipes-devtools/elfutils/files/0001-dso-link-change.patch
+++ b/meta/recipes-devtools/elfutils/files/0001-dso-link-change.patch
@@ -16,18 +16,18 @@  more details.
 Rebase to 0.170
 
 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-
+Signed-off-by: Zang Ruochen <zangruochen@loongson.cn>
 ---
  src/Makefile.am   | 2 +-
  tests/Makefile.am | 2 +-
  2 files changed, 2 insertions(+), 2 deletions(-)
 
 diff --git a/src/Makefile.am b/src/Makefile.am
-index 88d0ac8..c28d81f 100644
+index d3d9d40..ea61616 100644
 --- a/src/Makefile.am
 +++ b/src/Makefile.am
 @@ -45,7 +45,7 @@ libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) -ldl -lpthread
- libelf = ../libelf/libelf.a -lz
+ libelf = ../libelf/libelf.a -lz $(zstd_LIBS)
  else
  libasm = ../libasm/libasm.so
 -libdw = ../libdw/libdw.so
@@ -36,11 +36,11 @@  index 88d0ac8..c28d81f 100644
  endif
  libebl = ../libebl/libebl.a ../backends/libebl_backends.a ../libcpu/libcpu.a
 diff --git a/tests/Makefile.am b/tests/Makefile.am
-index c145720..72afd0e 100644
+index 7fb8efb..71c1a61 100644
 --- a/tests/Makefile.am
 +++ b/tests/Makefile.am
-@@ -554,7 +554,7 @@ libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl -lpthread
- libelf = ../libelf/libelf.a -lz
+@@ -680,7 +680,7 @@ libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) $(libebl) -ldl -lpthread
+ libelf = ../libelf/libelf.a -lz $(zstd_LIBS)
  libasm = ../libasm/libasm.a
  else
 -libdw = ../libdw/libdw.so
@@ -48,3 +48,5 @@  index c145720..72afd0e 100644
  libelf = ../libelf/libelf.so
  libasm = ../libasm/libasm.so
  endif
+--
+2.25.1
diff --git a/meta/recipes-devtools/elfutils/files/0001-libasm-may-link-with-libbz2-if-found.patch b/meta/recipes-devtools/elfutils/files/0001-libasm-may-link-with-libbz2-if-found.patch
deleted file mode 100644
index 09c9d3ea24..0000000000
--- a/meta/recipes-devtools/elfutils/files/0001-libasm-may-link-with-libbz2-if-found.patch
+++ /dev/null
@@ -1,36 +0,0 @@ 
-From ed1975deeaa47f98d212fd144c8bda075b1a5d36 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 4 Oct 2017 22:30:46 -0700
-Subject: [PATCH] libasm may link with libbz2 if found
-
-This can fail to link binaries like objdump
-where indirect libraries may be not found by linker
-
-| /mnt/a/oe/build/tmp/work/riscv64-bec-linux/elfutils/0.170-r0/recipe-sysroot/usr/lib/libbz2.so.1: error adding symbols: DSO missing from command line
-| collect2: error: ld returned 1 exit status
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
----
- src/Makefile.am | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index c28d81f..951e978 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -40,11 +40,11 @@ EXTRA_DIST += make-debug-archive.in
- CLEANFILES += make-debug-archive
- 
- if BUILD_STATIC
--libasm = ../libasm/libasm.a
-+libasm = ../libasm/libasm.a $(zip_LIBS)
- libdw = ../libdw/libdw.a -lz $(zip_LIBS) $(libelf) -ldl -lpthread
- libelf = ../libelf/libelf.a -lz
- else
--libasm = ../libasm/libasm.so
-+libasm = ../libasm/libasm.so $(zip_LIBS)
- libdw = ../libdw/libdw.so $(zip_LIBS) $(libelf) $(libebl) -ldl
- libelf = ../libelf/libelf.so
- endif