diff mbox series

tzdata: only the timezone subpackage tzdata-core is retained

Message ID 20231211033927.1042557-1-lizhi.xu@windriver.com
State New
Headers show
Series tzdata: only the timezone subpackage tzdata-core is retained | expand

Commit Message

Lizhi Xu Dec. 11, 2023, 3:39 a.m. UTC
To reduce the size of rootfs, the subpackages contained in tzdata.bb will now 
default to only retaining tzdata-core.

tzdata.bb by default pulls in all possible timezone data packages which increases
size of the final root filesystem considerably.
The customer would like to have extra timezones configurable so that only 
tzdata-core is chosen by default and rest of the zones are optional.

Signed-off-by: Lizhi Xu <lizhi.xu@windriver.com>
---
 meta/recipes-extended/timezone/tzdata.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Alexandre Belloni Dec. 11, 2023, 11:02 a.m. UTC | #1
Please follow https://docs.yoctoproject.org/dev/contributor-guide/submit-changes.html#fixing-your-from-identity

On 11/12/2023 11:39:27+0800, Xu, Lizhi via lists.openembedded.org wrote:
> To reduce the size of rootfs, the subpackages contained in tzdata.bb will now 
> default to only retaining tzdata-core.
> 
> tzdata.bb by default pulls in all possible timezone data packages which increases
> size of the final root filesystem considerably.
> The customer would like to have extra timezones configurable so that only 
> tzdata-core is chosen by default and rest of the zones are optional.
> 
> Signed-off-by: Lizhi Xu <lizhi.xu@windriver.com>
> ---
>  meta/recipes-extended/timezone/tzdata.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-extended/timezone/tzdata.bb b/meta/recipes-extended/timezone/tzdata.bb
> index dd1960ffa7..7b1d4fd460 100644
> --- a/meta/recipes-extended/timezone/tzdata.bb
> +++ b/meta/recipes-extended/timezone/tzdata.bb
> @@ -201,4 +201,4 @@ CONFFILES:tzdata-core = "${sysconfdir}/localtime ${sysconfdir}/timezone"
>  
>  ALLOW_EMPTY:${PN} = "1"
>  
> -RDEPENDS:${PN} = "${TZ_PACKAGES}"
> +RDEPENDS:${PN} = "tzdata-core"
> -- 
> 2.43.0
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#192141): https://lists.openembedded.org/g/openembedded-core/message/192141
> Mute This Topic: https://lists.openembedded.org/mt/103102817/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Lizhi Xu Dec. 13, 2023, 8:36 a.m. UTC | #2
On Mon, 11 Dec 2023 12:02:47 +0100, Alexandre Belloni wrote:
> Please follow https://docs.yoctoproject.org/dev/contributor-guide/submit-changes.html#fixing-your-from-identity
Yes, I followed the rules in this document.

Lizhi
Peter Marko Dec. 13, 2023, 8:49 a.m. UTC | #3
I don't think that this is a good idea.
Currently you have a possibility to add to your IMAGE_INSTALL either tzdata (to install all data) or tzdata-core (to install minimal subset),
After this change, you can add tzdata or tzdata-core to install minimal subset (these packages will be now equal) or dozens of packages to install all without a good way to track changes in packages.

Also, this change would require analyzing all components in all layers which depend just on tzdata if their dependencies need to be adapted.

Much more reasonable is that you install tzdata-core in your images and let the option to install all via just one package to the others.
Or alternatively change the depends to rrecommends and exclude the recommendations in your images.
Or add RDEPENDS:${PN}:pn-tzdata = "tzdata-core" to your distro config.

Peter

-----Original Message-----
From: openembedded-core@lists.openembedded.org <openembedded-core@lists.openembedded.org> On Behalf Of Xu, Lizhi via lists.openembedded.org
Sent: Monday, December 11, 2023 4:39
To: openembedded-core@lists.openembedded.org
Cc: anca.mihalache@windriver.com
Subject: [PATCH] [OE-Core] tzdata: only the timezone subpackage tzdata-core is retained

> To reduce the size of rootfs, the subpackages contained in tzdata.bb will now default to only retaining tzdata-core.
>
> tzdata.bb by default pulls in all possible timezone data packages which increases size of the final root filesystem considerably.
> The customer would like to have extra timezones configurable so that only tzdata-core is chosen by default and rest of the zones are optional.
>
> Signed-off-by: Lizhi Xu <lizhi.xu@windriver.com>
> ---
>  meta/recipes-extended/timezone/tzdata.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-extended/timezone/tzdata.bb b/meta/recipes-extended/timezone/tzdata.bb
> index dd1960ffa7..7b1d4fd460 100644
> --- a/meta/recipes-extended/timezone/tzdata.bb
> +++ b/meta/recipes-extended/timezone/tzdata.bb
> @@ -201,4 +201,4 @@ CONFFILES:tzdata-core = "${sysconfdir}/localtime ${sysconfdir}/timezone"
>  
>  ALLOW_EMPTY:${PN} = "1"
>  
> -RDEPENDS:${PN} = "${TZ_PACKAGES}"
> +RDEPENDS:${PN} = "tzdata-core"
> --
> 2.43.0
diff mbox series

Patch

diff --git a/meta/recipes-extended/timezone/tzdata.bb b/meta/recipes-extended/timezone/tzdata.bb
index dd1960ffa7..7b1d4fd460 100644
--- a/meta/recipes-extended/timezone/tzdata.bb
+++ b/meta/recipes-extended/timezone/tzdata.bb
@@ -201,4 +201,4 @@  CONFFILES:tzdata-core = "${sysconfdir}/localtime ${sysconfdir}/timezone"
 
 ALLOW_EMPTY:${PN} = "1"
 
-RDEPENDS:${PN} = "${TZ_PACKAGES}"
+RDEPENDS:${PN} = "tzdata-core"