diff mbox series

abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake

Message ID 20231208054757.1466187-1-p.chernikov@yadro.com
State Accepted
Headers show
Series abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake | expand

Commit Message

Petr Chernikov Dec. 8, 2023, 5:47 a.m. UTC
Old versions of abseil-cpp could not be compiled using C++ Standard 17.
For now this cmake flag is not needed.
Mosh compilation fixed by specifying c++17 standard.

Signed-off-by: Petr Chernikov <p.chernikov@yadro.com>

Comments

Khem Raj Dec. 13, 2023, 7:07 a.m. UTC | #1
On Fri, 08 Dec 2023 08:47:57 +0300, Petr Chernikov wrote:
> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
> For now this cmake flag is not needed.
> Mosh compilation fixed by specifying c++17 standard.
> 
> 

Applied, thanks!

[1/1] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake
      commit: 190f7b50ac3d7d30cf9d31167fb74f7146c3c8ff

Best regards,
Petr Chernikov Dec. 13, 2023, 9:36 a.m. UTC | #2
Thank you Raj!


-----Original Message-----
From: Khem Raj <raj.khem@gmail.com> 
Sent: Wednesday, December 13, 2023 10:08 AM
To: openembedded-devel@lists.openembedded.org; Petr Chernikov <p.chernikov@yadro.com>
Subject: Re: [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake

On Fri, 08 Dec 2023 08:47:57 +0300, Petr Chernikov wrote:
> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
> For now this cmake flag is not needed.
> Mosh compilation fixed by specifying c++17 standard.
>
>

Applied, thanks!

[1/1] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake
      commit: 190f7b50ac3d7d30cf9d31167fb74f7146c3c8ff

Best regards,
--
Khem Raj <raj.khem@gmail.com>
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index f847ebf15..4705b6f8c 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -26,7 +26,6 @@  inherit cmake
 
 EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
                  -DBUILD_TESTING=OFF    \
-                 -DCMAKE_CXX_STANDARD=14 \
                  -DABSL_ENABLE_INSTALL=ON \
                 "
 
diff --git a/meta-oe/recipes-connectivity/mosh/mosh_1.4.0.bb b/meta-oe/recipes-connectivity/mosh/mosh_1.4.0.bb
index 0ee050da9..693ec12d3 100644
--- a/meta-oe/recipes-connectivity/mosh/mosh_1.4.0.bb
+++ b/meta-oe/recipes-connectivity/mosh/mosh_1.4.0.bb
@@ -46,3 +46,5 @@  RDEPENDS:${PN}-server += "openssh-sshd"
 #| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7'
 #| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs'
 ARM_INSTRUCTION_SET = "arm"
+
+CXXFLAGS:append = " -std=c++17"