Patchwork [RFC,0/2] package_ipk.bbclass: use "--force-arch" when install package

login
register
mail settings
Submitter Robert Yang
Date Sept. 5, 2012, 9:31 a.m.
Message ID <cover.1346837268.git.liezhi.yang@windriver.com>
Download mbox
Permalink /patch/35915/
State New
Headers show

Pull-request

git://git.pokylinux.org/poky-contrib robert/ipk_arch

Comments

Robert Yang - Sept. 5, 2012, 9:31 a.m.
Note:

* This is a RFC patch.

* This is for opkg_svn.bb, the opkg_0.1.8.bb also needs it, but needs re-work.

* Please feel free to give your comments.

// Robert

The following changes since commit 99c85ba93075a1aff789cafabbacf42e6a93bd32:

  build-appliance-image: Update to latest poky master (2012-09-04 18:04:40 +0100)

are available in the git repository at:
  git://git.pokylinux.org/poky-contrib robert/ipk_arch
  http://git.pokylinux.org/cgit.cgi/poky-contrib/log/?h=robert/ipk_arch

Robert Yang (2):
  opkg svn: Add the --force-arch option
  package_ipk.bbclass: use "--force-arch" when install package

 meta/classes/package_ipk.bbclass                 |    6 +-
 meta/recipes-devtools/opkg/opkg/force-arch.patch |  103 ++++++++++++++++++++++
 meta/recipes-devtools/opkg/opkg_svn.bb           |    3 +-
 3 files changed, 109 insertions(+), 3 deletions(-)
 create mode 100644 meta/recipes-devtools/opkg/opkg/force-arch.patch