diff mbox series

[meta-python,5/7] python3-pydantic-core: enable ptest

Message ID e3b18f45a2c2a09e78dec9119a15994d08c10f68.1701991044.git.ticotimo@gmail.com
State Accepted
Headers show
Series [meta-python,1/7] python3-pydantic-core: add v2.14.5 | expand

Commit Message

Tim Orling Dec. 7, 2023, 11:23 p.m. UTC
* Add to ptest-packagelists-meta-python.inc "FAST" under 30 seconds

Signed-off-by: Tim Orling <ticotimo@gmail.com>
---
 .../include/ptest-packagelists-meta-python.inc    |  1 +
 .../python/python3-pydantic-core/run-ptest        |  3 +++
 .../python/python3-pydantic-core_2.14.5.bb        | 15 +++++++++++++++
 3 files changed, 19 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pydantic-core/run-ptest
diff mbox series

Patch

diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 3272d9819..13dcb621d 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -27,6 +27,7 @@  PTESTS_FAST_META_PYTHON = "\
     python3-polyline \
     python3-precise-runner \
     python3-prettytable \
+    python3-pydantic-core \
     python3-pylint \
     python3-ptyprocess \
     python3-py-cpuinfo \
diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core/run-ptest b/meta-python/recipes-devtools/python/python3-pydantic-core/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pydantic-core/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb b/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb
index 8221de80b..01f180c8c 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb
@@ -23,3 +23,18 @@  PYPI_ARCHIVE_NAME = "pydantic_core-${PV}.${PYPI_PACKAGE_EXT}"
 RDEPENDS:${PN} += "python3-typing-extensions"
 
 INSANE_SKIP:${PN} = "already-stripped"
+
+inherit ptest
+SRC_URI += "file://run-ptest"
+RDEPENDS:${PN}-ptest += "\
+    python3-dirty-equals \
+    python3-hypothesis \
+    python3-pytest \
+    python3-pytest-mock \
+    python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+    cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
+    rm -rf ${D}${PTEST_PATH}/tests/benchmarks
+}