diff mbox series

[2/4] python3-qemu-qmp: Add recipe

Message ID 25d25aac54efcb8afe5a6d17f70800b57a0d0a21.1701959631.git.pidge@baylibre.com
State New
Headers show
Series Image screenshot testing proof of concept | expand

Commit Message

Eilís 'pidge' Ní Fhlannagáin Dec. 7, 2023, 2:36 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

Add a recipe for python QEMU Monitor Protocol. This will be needed for
qemu screendumps for qemu screendump testing.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Eilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com>
---
 .../python/python3-qemu-qmp_0.0.2.bb               | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb

Comments

Tim Orling Dec. 7, 2023, 5:38 p.m. UTC | #1
This will also need a maintainer entry in:
https://git.openembedded.org/openembedded-core/tree/meta/conf/distro/include/maintainers.inc

On Thu, Dec 7, 2023 at 6:36 AM Eilís 'pidge' Ní Fhlannagáin <
pidge@baylibre.com> wrote:

> From: Ross Burton <ross.burton@arm.com>
>
> Add a recipe for python QEMU Monitor Protocol. This will be needed for
> qemu screendumps for qemu screendump testing.
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> Signed-off-by: Eilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com>
> ---
>  .../python/python3-qemu-qmp_0.0.2.bb               | 14 ++++++++++++++
>  1 file changed, 14 insertions(+)
>  create mode 100644 meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
>
> diff --git a/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> new file mode 100644
> index 00000000000..faa0cc69738
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> @@ -0,0 +1,14 @@
> +SUMMARY = "asyncio library for communicating with QEMU Monitor Protocol
> (QMP) servers"
> +LICENSE = "LGPLv2+ & GPLv2"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=4cf66a4984120007c9881cc871cf49db \
> +
> file://LICENSE_GPL2;md5=441c28d2cf86e15a37fa47e15a72fbac"
> +
> +SRC_URI[sha256sum] =
> "c918e9e3ae09abdf70c7ece67637a93ac4583d940bbf48d24ff77987f74f1b8b"
> +
> +inherit pypi python_setuptools_build_meta
> +
> +PYPI_PACKAGE = "qemu.qmp"
> +
> +DEPENDS += "python3-setuptools-scm-native"
> +
> +BBCLASSEXTEND = "native nativesdk"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#191960):
> https://lists.openembedded.org/g/openembedded-core/message/191960
> Mute This Topic: https://lists.openembedded.org/mt/103035077/924729
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Alexandre Belloni Dec. 10, 2023, 10:17 p.m. UTC | #2
On 07/12/2023 09:38:17-0800, Tim Orling wrote:
> This will also need a maintainer entry in:
> https://git.openembedded.org/openembedded-core/tree/meta/conf/distro/include/maintainers.inc
> 

Also:
stdio: WARNING: python3-qemu-qmp-0.0.2-r0 do_recipe_qa: QA Issue: Recipe python3-qemu-qmp in /home/pokybuild/yocto-worker/qemuarm64-armhost/build/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb does not contain a HOMEPAGE. Please add an entry. [missing-metadata]
stdio: WARNING: python3-qemu-qmp-0.0.2-r0 do_recipe_qa: QA Issue: Recipe python3-qemu-qmp in /home/pokybuild/yocto-worker/qemuarm64-armhost/build/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb does not have an assigned maintainer. Please add an entry into meta/conf/distro/include/maintainers.inc. [missing-maintainer]
stdio: WARNING: python3-qemu-qmp-native-0.0.2-r0 do_recipe_qa: QA Issue: Recipe python3-qemu-qmp-native in /home/pokybuild/yocto-worker/qemuarm64-armhost/build/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb does not contain a HOMEPAGE. Please add an entry. [missing-metadata]
WARNING: python3-qemu-qmp-0.0.2-r0 do_package_qa: QA Issue: Recipe LICENSE includes obsolete licenses GPLv2 LGPLv2+ [obsolete-license]

> On Thu, Dec 7, 2023 at 6:36 AM Eilís 'pidge' Ní Fhlannagáin <
> pidge@baylibre.com> wrote:
> 
> > From: Ross Burton <ross.burton@arm.com>
> >
> > Add a recipe for python QEMU Monitor Protocol. This will be needed for
> > qemu screendumps for qemu screendump testing.
> >
> > Signed-off-by: Ross Burton <ross.burton@arm.com>
> > Signed-off-by: Eilís 'pidge' Ní Fhlannagáin <pidge@baylibre.com>
> > ---
> >  .../python/python3-qemu-qmp_0.0.2.bb               | 14 ++++++++++++++
> >  1 file changed, 14 insertions(+)
> >  create mode 100644 meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> >
> > diff --git a/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> > b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> > new file mode 100644
> > index 00000000000..faa0cc69738
> > --- /dev/null
> > +++ b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
> > @@ -0,0 +1,14 @@
> > +SUMMARY = "asyncio library for communicating with QEMU Monitor Protocol
> > (QMP) servers"
> > +LICENSE = "LGPLv2+ & GPLv2"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=4cf66a4984120007c9881cc871cf49db \
> > +
> > file://LICENSE_GPL2;md5=441c28d2cf86e15a37fa47e15a72fbac"
> > +
> > +SRC_URI[sha256sum] =
> > "c918e9e3ae09abdf70c7ece67637a93ac4583d940bbf48d24ff77987f74f1b8b"
> > +
> > +inherit pypi python_setuptools_build_meta
> > +
> > +PYPI_PACKAGE = "qemu.qmp"
> > +
> > +DEPENDS += "python3-setuptools-scm-native"
> > +
> > +BBCLASSEXTEND = "native nativesdk"
> > --
> > 2.34.1
> >
> >
> > 
> >
> >

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#191969): https://lists.openembedded.org/g/openembedded-core/message/191969
> Mute This Topic: https://lists.openembedded.org/mt/103035077/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
new file mode 100644
index 00000000000..faa0cc69738
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-qemu-qmp_0.0.2.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "asyncio library for communicating with QEMU Monitor Protocol (QMP) servers"
+LICENSE = "LGPLv2+ & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4cf66a4984120007c9881cc871cf49db \
+                    file://LICENSE_GPL2;md5=441c28d2cf86e15a37fa47e15a72fbac"
+
+SRC_URI[sha256sum] = "c918e9e3ae09abdf70c7ece67637a93ac4583d940bbf48d24ff77987f74f1b8b"
+
+inherit pypi python_setuptools_build_meta
+
+PYPI_PACKAGE = "qemu.qmp"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"