diff mbox series

abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake

Message ID 20231204141856.2977926-1-p.chernikov@yadro.com
State Accepted
Headers show
Series abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake | expand

Commit Message

Petr Chernikov Dec. 4, 2023, 2:18 p.m. UTC
Old versions of abseil-cpp could not be compiled using C++ Standard 17.
For now this cmake flag is not needed.

Signed-off-by: Petr Chernikov <p.chernikov@yadro.com>

Comments

Khem Raj Dec. 4, 2023, 3:22 p.m. UTC | #1
On Mon, Dec 4, 2023 at 6:23 AM Petr Chernikov <p.chernikov@yadro.com> wrote:

> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
> For now this cmake flag is not needed.


Can you check if this works with clang compiler as well

>
>
> Signed-off-by: Petr Chernikov <p.chernikov@yadro.com>
>
> diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> index f847ebf15..4705b6f8c 100644
> --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> @@ -26,7 +26,6 @@ inherit cmake
>
>  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
>                   -DBUILD_TESTING=OFF    \
> -                 -DCMAKE_CXX_STANDARD=14 \
>                   -DABSL_ENABLE_INSTALL=ON \
>                  "
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107204):
> https://lists.openembedded.org/g/openembedded-devel/message/107204
> Mute This Topic: https://lists.openembedded.org/mt/102970930/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Dec. 4, 2023, 10:45 p.m. UTC | #2
here is a problem which might be related to this change

https://errors.yoctoproject.org/Errors/Details/745165/

On Mon, Dec 4, 2023 at 7:22 AM Khem Raj <raj.khem@gmail.com> wrote:
>
>
>
> On Mon, Dec 4, 2023 at 6:23 AM Petr Chernikov <p.chernikov@yadro.com> wrote:
>>
>> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
>> For now this cmake flag is not needed.
>
>
> Can you check if this works with clang compiler as well
>>
>>
>>
>> Signed-off-by: Petr Chernikov <p.chernikov@yadro.com>
>>
>> diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> index f847ebf15..4705b6f8c 100644
>> --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> @@ -26,7 +26,6 @@ inherit cmake
>>
>>  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
>>                   -DBUILD_TESTING=OFF    \
>> -                 -DCMAKE_CXX_STANDARD=14 \
>>                   -DABSL_ENABLE_INSTALL=ON \
>>                  "
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#107204): https://lists.openembedded.org/g/openembedded-devel/message/107204
>> Mute This Topic: https://lists.openembedded.org/mt/102970930/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Petr Chernikov Dec. 5, 2023, 7:53 a.m. UTC | #3
Hi Raj, 
Thank you for feedback!

I've just tested compilation via clang using meta-clang layer - this is fine

I've also tested `native` compilation using both gcc and clang, this is OK too.
But I don't know how to test nativesdk, any thoughts about this kind of compilation?


-----Original Message-----
From: Khem Raj <raj.khem@gmail.com> 
Sent: Tuesday, December 5, 2023 1:46 AM
To: Petr Chernikov <p.chernikov@yadro.com>
Cc: openembedded-devel@lists.openembedded.org
Subject: Re: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake

«Внимание! Данное письмо от внешнего адресата!»

here is a problem which might be related to this change

https://errors.yoctoproject.org/Errors/Details/745165/

On Mon, Dec 4, 2023 at 7:22 AM Khem Raj <raj.khem@gmail.com> wrote:
>
>
>
> On Mon, Dec 4, 2023 at 6:23 AM Petr Chernikov <p.chernikov@yadro.com> wrote:
>>
>> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
>> For now this cmake flag is not needed.
>
>
> Can you check if this works with clang compiler as well
>>
>>
>>
>> Signed-off-by: Petr Chernikov <p.chernikov@yadro.com>
>>
>> diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> index f847ebf15..4705b6f8c 100644
>> --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> @@ -26,7 +26,6 @@ inherit cmake
>>
>>  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
>>                   -DBUILD_TESTING=OFF    \
>> -                 -DCMAKE_CXX_STANDARD=14 \
>>                   -DABSL_ENABLE_INSTALL=ON \
>>                  "
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#107204): https://lists.openembedded.org/g/openembedded-devel/message/107204
>> Mute This Topic: https://lists.openembedded.org/mt/102970930/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Petr Chernikov Dec. 6, 2023, 11:01 a.m. UTC | #4
Raj, is my testing enough to apply changes?


-----Original Message-----
From: Petr Chernikov 
Sent: Tuesday, December 5, 2023 10:53 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: openembedded-devel@lists.openembedded.org
Subject: RE: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake

Hi Raj, 
Thank you for feedback!

I've just tested compilation via clang using meta-clang layer - this is fine

I've also tested `native` compilation using both gcc and clang, this is OK too.
But I don't know how to test nativesdk, any thoughts about this kind of compilation?


-----Original Message-----
From: Khem Raj <raj.khem@gmail.com> 
Sent: Tuesday, December 5, 2023 1:46 AM
To: Petr Chernikov <p.chernikov@yadro.com>
Cc: openembedded-devel@lists.openembedded.org
Subject: Re: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake

«Внимание! Данное письмо от внешнего адресата!»

here is a problem which might be related to this change

https://errors.yoctoproject.org/Errors/Details/745165/

On Mon, Dec 4, 2023 at 7:22 AM Khem Raj <raj.khem@gmail.com> wrote:
>
>
>
> On Mon, Dec 4, 2023 at 6:23 AM Petr Chernikov <p.chernikov@yadro.com> wrote:
>>
>> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
>> For now this cmake flag is not needed.
>
>
> Can you check if this works with clang compiler as well
>>
>>
>>
>> Signed-off-by: Petr Chernikov <p.chernikov@yadro.com>
>>
>> diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> index f847ebf15..4705b6f8c 100644
>> --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
>> @@ -26,7 +26,6 @@ inherit cmake
>>
>>  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
>>                   -DBUILD_TESTING=OFF    \
>> -                 -DCMAKE_CXX_STANDARD=14 \
>>                   -DABSL_ENABLE_INSTALL=ON \
>>                  "
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#107204): https://lists.openembedded.org/g/openembedded-devel/message/107204
>> Mute This Topic: https://lists.openembedded.org/mt/102970930/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj Dec. 6, 2023, 3:07 p.m. UTC | #5
On Wed, Dec 6, 2023 at 3:01 AM Petr Chernikov <p.chernikov@yadro.com> wrote:

> Raj, is my testing enough to apply changes?
>

I think you have to compile mosh package to see the issue abseil builds
fine

>
>
> -----Original Message-----
> From: Petr Chernikov
> Sent: Tuesday, December 5, 2023 10:53 AM
> To: 'Khem Raj' <raj.khem@gmail.com>
> Cc: openembedded-devel@lists.openembedded.org
> Subject: RE: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag
> from extra_oecmake
>
> Hi Raj,
> Thank you for feedback!
>
> I've just tested compilation via clang using meta-clang layer - this is
> fine
>
> I've also tested `native` compilation using both gcc and clang, this is OK
> too.
> But I don't know how to test nativesdk, any thoughts about this kind of
> compilation?
>
>
> -----Original Message-----
> From: Khem Raj <raj.khem@gmail.com>
> Sent: Tuesday, December 5, 2023 1:46 AM
> To: Petr Chernikov <p.chernikov@yadro.com>
> Cc: openembedded-devel@lists.openembedded.org
> Subject: Re: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag
> from extra_oecmake
>
> «Внимание! Данное письмо от внешнего адресата!»
>
> here is a problem which might be related to this change
>
> https://errors.yoctoproject.org/Errors/Details/745165/
>
> On Mon, Dec 4, 2023 at 7:22 AM Khem Raj <raj.khem@gmail.com> wrote:
> >
> >
> >
> > On Mon, Dec 4, 2023 at 6:23 AM Petr Chernikov <p.chernikov@yadro.com>
> wrote:
> >>
> >> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
> >> For now this cmake flag is not needed.
> >
> >
> > Can you check if this works with clang compiler as well
> >>
> >>
> >>
> >> Signed-off-by: Petr Chernikov <p.chernikov@yadro.com>
> >>
> >> diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> >> index f847ebf15..4705b6f8c 100644
> >> --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> >> +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> >> @@ -26,7 +26,6 @@ inherit cmake
> >>
> >>  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
> >>                   -DBUILD_TESTING=OFF    \
> >> -                 -DCMAKE_CXX_STANDARD=14 \
> >>                   -DABSL_ENABLE_INSTALL=ON \
> >>                  "
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#107204):
> https://lists.openembedded.org/g/openembedded-devel/message/107204
> >> Mute This Topic: https://lists.openembedded.org/mt/102970930/1997914
> >> Group Owner: openembedded-devel+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub
> [raj.khem@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
>
Petr Chernikov Dec. 7, 2023, 8:34 a.m. UTC | #6
Good catch Raj! Thank you!

I’ve tested mosh compilation and yes, this fails without some changes:

I’ve added ` CXXFLAGS:append = " -std=c++17"` to mosh recipe and compilation is fixed, so my question:
Should I put both changes (for mosh and for abseil-cpp) in one patch?


Yours sincerely,
Petr Chernikov





From: Khem Raj <raj.khem@gmail.com>
Sent: Wednesday, December 6, 2023 6:07 PM
To: Petr Chernikov <p.chernikov@yadro.com>
Cc: openembedded-devel@lists.openembedded.org
Subject: Re: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake


«Внимание! Данное письмо от внешнего адресата!»


On Wed, Dec 6, 2023 at 3:01 AM Petr Chernikov <p.chernikov@yadro.com<mailto:p.chernikov@yadro.com>> wrote:
Raj, is my testing enough to apply changes?

I think you have to compile mosh package to see the issue abseil builds fine


-----Original Message-----
From: Petr Chernikov
Sent: Tuesday, December 5, 2023 10:53 AM
To: 'Khem Raj' <raj.khem@gmail.com<mailto:raj.khem@gmail.com>>
Cc: openembedded-devel@lists.openembedded.org<mailto:openembedded-devel@lists.openembedded.org>
Subject: RE: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake

Hi Raj,
Thank you for feedback!

I've just tested compilation via clang using meta-clang layer - this is fine

I've also tested `native` compilation using both gcc and clang, this is OK too.
But I don't know how to test nativesdk, any thoughts about this kind of compilation?


-----Original Message-----
From: Khem Raj <raj.khem@gmail.com<mailto:raj.khem@gmail.com>>
Sent: Tuesday, December 5, 2023 1:46 AM
To: Petr Chernikov <p.chernikov@yadro.com<mailto:p.chernikov@yadro.com>>
Cc: openembedded-devel@lists.openembedded.org<mailto:openembedded-devel@lists.openembedded.org>
Subject: Re: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake

«Внимание! Данное письмо от внешнего адресата!»

here is a problem which might be related to this change

https://errors.yoctoproject.org/Errors/Details/745165/

On Mon, Dec 4, 2023 at 7:22 AM Khem Raj <raj.khem@gmail.com<mailto:raj.khem@gmail.com>> wrote:
>
>
>
> On Mon, Dec 4, 2023 at 6:23 AM Petr Chernikov <p.chernikov@yadro.com<mailto:p.chernikov@yadro.com>> wrote:
>>
>> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
>> For now this cmake flag is not needed.
>
>
> Can you check if this works with clang compiler as well
>>
>>
>>
>> Signed-off-by: Petr Chernikov <p.chernikov@yadro.com<mailto:p.chernikov@yadro.com>>
>>
>> diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb<http://abseil-cpp_git.bb> b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb<http://abseil-cpp_git.bb>
>> index f847ebf15..4705b6f8c 100644
>> --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb<http://abseil-cpp_git.bb>
>> +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb<http://abseil-cpp_git.bb>
>> @@ -26,7 +26,6 @@ inherit cmake
>>
>>  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
>>                   -DBUILD_TESTING=OFF    \
>> -                 -DCMAKE_CXX_STANDARD=14 \
>>                   -DABSL_ENABLE_INSTALL=ON \
>>                  "
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#107204): https://lists.openembedded.org/g/openembedded-devel/message/107204
>> Mute This Topic: https://lists.openembedded.org/mt/102970930/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org<mailto:openembedded-devel%2Bowner@lists.openembedded.org>
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com<mailto:raj.khem@gmail.com>]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj Dec. 7, 2023, 3:01 p.m. UTC | #7
On Thu, Dec 7, 2023 at 12:34 AM Petr Chernikov <p.chernikov@yadro.com>
wrote:

> Good catch Raj! Thank you!
>
>
>
> I’ve tested mosh compilation and yes, this fails without some changes:
>
>
>
> I’ve added ` CXXFLAGS:append = " -std=c++17"` to mosh recipe and
> compilation is fixed, so my question:
>
> Should I put both changes (for mosh and for abseil-cpp) in one patch?
>

Two patches in one series yes

>
>
>
>
> Yours sincerely,
> *Petr Chernikov*
>
>
>
>
>
> *From:* Khem Raj <raj.khem@gmail.com>
> *Sent:* Wednesday, December 6, 2023 6:07 PM
> *To:* Petr Chernikov <p.chernikov@yadro.com>
> *Cc:* openembedded-devel@lists.openembedded.org
> *Subject:* Re: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14
> flag from extra_oecmake
>
>
>
> «Внимание! Данное письмо от внешнего адресата!»
>
>
>
>
>
> On Wed, Dec 6, 2023 at 3:01 AM Petr Chernikov <p.chernikov@yadro.com>
> wrote:
>
> Raj, is my testing enough to apply changes?
>
>
>
> I think you have to compile mosh package to see the issue abseil builds
> fine
>
>
>
> -----Original Message-----
> From: Petr Chernikov
> Sent: Tuesday, December 5, 2023 10:53 AM
> To: 'Khem Raj' <raj.khem@gmail.com>
> Cc: openembedded-devel@lists.openembedded.org
> Subject: RE: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag
> from extra_oecmake
>
> Hi Raj,
> Thank you for feedback!
>
> I've just tested compilation via clang using meta-clang layer - this is
> fine
>
> I've also tested `native` compilation using both gcc and clang, this is OK
> too.
> But I don't know how to test nativesdk, any thoughts about this kind of
> compilation?
>
>
> -----Original Message-----
> From: Khem Raj <raj.khem@gmail.com>
> Sent: Tuesday, December 5, 2023 1:46 AM
> To: Petr Chernikov <p.chernikov@yadro.com>
> Cc: openembedded-devel@lists.openembedded.org
> Subject: Re: [oe] [PATCH] abseil-cpp: remove -Dcmake_cxx_standard=14 flag
> from extra_oecmake
>
> «Внимание! Данное письмо от внешнего адресата!»
>
> here is a problem which might be related to this change
>
> https://errors.yoctoproject.org/Errors/Details/745165/
>
> On Mon, Dec 4, 2023 at 7:22 AM Khem Raj <raj.khem@gmail.com> wrote:
> >
> >
> >
> > On Mon, Dec 4, 2023 at 6:23 AM Petr Chernikov <p.chernikov@yadro.com>
> wrote:
> >>
> >> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
> >> For now this cmake flag is not needed.
> >
> >
> > Can you check if this works with clang compiler as well
> >>
> >>
> >>
> >> Signed-off-by: Petr Chernikov <p.chernikov@yadro.com>
> >>
> >> diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> >> index f847ebf15..4705b6f8c 100644
> >> --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> >> +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
> >> @@ -26,7 +26,6 @@ inherit cmake
> >>
> >>  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
> >>                   -DBUILD_TESTING=OFF    \
> >> -                 -DCMAKE_CXX_STANDARD=14 \
> >>                   -DABSL_ENABLE_INSTALL=ON \
> >>                  "
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#107204):
> https://lists.openembedded.org/g/openembedded-devel/message/107204
> >> Mute This Topic: https://lists.openembedded.org/mt/102970930/1997914
> >> Group Owner: openembedded-devel+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub
> [raj.khem@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
>
>
Khem Raj Dec. 13, 2023, 7:07 a.m. UTC | #8
On Mon, 04 Dec 2023 17:18:56 +0300, Petr Chernikov wrote:
> Old versions of abseil-cpp could not be compiled using C++ Standard 17.
> For now this cmake flag is not needed.
> 
> 

Applied, thanks!

[1/1] abseil-cpp: remove -Dcmake_cxx_standard=14 flag from extra_oecmake
      commit: 190f7b50ac3d7d30cf9d31167fb74f7146c3c8ff

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index f847ebf15..4705b6f8c 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -26,7 +26,6 @@  inherit cmake
 
 EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
                  -DBUILD_TESTING=OFF    \
-                 -DCMAKE_CXX_STANDARD=14 \
                  -DABSL_ENABLE_INSTALL=ON \
                 "