diff mbox series

rust: Drop targets and hosts override magic

Message ID 20231201183418.4188-1-alex.kiernan@gmail.com
State Accepted, archived
Commit 6c93a71a9855cb0231d2f90f0412b6a49e3b1d99
Headers show
Series rust: Drop targets and hosts override magic | expand

Commit Message

Alex Kiernan Dec. 1, 2023, 6:34 p.m. UTC
`targets` and `hosts` could be overridden prior to 0a01b5ab973e
("rust-cross-canadian: Simplify and fix"), that commit deleted this
usage, remove the remnant of it from here.

Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---

 meta/recipes-devtools/rust/rust_1.70.0.bb | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/rust/rust_1.70.0.bb b/meta/recipes-devtools/rust/rust_1.70.0.bb
index 6a28dc926ed2..3d176e54c15c 100644
--- a/meta/recipes-devtools/rust/rust_1.70.0.bb
+++ b/meta/recipes-devtools/rust/rust_1.70.0.bb
@@ -154,13 +154,9 @@  python do_configure() {
 
     config.set("build", "vendor", e(True))
 
-    if not "targets" in locals():
-        targets = [d.getVar("RUST_TARGET_SYS")]
-    config.set("build", "target", e(targets))
+    config.set("build", "target", e([d.getVar("RUST_TARGET_SYS")]))
 
-    if not "hosts" in locals():
-        hosts = [d.getVar("RUST_HOST_SYS")]
-    config.set("build", "host", e(hosts))
+    config.set("build", "host", e([d.getVar("RUST_HOST_SYS")]))
 
     # We can't use BUILD_SYS since that is something the rust snapshot knows
     # nothing about when trying to build some stage0 tools (like fabricate)