diff mbox series

[meta-networking] spice-gtk: Set meson version based on PV

Message ID 20231129194343.6195-1-f_l_k@t-online.de
State Under Review
Headers show
Series [meta-networking] spice-gtk: Set meson version based on PV | expand

Commit Message

Markus Volk Nov. 29, 2023, 7:43 p.m. UTC
This fixes build for gnome-boxes

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...n.build-set-hardcoded-version-string.patch | 26 +++++++++++++++++++
 .../recipes-support/spice/spice-gtk_0.42.bb   |  9 ++++++-
 2 files changed, 34 insertions(+), 1 deletion(-)
 create mode 100644 meta-networking/recipes-support/spice/spice-gtk/0001-meson.build-set-hardcoded-version-string.patch
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/spice/spice-gtk/0001-meson.build-set-hardcoded-version-string.patch b/meta-networking/recipes-support/spice/spice-gtk/0001-meson.build-set-hardcoded-version-string.patch
new file mode 100644
index 000000000..a691842c8
--- /dev/null
+++ b/meta-networking/recipes-support/spice/spice-gtk/0001-meson.build-set-hardcoded-version-string.patch
@@ -0,0 +1,26 @@ 
+From 452061cae6288c6fd0ef9455bb4f7603b2e6eefd Mon Sep 17 00:00:00 2001
+From: Markus Volk <f_l_k@t-online.de>
+Date: Mon, 27 Nov 2023 20:39:32 +0100
+Subject: [PATCH] meson.build: set hardcoded version string
+
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 341f5fb..ecda25c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -2,7 +2,7 @@
+ # project definition
+ #
+ project('spice-gtk', 'c',
+-         version : run_command('build-aux/git-version-gen', '@0@/.tarball-version'.format(meson.project_source_root()), check : true).stdout().strip(),
++         version : '@version@',
+          license : 'LGPLv2.1',
+          meson_version : '>= 0.56',
+          default_options : ['buildtype=debugoptimized',
+-- 
+2.42.0
+
diff --git a/meta-networking/recipes-support/spice/spice-gtk_0.42.bb b/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
index 3d34f222d..8d848a319 100644
--- a/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
+++ b/meta-networking/recipes-support/spice/spice-gtk_0.42.bb
@@ -10,7 +10,10 @@  LIC_FILES_CHKSUM = " \
 
 SRCREV = "f04479c16f0969fb394ebe74b6eff74e560a42f0"
 
-SRC_URI = "gitsm://gitlab.freedesktop.org/spice/spice-gtk.git;protocol=https;branch=master"
+SRC_URI = " \
+	gitsm://gitlab.freedesktop.org/spice/spice-gtk.git;protocol=https;branch=master \
+	file://0001-meson.build-set-hardcoded-version-string.patch \
+"
 
 S = "${WORKDIR}/git"
 
@@ -52,6 +55,10 @@  GTKDOC_MESON_OPTION = 'gtk_doc'
 GTKDOC_MESON_ENABLE_FLAG = 'enabled'
 GTKDOC_MESON_DISABLE_FLAG = 'disabled'
 
+do_configure:prepend() {
+    sed -i "s|@version@|${PV}|" ${S}/meson.build
+}
+
 PACKAGECONFIG ??= "${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vapi', '', d)} smartcard"
 PACKAGECONFIG[vapi] = "-Dvapi=enabled,-Dvapi=disabled"
 PACKAGECONFIG[smartcard] = "-Dsmartcard=enabled,-Dsmartcard=disabled,libcacard"