diff mbox series

[PATCHv3] pciutils: add packageconfigs for options

Message ID 20231127070746.3199347-1-f_l_k@t-online.de
State New
Headers show
Series [PATCHv3] pciutils: add packageconfigs for options | expand

Commit Message

Markus Volk Nov. 27, 2023, 7:07 a.m. UTC
My motivation for this is to get zlib support selectable, because
libosinfo requires the pci.ids file uncompressed. Add packageconfigs for
the other options as well to avoid autoselect.

Configuration stays the same besides zlib is deselected by default.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-bsp/pciutils/pciutils_3.10.0.bb | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

Comments

Alexandre Belloni Dec. 1, 2023, 7:19 p.m. UTC | #1
This breaks most of the AB builds because of missing libpci:

https://autobuilder.yoctoproject.org/typhoon/#/builders/83/builds/6271

In particular:
https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4017/steps/12/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/48/builds/8258/steps/11/logs/stdio
https://autobuilder.yoctoproject.org/typhoon/#/builders/37/builds/8240/steps/11/logs/stdio

I would appreciate more testing on your side...

On 27/11/2023 08:07:46+0100, Markus Volk wrote:
> My motivation for this is to get zlib support selectable, because
> libosinfo requires the pci.ids file uncompressed. Add packageconfigs for
> the other options as well to avoid autoselect.
> 
> Configuration stays the same besides zlib is deselected by default.
> 
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  meta/recipes-bsp/pciutils/pciutils_3.10.0.bb | 13 +++++++------
>  1 file changed, 7 insertions(+), 6 deletions(-)
> 
> diff --git a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb b/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
> index e27cfd4ced..351dd94778 100644
> --- a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
> +++ b/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
> @@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
>  # Can drop make-native when all systems have make 4.3
>  # https://git.savannah.gnu.org/cgit/make.git/commit/?id=b90fabc8d6f34fb37d428dc0fb1b8b1951a9fbed
>  # causes space issues in lib/libpci.pc
> -DEPENDS = "zlib kmod make-native"
> +DEPENDS = "make-native"
>  
>  SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.xz \
>             file://configure.patch"
> @@ -18,10 +18,11 @@ SRC_URI[sha256sum] = "238a2e27166730e53a17fe07bfad229e07fa39b618117e5944b6d7eda9
>  
>  inherit multilib_header pkgconfig update-alternatives
>  
> -PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)}"
> +PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)} dns kmod"
>  PACKAGECONFIG[hwdb] = "HWDB=yes,HWDB=no,udev"
> -
> -PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes STRIP= LIBDIR=${libdir}"
> +PACKAGECONFIG[zlib] = "ZLIB=yes,ZLIB=no,zlib"
> +PACKAGECONFIG[kmod] = "LIBKMOD=yes,LIBKMOD=no,kmod"
> +PACKAGECONFIG[dns] = "DNS=yes,DNS=no"
>  
>  # see configure.patch
>  do_configure () {
> @@ -29,7 +30,7 @@ do_configure () {
>  	  cd lib && \
>  	  # PACKAGECONFIG_CONFARGS for this recipe could only possibly contain 'HWDB=yes/no',
>  	  # so we put it before ./configure
> -	  ${PCI_CONF_FLAG} ${PACKAGECONFIG_CONFARGS} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
> +	  ${PACKAGECONFIG_CONFARGS} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
>  	)
>  }
>  
> @@ -38,7 +39,7 @@ export SBINDIR = "${sbindir}"
>  export SHAREDIR = "${datadir}"
>  export MANDIR = "${mandir}"
>  
> -EXTRA_OEMAKE = "-e MAKEFLAGS= ${PCI_CONF_FLAG}"
> +EXTRA_OEMAKE = "-e MAKEFLAGS='SHARED=yes STRIP= LIBDIR=${libdir}'"
>  
>  ASNEEDED = ""
>  
> -- 
> 2.42.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#191260): https://lists.openembedded.org/g/openembedded-core/message/191260
> Mute This Topic: https://lists.openembedded.org/mt/102824927/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie Dec. 3, 2023, 1:24 p.m. UTC | #2
On Mon, 2023-11-27 at 08:07 +0100, Markus Volk wrote:
> My motivation for this is to get zlib support selectable, because
> libosinfo requires the pci.ids file uncompressed. Add packageconfigs for
> the other options as well to avoid autoselect.
> 
> Configuration stays the same besides zlib is deselected by default.

This needs to be two patches, one adding the PACKAGECONFIG and one
changing the defaults.

FWIW I think the default of compression makes sense gives our embedded
targets so I'd argue against that change.

Cheers,

Richard
Markus Volk Dec. 4, 2023, 7:05 a.m. UTC | #3
On Sun, Dec 3 2023 at 01:24:06 PM +00:00:00, Richard Purdie 
<richard.purdie@linuxfoundation.org> wrote:
> FWIW I think the default of compression makes sense gives our embedded
> targets so I'd argue against that change.

Also though about not changing the default, because it'll increase size 
by about one MB. On the other hand the only consumer of pci.ids I know 
of requires to read it uncompressed plus it's packaged into its own 
package, so its not installed by default.
I'll split the patch up but will have to find some time first to look 
at the issue this patch causes to the autobuilder.
diff mbox series

Patch

diff --git a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb b/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
index e27cfd4ced..351dd94778 100644
--- a/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
+++ b/meta/recipes-bsp/pciutils/pciutils_3.10.0.bb
@@ -9,7 +9,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 # Can drop make-native when all systems have make 4.3
 # https://git.savannah.gnu.org/cgit/make.git/commit/?id=b90fabc8d6f34fb37d428dc0fb1b8b1951a9fbed
 # causes space issues in lib/libpci.pc
-DEPENDS = "zlib kmod make-native"
+DEPENDS = "make-native"
 
 SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.xz \
            file://configure.patch"
@@ -18,10 +18,11 @@  SRC_URI[sha256sum] = "238a2e27166730e53a17fe07bfad229e07fa39b618117e5944b6d7eda9
 
 inherit multilib_header pkgconfig update-alternatives
 
-PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)}"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'hwdb', '', d)} dns kmod"
 PACKAGECONFIG[hwdb] = "HWDB=yes,HWDB=no,udev"
-
-PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes STRIP= LIBDIR=${libdir}"
+PACKAGECONFIG[zlib] = "ZLIB=yes,ZLIB=no,zlib"
+PACKAGECONFIG[kmod] = "LIBKMOD=yes,LIBKMOD=no,kmod"
+PACKAGECONFIG[dns] = "DNS=yes,DNS=no"
 
 # see configure.patch
 do_configure () {
@@ -29,7 +30,7 @@  do_configure () {
 	  cd lib && \
 	  # PACKAGECONFIG_CONFARGS for this recipe could only possibly contain 'HWDB=yes/no',
 	  # so we put it before ./configure
-	  ${PCI_CONF_FLAG} ${PACKAGECONFIG_CONFARGS} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
+	  ${PACKAGECONFIG_CONFARGS} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
 	)
 }
 
@@ -38,7 +39,7 @@  export SBINDIR = "${sbindir}"
 export SHAREDIR = "${datadir}"
 export MANDIR = "${mandir}"
 
-EXTRA_OEMAKE = "-e MAKEFLAGS= ${PCI_CONF_FLAG}"
+EXTRA_OEMAKE = "-e MAKEFLAGS='SHARED=yes STRIP= LIBDIR=${libdir}'"
 
 ASNEEDED = ""