diff mbox series

nlohmann-json: Fix SRCREV_FORMAT and do not package git metadata into ptests

Message ID 20231126221948.3343737-1-raj.khem@gmail.com
State New
Headers show
Series nlohmann-json: Fix SRCREV_FORMAT and do not package git metadata into ptests | expand

Commit Message

Khem Raj Nov. 26, 2023, 10:19 p.m. UTC
SRCREV_FORMAT should append to default for considering both git
repositories.

the git hook scripts require shell to be installed on target and
it may want it from /usr/bin/sh and distro may not provide /usr/bin/sh
since its not having usrmerge distro feature.

Fixes
ERROR: nlohmann-json-3.11.2-r0 do_package_qa: QA Issue: /usr/lib/nlohmann-json/ptest/json_test_data/.git/hooks/update.sample contained in package nlohmann-json-ptest requires /usr/bin/sh, but no providers found in RDEPENDS:nlohmann-json-ptest? [file-rdeps]

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb
index 694d632cb1..350932388c 100644
--- a/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb
+++ b/meta-oe/recipes-devtools/nlohmann-json/nlohmann-json_3.11.2.bb
@@ -16,7 +16,7 @@  SRC_URI = "git://github.com/nlohmann/json.git;branch=develop;protocol=https \
 SRCREV = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d"
 SRCREV_json-test-data = "a1375cea09d27cc1c4cadb8d00470375b421ac37"
 
-SRCREV_FORMAT = "json-test-data"
+SRCREV_FORMAT .= "_json-test-data"
 
 S = "${WORKDIR}/git"
 
@@ -36,6 +36,7 @@  do_install_ptest () {
     install -d ${D}${PTEST_PATH}/tests
     cp -r ${S}/json_test_data/ ${D}${PTEST_PATH}/
     cp -r ${B}/tests/test-* ${D}${PTEST_PATH}/tests
+    rm -rf ${D}${PTEST_PATH}/json_test_data/.git
 }