diff mbox series

[4/5] python3-sphinxcontrib-qthelp: 1.0.3 -> 1.0.6

Message ID f5b14940b111674648e451301027f628c5988a17.1700670471.git.tim.orling@konsulko.com
State Accepted, archived
Commit a38ec60aa0a3eece7060cc86f1aae161072e212e
Headers show
Series [1/5] python3-sphinxcontrib-applehelp: 1.0.4 -> 1.0.7 | expand

Commit Message

Tim Orling Nov. 22, 2023, 4:37 p.m. UTC
* Upstream download filename changed from sphinxcontrib-qthelp*
  to sphinxcontrib_qthelp*
* build-backend changed to flit (inherit python_flit_core)

Release 1.0.6 (2023-08-14)
==========================

* Use ``os.PathLike`` over ``pathlib.Path``

Release 1.0.5 (2023-08-09)
==========================

* Fix tests for Sphinx 7.1 and below

Release 1.0.4 (2023-08-07)
==========================

* Drop support for Python 3.5, 3.6, 3.7, and 3.8
* Raise minimum required Sphinx version to 5.0

https://github.com/sphinx-doc/sphinxcontrib-qthelp/compare/1.0.3...1.0.6

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 ...help_1.0.3.bb => python3-sphinxcontrib-qthelp_1.0.6.bb} | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-sphinxcontrib-qthelp_1.0.3.bb => python3-sphinxcontrib-qthelp_1.0.6.bb} (54%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-sphinxcontrib-qthelp_1.0.3.bb b/meta/recipes-devtools/python/python3-sphinxcontrib-qthelp_1.0.6.bb
similarity index 54%
rename from meta/recipes-devtools/python/python3-sphinxcontrib-qthelp_1.0.3.bb
rename to meta/recipes-devtools/python/python3-sphinxcontrib-qthelp_1.0.6.bb
index 41d2b6187b7..3538b063d6c 100644
--- a/meta/recipes-devtools/python/python3-sphinxcontrib-qthelp_1.0.3.bb
+++ b/meta/recipes-devtools/python/python3-sphinxcontrib-qthelp_1.0.6.bb
@@ -3,10 +3,13 @@  HOMEPAGE = "http://babel.edgewall.org/"
 LICENSE = "BSD-2-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=f7a83b72ea86d04827575ec0b63430eb"
 
-SRC_URI[sha256sum] = "4c33767ee058b70dba89a6fc5c1892c0d57a54be67ddd3e7875a18d14cba5a72"
+SRC_URI[sha256sum] = "62b9d1a186ab7f5ee3356d906f648cacb7a6bdb94d201ee7adf26db55092982d"
 
 PYPI_PACKAGE = "sphinxcontrib-qthelp"
 
-inherit pypi setuptools3
+inherit pypi python_flit_core
+
+PYPI_ARCHIVE_NAME = "sphinxcontrib_qthelp-${PV}.${PYPI_PACKAGE_EXT}"
+S = "${WORKDIR}/sphinxcontrib_qthelp-${PV}"
 
 BBCLASSEXTEND = "native nativesdk"