diff mbox series

[kirkstone,1/1] mesa-pvr: use different srcrev for Rogue and SGX GPU platforms

Message ID 20231122145324.3481890-1-anandb@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [kirkstone,1/1] mesa-pvr: use different srcrev for Rogue and SGX GPU platforms | expand

Commit Message

Anand Balagopalakrishnan Nov. 22, 2023, 2:53 p.m. UTC
From: Darren Etheridge <detheridge@ti.com>

A bug was introduced while trying to unify the Mesa version that is used
on SGX GPU's and Rogue GPU's.   It manifests itself as an immediate segfault
whenever you try and run something like glmark2-es2-wayland or
weston-simple-egl on certain Rogue based platforms (specifically am62x).

Use different srcrev for Rogue GPU and SGX GPU platforms. The SGX GPU platforms
will use the latest commit. Rogue GPU platforms will use the last good working
commit before SGX related changes were introduced.

This change will be reverted once the issue is rootcaused and a common solution
is found for both Rogue and SGX based GPU platforms.

Signed-off-by: Darren Etheridge <detheridge@ti.com>
Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com>
---
 meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
index 98d30c5b..55dad414 100644
--- a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
+++ b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
@@ -23,13 +23,17 @@  SRC_URI = " \
 
 S = "${WORKDIR}/git"
 
-SRCREV = "7c9522a4147836064f582278e4f7115735c16868"
-
 PACKAGECONFIG:append = " \
     ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver', 'pvr', '', d)} \
     ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \
 "
 
+# Temporary work around to use a different SRCREV for SGX Mesa, vs Rogue Mesa
+# Idea is these two should be the same, but currently a segfault is happening
+# on certain platforms if the sgx commit is used.
+SRCREV = "${@bb.utils.contains('PACKAGECONFIG', 'sgx', '7c9522a4147836064f582278e4f7115735c16868', '54fd9d7dea098b6f11c2a244b0c6763dc8c5690c', d)}"
+PR = "sgxrgx-${SRCREV}"
+
 PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss"
 PACKAGECONFIG[pvr] = "-Dgallium-pvr-alias=${PVR_DISPLAY_CONTROLLER_ALIAS},"
 PACKAGECONFIG[sgx] = "-Dgallium-sgx-alias=${PVR_DISPLAY_CONTROLLER_ALIAS},"