[meta-oe] libiio: use setuptools functions instead of distutils

Message ID 20220210141520.5348-1-sam.van.den.berge@oip.be
State New
Headers show
Series [meta-oe] libiio: use setuptools functions instead of distutils | expand

Commit Message

Sam Van Den Berge Feb. 10, 2022, 2:15 p.m. UTC
From: Sam Van Den Berge <sam.van.den.berge@gmail.com>

Since ca73393a36c4144662ea8570f904154188e9815a in oe-core, setuptools
does not inherit from distutils3 anymore. Therefore replace the
distutils functions and variables by their setuptools counterparts which
are now available.

Signed-off-by: Sam Van Den Berge <sam.van.den.berge@gmail.com>
---
 meta-oe/recipes-support/libiio/libiio_git.bb | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Patch

diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
index 6632f7e64..f33fc0c1c 100644
--- a/meta-oe/recipes-support/libiio/libiio_git.bb
+++ b/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -14,7 +14,7 @@  UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
 
 S = "${WORKDIR}/git"
 
-DISTUTILS_SETUP_PATH ?= "${B}/bindings/python/"
+SETUPTOOLS_SETUP_PATH ?= "${B}/bindings/python/"
 
 DEPENDS = " \
     flex-native bison-native libaio \
@@ -65,14 +65,14 @@  do_configure() {
 
 do_compile() {
     if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then
-        distutils3_do_compile
+        setuptools3_do_compile
     fi
     cmake_do_compile
 }
 
 do_install() {
     if ${@bb.utils.contains('PACKAGECONFIG', 'libiio-python3', 'true', 'false', d)}; then
-        distutils3_do_install
+        setuptools3_do_install
     fi
     cmake_do_install
 }