diff mbox series

[meta-oe,2/2] idevicerestore: Upgrade to latest master

Message ID 20231120072416.2556340-3-potin.lai.pt@gmail.com
State Accepted
Headers show
Series Upgrade idevicerestore and libplist to latest master | expand

Commit Message

Potin Lai Nov. 20, 2023, 7:24 a.m. UTC
Upgrade to latest master.

ecae6c6 Change path_get_basename arg to const too
acecac3 Change path_get_basename()'s return type to const char*
83600e9 restore: Fix UaF
85ea337 asr: Fix sending payload without checksum
10c15d5 Fix update restore by making sure the premanifest is properly generated
6085ed7 Print progress for large components (e.g. Cryptex)
f87ab8b .gitignore: Add src/idevicerestore.exe
8664de0 Print device Product and Build Version and IPSW Product and Build Version
c871c59 Extract OS component when using older ipsw archives
4072cd9 tss: Add USBPortController1,* entries to parameters
503bdd0 Improve debug output by suppressing libimobiledevice and libirecovery debug output by default
6806495 restore: Also print checkpoint warning messages
f17f520 restore: Add Ace3 as known updater name to suppress error message
523e567 restore: Skip adding FirmwareData to FirmwareResponseData for Rose
7e5860d restore: Improve checkpoint log output again, make sure to always check for errors
1405a9f restore: Refine checkpoint log output
e4e5512 restore/tss: Prefer DeviceGeneratedRequest for Rose TSS request, and add missing tag
064daea restore: Add new SE,ChipID 0x36 to list of known values
ca76f44 restore: Attributed status code 50 with SEP load failure
c96f60b restore: Handle SepStage1 (SEPPatchImageData) in NORImageData
cf22a1c tss: Add Ap,SikaFuse to TSS request as seen for iPhone 14/15 devices
dbe7313 Refactor ipsw code to transparently stream images directly from ZIP or extracted ipsw
17969ef [github-actions] Updated to use upload-artifact@v3
cc9c68e autoconf: Link against libusbmuxd too
9546654 [github-actions] Updated to use checkout@v3
5a00bbd tss: Make missing ApNonce non-fatal for IMG3
7943b63 normal: Don't do unpair before entering recovery mode, remove pairing record afterwards instead
4191036 restore: Remove plist debug print for non-existent UniqueBuildID
c8b9f3e fdr: Fix a debug log message
9b9bba7 tss: Bump auth client version to match iOS 16.5
ed5463a Add generic TSS request generator
a351513 Add SE,ChipID 0x2C
da22dd4 Display iBoot boot stage
73438a6 Add support for incoherent iBoot parameters
609f7f0 Use DeviceGeneratedRequest plist for SE TSS requests

Signed-off-by: Potin Lai <potin.lai.pt@gmail.com>
---
 meta-oe/recipes-support/idevicerestore/idevicerestore_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/idevicerestore/idevicerestore_git.bb b/meta-oe/recipes-support/idevicerestore/idevicerestore_git.bb
index 2a0a129fe..3dbd8db63 100644
--- a/meta-oe/recipes-support/idevicerestore/idevicerestore_git.bb
+++ b/meta-oe/recipes-support/idevicerestore/idevicerestore_git.bb
@@ -10,7 +10,7 @@  DEPENDS = "libirecovery libimobiledevice libzip curl libimobiledevice-glue opens
 
 PV = "1.0.1+git${SRCPV}"
 
-SRCREV = "163a1647dedb7ca4656c0f072e4733573f9f982b"
+SRCREV = "ecae6c6e8ca6b6bad080a1c73f10ffd0e67d75a7"
 SRC_URI = "git://github.com/libimobiledevice/idevicerestore;protocol=https;branch=master"
 
 S = "${WORKDIR}/git"