diff mbox series

ffmpeg: Upgrade 6.0 -> 6.1

Message ID 20231118171838.42190-1-f_l_k@t-online.de
State Accepted, archived
Commit faa32bbb35e92a14b8064715c12e1007fd106b34
Headers show
Series ffmpeg: Upgrade 6.0 -> 6.1 | expand

Commit Message

Markus Volk Nov. 18, 2023, 5:18 p.m. UTC
-Remove patches that made it upstream

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...ops-clip-constants-used-with-shift-i.patch | 77 -------------------
 ...bswscale-riscv-Fix-syntax-of-vsetvli.patch | 35 ---------
 .../ffmpeg/{ffmpeg_6.0.bb => ffmpeg_6.1.bb}   |  6 +-
 3 files changed, 2 insertions(+), 116 deletions(-)
 delete mode 100644 meta/recipes-multimedia/ffmpeg/ffmpeg/0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch
 delete mode 100644 meta/recipes-multimedia/ffmpeg/ffmpeg/0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch
 rename meta/recipes-multimedia/ffmpeg/{ffmpeg_6.0.bb => ffmpeg_6.1.bb} (96%)

Comments

Khem Raj Nov. 20, 2023, 4:22 p.m. UTC | #1
breaks musicpd

https://errors.yoctoproject.org/Errors/Details/742704/

On Sat, Nov 18, 2023 at 9:18 AM Markus Volk <f_l_k@t-online.de> wrote:
>
> -Remove patches that made it upstream
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  ...ops-clip-constants-used-with-shift-i.patch | 77 -------------------
>  ...bswscale-riscv-Fix-syntax-of-vsetvli.patch | 35 ---------
>  .../ffmpeg/{ffmpeg_6.0.bb => ffmpeg_6.1.bb}   |  6 +-
>  3 files changed, 2 insertions(+), 116 deletions(-)
>  delete mode 100644 meta/recipes-multimedia/ffmpeg/ffmpeg/0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch
>  delete mode 100644 meta/recipes-multimedia/ffmpeg/ffmpeg/0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch
>  rename meta/recipes-multimedia/ffmpeg/{ffmpeg_6.0.bb => ffmpeg_6.1.bb} (96%)
>
> diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch b/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch
> deleted file mode 100644
> index a47a20365f..0000000000
> --- a/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch
> +++ /dev/null
> @@ -1,77 +0,0 @@
> -From effadce6c756247ea8bae32dc13bb3e6f464f0eb Mon Sep 17 00:00:00 2001
> -From: =?UTF-8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
> -Date: Sun, 16 Jul 2023 18:18:02 +0300
> -Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
> - instructions within inline assembly
> -
> -Fixes assembling with binutil as >= 2.41
> -
> -Upstream-Status: Backport [https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/effadce6c756247ea8bae32dc13bb3e6f464f0eb]
> -Signed-off-by: James Almer <jamrial@gmail.com>
> ----
> - libavcodec/x86/mathops.h | 26 +++++++++++++++++++++++---
> - 1 file changed, 23 insertions(+), 3 deletions(-)
> -
> -diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
> -index 6298f5ed19..ca7e2dffc1 100644
> ---- a/libavcodec/x86/mathops.h
> -+++ b/libavcodec/x86/mathops.h
> -@@ -35,12 +35,20 @@
> - static av_always_inline av_const int MULL(int a, int b, unsigned shift)
> - {
> -     int rt, dummy;
> -+    if (__builtin_constant_p(shift))
> -     __asm__ (
> -         "imull %3               \n\t"
> -         "shrdl %4, %%edx, %%eax \n\t"
> -         :"=a"(rt), "=d"(dummy)
> --        :"a"(a), "rm"(b), "ci"((uint8_t)shift)
> -+        :"a"(a), "rm"(b), "i"(shift & 0x1F)
> -     );
> -+    else
> -+        __asm__ (
> -+            "imull %3               \n\t"
> -+            "shrdl %4, %%edx, %%eax \n\t"
> -+            :"=a"(rt), "=d"(dummy)
> -+            :"a"(a), "rm"(b), "c"((uint8_t)shift)
> -+        );
> -     return rt;
> - }
> -
> -@@ -113,19 +121,31 @@ __asm__ volatile(\
> - // avoid +32 for shift optimization (gcc should do that ...)
> - #define NEG_SSR32 NEG_SSR32
> - static inline  int32_t NEG_SSR32( int32_t a, int8_t s){
> -+    if (__builtin_constant_p(s))
> -     __asm__ ("sarl %1, %0\n\t"
> -          : "+r" (a)
> --         : "ic" ((uint8_t)(-s))
> -+         : "i" (-s & 0x1F)
> -     );
> -+    else
> -+        __asm__ ("sarl %1, %0\n\t"
> -+               : "+r" (a)
> -+               : "c" ((uint8_t)(-s))
> -+        );
> -     return a;
> - }
> -
> - #define NEG_USR32 NEG_USR32
> - static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
> -+    if (__builtin_constant_p(s))
> -     __asm__ ("shrl %1, %0\n\t"
> -          : "+r" (a)
> --         : "ic" ((uint8_t)(-s))
> -+         : "i" (-s & 0x1F)
> -     );
> -+    else
> -+        __asm__ ("shrl %1, %0\n\t"
> -+               : "+r" (a)
> -+               : "c" ((uint8_t)(-s))
> -+        );
> -     return a;
> - }
> -
> ---
> -2.41.0
> -
> diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch b/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch
> deleted file mode 100644
> index 94e0ba6d10..0000000000
> --- a/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch
> +++ /dev/null
> @@ -1,35 +0,0 @@
> -From 85eefb65eb632d827e17a72518dd289dcd721084 Mon Sep 17 00:00:00 2001
> -From: Khem Raj <raj.khem@gmail.com>
> -Date: Sun, 2 Jul 2023 19:29:55 -0700
> -Subject: [PATCH] libswscale/riscv: Fix syntax of vsetvli
> -
> -Add missing operand which clang complains about but gcc assumes it to be
> -'m1' if not specifiied.
> -
> -Fixes building with clang
> -| src/libswscale/riscv/rgb2rgb_rvv.S:88:25: error: operand must be e[8|16|32|64|128|256|512|1024],m[1|2|4|8|f2|f4|f8],[ta|tu],[ma|mu]
> -|         vsetvli t4, t3, e8, ta, ma
> -|                         ^
> -
> -Upstream-Status: Submitted [https://ffmpeg.org/pipermail/ffmpeg-devel/2023-July/311514.html]
> -Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ----
> - libswscale/riscv/rgb2rgb_rvv.S | 2 +-
> - 1 file changed, 1 insertion(+), 1 deletion(-)
> -
> -diff --git a/libswscale/riscv/rgb2rgb_rvv.S b/libswscale/riscv/rgb2rgb_rvv.S
> -index 5626d90..bbdfdbe 100644
> ---- a/libswscale/riscv/rgb2rgb_rvv.S
> -+++ b/libswscale/riscv/rgb2rgb_rvv.S
> -@@ -85,7 +85,7 @@ func ff_interleave_bytes_rvv, zve32x
> -         mv      t3, a3
> -         addi    a4, a4, -1
> - 2:
> --        vsetvli    t4, t3, e8, ta, ma
> -+        vsetvli    t4, t3, e8, m1, ta, ma
> -         sub        t3, t3, t4
> -         vle8.v     v8, (t0)
> -         add        t0, t4, t0
> ---
> -2.41.0
> -
> diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_6.0.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_6.1.bb
> similarity index 96%
> rename from meta/recipes-multimedia/ffmpeg/ffmpeg_6.0.bb
> rename to meta/recipes-multimedia/ffmpeg/ffmpeg_6.1.bb
> index e65f80d64b..6b5731d052 100644
> --- a/meta/recipes-multimedia/ffmpeg/ffmpeg_6.0.bb
> +++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_6.1.bb
> @@ -22,11 +22,9 @@ LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
>                      file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
>                      file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
>
> -SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz \
> -           file://0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch \
> -           file://0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch"
> +SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz"
>
> -SRC_URI[sha256sum] = "57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082"
> +SRC_URI[sha256sum] = "488c76e57dd9b3bee901f71d5c95eaf1db4a5a31fe46a28654e837144207c270"
>
>  # https://nvd.nist.gov/vuln/detail/CVE-2023-39018
>  # https://github.com/bramp/ffmpeg-cli-wrapper/issues/291
> --
> 2.42.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#190865): https://lists.openembedded.org/g/openembedded-core/message/190865
> Mute This Topic: https://lists.openembedded.org/mt/102674870/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch b/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch
deleted file mode 100644
index a47a20365f..0000000000
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch
+++ /dev/null
@@ -1,77 +0,0 @@ 
-From effadce6c756247ea8bae32dc13bb3e6f464f0eb Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
-Date: Sun, 16 Jul 2023 18:18:02 +0300
-Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
- instructions within inline assembly
-
-Fixes assembling with binutil as >= 2.41
-
-Upstream-Status: Backport [https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/effadce6c756247ea8bae32dc13bb3e6f464f0eb]
-Signed-off-by: James Almer <jamrial@gmail.com>
----
- libavcodec/x86/mathops.h | 26 +++++++++++++++++++++++---
- 1 file changed, 23 insertions(+), 3 deletions(-)
-
-diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
-index 6298f5ed19..ca7e2dffc1 100644
---- a/libavcodec/x86/mathops.h
-+++ b/libavcodec/x86/mathops.h
-@@ -35,12 +35,20 @@
- static av_always_inline av_const int MULL(int a, int b, unsigned shift)
- {
-     int rt, dummy;
-+    if (__builtin_constant_p(shift))
-     __asm__ (
-         "imull %3               \n\t"
-         "shrdl %4, %%edx, %%eax \n\t"
-         :"=a"(rt), "=d"(dummy)
--        :"a"(a), "rm"(b), "ci"((uint8_t)shift)
-+        :"a"(a), "rm"(b), "i"(shift & 0x1F)
-     );
-+    else
-+        __asm__ (
-+            "imull %3               \n\t"
-+            "shrdl %4, %%edx, %%eax \n\t"
-+            :"=a"(rt), "=d"(dummy)
-+            :"a"(a), "rm"(b), "c"((uint8_t)shift)
-+        );
-     return rt;
- }
- 
-@@ -113,19 +121,31 @@ __asm__ volatile(\
- // avoid +32 for shift optimization (gcc should do that ...)
- #define NEG_SSR32 NEG_SSR32
- static inline  int32_t NEG_SSR32( int32_t a, int8_t s){
-+    if (__builtin_constant_p(s))
-     __asm__ ("sarl %1, %0\n\t"
-          : "+r" (a)
--         : "ic" ((uint8_t)(-s))
-+         : "i" (-s & 0x1F)
-     );
-+    else
-+        __asm__ ("sarl %1, %0\n\t"
-+               : "+r" (a)
-+               : "c" ((uint8_t)(-s))
-+        );
-     return a;
- }
- 
- #define NEG_USR32 NEG_USR32
- static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
-+    if (__builtin_constant_p(s))
-     __asm__ ("shrl %1, %0\n\t"
-          : "+r" (a)
--         : "ic" ((uint8_t)(-s))
-+         : "i" (-s & 0x1F)
-     );
-+    else
-+        __asm__ ("shrl %1, %0\n\t"
-+               : "+r" (a)
-+               : "c" ((uint8_t)(-s))
-+        );
-     return a;
- }
- 
--- 
-2.41.0
-
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch b/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch
deleted file mode 100644
index 94e0ba6d10..0000000000
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg/0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch
+++ /dev/null
@@ -1,35 +0,0 @@ 
-From 85eefb65eb632d827e17a72518dd289dcd721084 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 2 Jul 2023 19:29:55 -0700
-Subject: [PATCH] libswscale/riscv: Fix syntax of vsetvli
-
-Add missing operand which clang complains about but gcc assumes it to be
-'m1' if not specifiied.
-
-Fixes building with clang
-| src/libswscale/riscv/rgb2rgb_rvv.S:88:25: error: operand must be e[8|16|32|64|128|256|512|1024],m[1|2|4|8|f2|f4|f8],[ta|tu],[ma|mu]
-|         vsetvli t4, t3, e8, ta, ma
-|                         ^
-
-Upstream-Status: Submitted [https://ffmpeg.org/pipermail/ffmpeg-devel/2023-July/311514.html]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- libswscale/riscv/rgb2rgb_rvv.S | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libswscale/riscv/rgb2rgb_rvv.S b/libswscale/riscv/rgb2rgb_rvv.S
-index 5626d90..bbdfdbe 100644
---- a/libswscale/riscv/rgb2rgb_rvv.S
-+++ b/libswscale/riscv/rgb2rgb_rvv.S
-@@ -85,7 +85,7 @@ func ff_interleave_bytes_rvv, zve32x
-         mv      t3, a3
-         addi    a4, a4, -1
- 2:
--        vsetvli    t4, t3, e8, ta, ma
-+        vsetvli    t4, t3, e8, m1, ta, ma
-         sub        t3, t3, t4
-         vle8.v     v8, (t0)
-         add        t0, t4, t0
--- 
-2.41.0
-
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_6.0.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_6.1.bb
similarity index 96%
rename from meta/recipes-multimedia/ffmpeg/ffmpeg_6.0.bb
rename to meta/recipes-multimedia/ffmpeg/ffmpeg_6.1.bb
index e65f80d64b..6b5731d052 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_6.0.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_6.1.bb
@@ -22,11 +22,9 @@  LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                     file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
                     file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
 
-SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz \
-           file://0001-avcodec-x86-mathops-clip-constants-used-with-shift-i.patch \
-           file://0001-libswscale-riscv-Fix-syntax-of-vsetvli.patch"
+SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz"
 
-SRC_URI[sha256sum] = "57be87c22d9b49c112b6d24bc67d42508660e6b718b3db89c44e47e289137082"
+SRC_URI[sha256sum] = "488c76e57dd9b3bee901f71d5c95eaf1db4a5a31fe46a28654e837144207c270"
 
 # https://nvd.nist.gov/vuln/detail/CVE-2023-39018
 # https://github.com/bramp/ffmpeg-cli-wrapper/issues/291