diff mbox series

[meta-oe] cloc: upgrade 1.94 -> 1.98

Message ID 20231116165527.1196891-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-oe] cloc: upgrade 1.94 -> 1.98 | expand

Commit Message

alperak Nov. 16, 2023, 4:55 p.m. UTC
Changelog:

- New Languages: Cairo, Carbon, Circom, Containerfile, HolyC, kvlang, Nunjucks, OpenSCAD, P4, Pest, Pony, TEAL, WGSL
- New switch --diff-list-files to run diff given two list files
- Handle comments embedded in OCaml strings
- Write empty JSON and XML structures if the inputs yield zero counts
- Support for long paths on Windows
- Better support for building and running Docker image on Windows
- Better output file names when running with --count-and-diff and --out;
- Resolve internal file handle conflict when running --diff with --sdir or --categorized

- New Languages: Asymptote, CoCoA 5, Constraint Grammar, Hare, Jai, Linker Script, NetLogo, Typst
- Added .editorconfig as an INI extension.
- Added .cppm, .ixx, .ccm, .cxxm, .c++m as C++ extensions.
- Improved handling of trailing slash with --match-d
- --exclude-list-file with --git now works as expected.
- --not-match-d, --not-match-f can now be repeated.
- --quiet mode is now enabled when STDOUT is not a terminal. This makes for cleaner output when piping to other programs.
- New switch --include-content=regex to only count files whose content matches the given regex.
- New switch --only-count-files to only count files. Counts for blank, comment, and code lines will be zero.
- --no-recurse now works on Windows
- Improved exclusion of autogenerated files on Windows.
- Improved handling of path separators with git in PowerShell.
- Resolve nondeterministic --diff output.
- --hide-rate supports all output file types
- Fixed --diff-list-file with unknown listed file.
- Fixed parsing of verbose option in the cloc configuration file.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 meta-oe/recipes-devtools/cloc/{cloc_1.94.bb => cloc_1.98.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-oe/recipes-devtools/cloc/{cloc_1.94.bb => cloc_1.98.bb} (85%)

Comments

Khem Raj Nov. 20, 2023, 3:51 a.m. UTC | #1
On Thu, 16 Nov 2023 19:55:27 +0300, alperak wrote:
> Changelog:
> 
> - New Languages: Cairo, Carbon, Circom, Containerfile, HolyC, kvlang, Nunjucks, OpenSCAD, P4, Pest, Pony, TEAL, WGSL
> - New switch --diff-list-files to run diff given two list files
> - Handle comments embedded in OCaml strings
> - Write empty JSON and XML structures if the inputs yield zero counts
> - Support for long paths on Windows
> - Better support for building and running Docker image on Windows
> - Better output file names when running with --count-and-diff and --out;
> - Resolve internal file handle conflict when running --diff with --sdir or --categorized
> 
> [...]

Applied, thanks!

[1/1] cloc: upgrade 1.94 -> 1.98
      commit: 1292ec8a03dd14bedd95fb3f1100212a81d475fe

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/cloc/cloc_1.94.bb b/meta-oe/recipes-devtools/cloc/cloc_1.98.bb
similarity index 85%
rename from meta-oe/recipes-devtools/cloc/cloc_1.94.bb
rename to meta-oe/recipes-devtools/cloc/cloc_1.98.bb
index 37a21cc3a..ea5f00669 100644
--- a/meta-oe/recipes-devtools/cloc/cloc_1.94.bb
+++ b/meta-oe/recipes-devtools/cloc/cloc_1.98.bb
@@ -5,7 +5,7 @@  LICENSE="GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
 
 SRC_URI = "https://github.com/AlDanial/cloc/releases/download/v${PV}/${BP}.tar.gz"
-SRC_URI[sha256sum] = "08212290c4e9b21c7bb1abc0a9b4a365ce1c5eb0d8f3ebb74d50b29559a71a9c"
+SRC_URI[sha256sum] = "5fe0b159eb75718df7308a4f61470eaddf82170733929999e37a3fbb4651cf8a"
 
 UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases"