[5/5] poky-tiny: enable qemuarmv5/qemuarm64 and cleanups

Message ID 20220209173014.1389378-6-jdmason@kudzu.us
State Accepted, archived
Commit 9bd21e1130155ad1ec704e0151a22e9f84bfaa78
Headers show
Series poky-tiny clean-ups and qemuarm fixes | expand

Commit Message

Jon Mason Feb. 9, 2022, 5:30 p.m. UTC
Add support for qemuarmv5 and qemuarm64, and remove qemuarm specific
entries, as it should be generic now.

Signed-off-by: Jon Mason <jdmason@kudzu.us>
---
 meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Khem Raj Feb. 9, 2022, 5:57 p.m. UTC | #1
On Wed, Feb 9, 2022 at 9:30 AM Jon Mason <jdmason@kudzu.us> wrote:
>
> Add support for qemuarmv5 and qemuarm64, and remove qemuarm specific
> entries, as it should be generic now.
>
> Signed-off-by: Jon Mason <jdmason@kudzu.us>
> ---
>  meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> index 2c81e3c00506..e146ecddceb9 100644
> --- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> @@ -1,5 +1,4 @@
>  KBRANCH ?= "v5.15/standard/tiny/base"
> -KBRANCH:qemuarm  ?= "v5.15/standard/tiny/arm-versatile-926ejs"
>
>  LINUX_KERNEL_TYPE = "tiny"
>  KCONFIG_MODE = "--allnoconfig"
> @@ -15,16 +14,16 @@ DEPENDS += "openssl-native util-linux-native"
>  KMETA = "kernel-meta"
>  KCONF_BSP_AUDIT_LEVEL = "2"
>
> -SRCREV_machine:qemuarm ?= "67b4c868eafbd63c437d0e79523c3bdc5f3aa834"
>  SRCREV_machine ?= "f46816a75d738acbe4b1211153badf2f8e412780"
>  SRCREV_meta ?= "26e884f8c2d22607e97900d22ad52a290f555fd7"
>
> +

spurious line :)

>  PV = "${LINUX_VERSION}+git${SRCPV}"
>
>  SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
>             git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
>
> -COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
> +COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5"
>
>  # Functionality flags
>  KERNEL_FEATURES = ""
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#161574): https://lists.openembedded.org/g/openembedded-core/message/161574
> Mute This Topic: https://lists.openembedded.org/mt/89026732/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
index 2c81e3c00506..e146ecddceb9 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
@@ -1,5 +1,4 @@ 
 KBRANCH ?= "v5.15/standard/tiny/base"
-KBRANCH:qemuarm  ?= "v5.15/standard/tiny/arm-versatile-926ejs"
 
 LINUX_KERNEL_TYPE = "tiny"
 KCONFIG_MODE = "--allnoconfig"
@@ -15,16 +14,16 @@  DEPENDS += "openssl-native util-linux-native"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine:qemuarm ?= "67b4c868eafbd63c437d0e79523c3bdc5f3aa834"
 SRCREV_machine ?= "f46816a75d738acbe4b1211153badf2f8e412780"
 SRCREV_meta ?= "26e884f8c2d22607e97900d22ad52a290f555fd7"
 
+
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
 
-COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5"
 
 # Functionality flags
 KERNEL_FEATURES = ""