diff mbox series

[meta-python,1/3] python3-file-magic: add recipe

Message ID 20231113142909.3093632-1-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/3] python3-file-magic: add recipe | expand

Commit Message

Leon Anavi Nov. 13, 2023, 2:29 p.m. UTC
Add file-magic version 0.4.1, a Python front end for libmagic(3).

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-file-magic_0.4.1.bb        | 21 +++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-file-magic_0.4.1.bb

Comments

Khem Raj Nov. 15, 2023, 7:19 a.m. UTC | #1
On Mon, 13 Nov 2023 16:29:07 +0200, Leon Anavi wrote:
> Add file-magic version 0.4.1, a Python front end for libmagic(3).
> 
> This work was sponsored by GOVCERT.LU.
> 
> 

Applied, thanks!

[1/3] python3-file-magic: add recipe
      commit: 5f2bd05add2b2ffede9cdfb714a859341397a1d9
[2/3] python3-wrapt: Upgrade 1.15.0 -> 1.16.0
      commit: 1c7691712f185aff821689d65a49d1cd085f54b6
[3/3] python3-bitarray: Upgrade 2.8.2 -> 2.8.3
      commit: 078646e1b51274295fbbabc340fe02223017c76f

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-file-magic_0.4.1.bb b/meta-python/recipes-devtools/python/python3-file-magic_0.4.1.bb
new file mode 100644
index 000000000..837edf7df
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-file-magic_0.4.1.bb
@@ -0,0 +1,21 @@ 
+SUMMARY = "Python front end for libmagic"
+DESCRIPTION = "This library is a Python ctypes interface to libmagic."
+HOMEPAGE = "https://darwinsys.com/file/"
+LICENSE = "BSD-2-Clause"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0e949c0b3fb4fd86232f00c6ee0bdef3"
+
+SRC_URI[sha256sum] = "a91d1483117f7ed48cd0238ad9be36b04824d57e9c38ea7523113989e81b9c53"
+
+PYPI_PACKAGE="file-magic"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    file \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-ctypes \
+    ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"