diff mbox series

[meta-oe] exiftool: add recipe

Message ID 20231108123356.2321371-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-oe] exiftool: add recipe | expand

Commit Message

Leon Anavi Nov. 8, 2023, 12:33 p.m. UTC
Add ExifTool, a platform-independent Perl library plus a command-line
application for reading, writing and editing meta information in a
wide variety of files. Version 12.69 brings:

- Added support for DNG version 1.7.0.0
- Added a new XMP-GCamera tag
- Added a number of new Nikon Z lenses (thanks Warren Hatch and Stefan)
- Added a number of new XMP-crs tags
- Extract XML metadata from some Hasselblad images
- Tweaked -fast2 option to read metadata from inside mdat atom of HEIC images
- Patched FFF reader to be more tolerant of the mess made by incompetent
  Hasselblad programmers (wrong IFD count for some values)
- Patched WebP reader to be more tolerant of the mess made by incompetent
  Google programmers (EXIF with wrong header and XMP with wrong ID)
- Fixed problem which could cause "use of uninitialized variable" warnings
  when reading images from some Nikon cameras
- Fixed List type for new XMP-photomech:CreatorIdentity tag

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../recipes-devtools/perl/exiftool_12.69.bb   | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/perl/exiftool_12.69.bb
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/perl/exiftool_12.69.bb b/meta-oe/recipes-devtools/perl/exiftool_12.69.bb
new file mode 100644
index 000000000..09b45ada7
--- /dev/null
+++ b/meta-oe/recipes-devtools/perl/exiftool_12.69.bb
@@ -0,0 +1,22 @@ 
+SUMMARY = "Exiftool"
+DESCRIPTION = "ExifTool is a platform-independent Perl library plus a command-line application for reading, writing and editing meta information in a wide variety of files."
+HOMEPAGE = "https://exiftool.org/"
+SECTION = "libs"
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://perl-Image-ExifTool.spec;beginline=5;endline=5;md5=ffefffc98dab025cb49489bd4d88ee10"
+
+inherit cpan
+
+SRCREV = "d521eba31a3d1753f53ee251cd6879900a0275b5"
+SRC_URI = "git://github.com/exiftool/exiftool;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS:${PN} = " \
+    perl \
+    perl-module-list-util \
+    perl-module-overload \
+    perl-module-file-glob \
+    perl-module-scalar-util \
+    perl-module-compress-zlib \
+"