diff mbox series

[meta-python,1/3] python3-pybcj: add recipe

Message ID 20231106134623.11522-1-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/3] python3-pybcj: add recipe | expand

Commit Message

Leon Anavi Nov. 6, 2023, 1:46 p.m. UTC
Add pybcj, a bcj filter library. Version 1.0.2 brings:

- Support python 3.12
- Add cibuildwheel config

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-pybcj_1.0.2.bb             | 24 +++++++++++++++++++
 1 file changed, 24 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pybcj_1.0.2.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pybcj_1.0.2.bb b/meta-python/recipes-devtools/python/python3-pybcj_1.0.2.bb
new file mode 100644
index 000000000..34ffb9793
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pybcj_1.0.2.bb
@@ -0,0 +1,24 @@ 
+SUMMARY = "bcj filter library"
+HOMEPAGE = "https://codeberg.org/miurahr/pybcj"
+LICENSE = "LGPL-2.1-or-later"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[sha256sum] = "c7f5bef7f47723c53420e377bc64d2553843bee8bcac5f0ad076ab1524780018"
+
+inherit pypi python_setuptools_build_meta pypi
+
+#PROVIDES = "python3-pybcj"
+
+DEPENDS += " \
+    ${PYTHON_PN}-setuptools-scm-native \
+    ${PYTHON_PN}-toml-native \
+    ${PYTHON_PN}-wheel-native \
+"
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-email \
+    ${PYTHON_PN}-importlib-metadata \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-compression \
+"