Patchwork [V3,07/11] mesa: Use 'require' instead of 'include'

login
register
mail settings
Submitter Ross Burton
Date Aug. 2, 2012, 4:49 p.m.
Message ID <e00dc8cb6a5aa62814b58fcf4263023add87d175.1343926021.git.ross.burton@intel.com>
Download mbox | patch
Permalink /patch/33695/
State New
Headers show

Comments

Ross Burton - Aug. 2, 2012, 4:49 p.m.
From: Damien Lespiau <damien.lespiau@intel.com>

These include files are really required, not optional.

Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
---
 meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb  |    6 +++---
 meta/recipes-graphics/mesa/mesa-dri_git.bb    |    6 +++---
 meta/recipes-graphics/mesa/mesa-xlib_8.0.4.bb |    6 +++---
 meta/recipes-graphics/mesa/mesa-xlib_git.bb   |    6 +++---
 4 files changed, 12 insertions(+), 12 deletions(-)

Patch

diff --git a/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb b/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb
index 219e555..bd62c98 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb
@@ -1,4 +1,4 @@ 
-include mesa-common.inc
-include mesa-${PV}.inc
-include mesa-dri.inc
+require mesa-common.inc
+require mesa-${PV}.inc
+require mesa-dri.inc
 PR = "${INC_PR}.1"
diff --git a/meta/recipes-graphics/mesa/mesa-dri_git.bb b/meta/recipes-graphics/mesa/mesa-dri_git.bb
index a0e1945..4b36f20 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_git.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_git.bb
@@ -1,6 +1,6 @@ 
-include mesa-common.inc
-include mesa-git.inc
-include mesa-dri.inc
+require mesa-common.inc
+require mesa-git.inc
+require mesa-dri.inc
 
 # this needs to be lower than -1 because all mesa-dri have -1 and git version has highest PV, but shouldn't be default
 DEFAULT_PREFERENCE = "-2"
diff --git a/meta/recipes-graphics/mesa/mesa-xlib_8.0.4.bb b/meta/recipes-graphics/mesa/mesa-xlib_8.0.4.bb
index 7547b22..a89640e 100644
--- a/meta/recipes-graphics/mesa/mesa-xlib_8.0.4.bb
+++ b/meta/recipes-graphics/mesa/mesa-xlib_8.0.4.bb
@@ -1,5 +1,5 @@ 
-include mesa-common.inc
-include mesa-${PV}.inc
-include mesa-xlib.inc
+require mesa-common.inc
+require mesa-${PV}.inc
+require mesa-xlib.inc
 PR = "${INC_PR}.2"
 
diff --git a/meta/recipes-graphics/mesa/mesa-xlib_git.bb b/meta/recipes-graphics/mesa/mesa-xlib_git.bb
index be2f5d3..6647120 100644
--- a/meta/recipes-graphics/mesa/mesa-xlib_git.bb
+++ b/meta/recipes-graphics/mesa/mesa-xlib_git.bb
@@ -1,6 +1,6 @@ 
-include mesa-common.inc
-include mesa-git.inc
-include mesa-xlib.inc
+require mesa-common.inc
+require mesa-git.inc
+require mesa-xlib.inc
 
 # this needs to be lower than -1 because all mesa-dri have -1 and git version has highest PV, but shouldn't be default
 DEFAULT_PREFERENCE = "-2"