diff mbox series

systemd: fix libnss-mymachines packaging

Message ID 20231103145037.2365572-1-fw@ferncast.de
State Accepted, archived
Commit 90f143984732ba0453c2d3a734eeb4d1a289269b
Headers show
Series systemd: fix libnss-mymachines packaging | expand

Commit Message

Florian Wickert Nov. 3, 2023, 2:50 p.m. UTC
By removing libnss_mymachines.so.2 from FILES:${PN}-container it
correctly gets packaged into libnss-mymachines, just like the other
libnss-* components, due to PACKAGES_DYNAMIC.

To make up for the missing lib in the container package, I added
libnss-mymachines to RDEPENDS:${PN}-container. As I understand it,
the lib should be installed even without this if anything from the
container package links against it. But since I don't know if there
was a special reason to explicitly add it to the container files list,
like something using dlopen to load the lib, it seemd to be the
safest option.

Signed-off-by: Florian Wickert <fw@ferncast.de>
---
 meta/recipes-core/systemd/systemd_254.4.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Khem Raj Nov. 6, 2023, 4:55 p.m. UTC | #1
On Fri, Nov 3, 2023 at 7:51 AM Florian Wickert <fw@ferncast.de> wrote:
>
> By removing libnss_mymachines.so.2 from FILES:${PN}-container it
> correctly gets packaged into libnss-mymachines, just like the other
> libnss-* components, due to PACKAGES_DYNAMIC.
>
> To make up for the missing lib in the container package, I added
> libnss-mymachines to RDEPENDS:${PN}-container. As I understand it,
> the lib should be installed even without this if anything from the
> container package links against it. But since I don't know if there
> was a special reason to explicitly add it to the container files list,
> like something using dlopen to load the lib, it seemd to be the
> safest option.
>
> Signed-off-by: Florian Wickert <fw@ferncast.de>
> ---
>  meta/recipes-core/systemd/systemd_254.4.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
> index ef29116bf9..ddc8a0219a 100644
> --- a/meta/recipes-core/systemd/systemd_254.4.bb
> +++ b/meta/recipes-core/systemd/systemd_254.4.bb
> @@ -534,7 +534,6 @@ FILES:${PN}-container = "${sysconfdir}/dbus-1/system.d/org.freedesktop.import1.c
>                           ${exec_prefix}/lib/tmpfiles.d/systemd-nspawn.conf \
>                           ${exec_prefix}/lib/tmpfiles.d/README \
>                           ${systemd_system_unitdir}/systemd-nspawn@.service \
> -                         ${libdir}/libnss_mymachines.so.2 \
>                           ${datadir}/dbus-1/system-services/org.freedesktop.import1.service \
>                           ${datadir}/dbus-1/system-services/org.freedesktop.machine1.service \
>                           ${datadir}/dbus-1/system.d/org.freedesktop.import1.conf \
> @@ -543,6 +542,8 @@ FILES:${PN}-container = "${sysconfdir}/dbus-1/system.d/org.freedesktop.import1.c
>                           ${datadir}/polkit-1/actions/org.freedesktop.machine1.policy \
>                          "
>
> +RDEPENDS:${PN}-container = "libnss-mymachines"

musl based targets do not build libnss-mymachines so please make this
dependency only for glibc


> +
>  # "machinectl import-tar" uses "tar --numeric-owner", not supported by busybox.
>  RRECOMMENDS:${PN}-container += "\
>                           ${PN}-journal-gatewayd \
> --
> 2.42.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#190164): https://lists.openembedded.org/g/openembedded-core/message/190164
> Mute This Topic: https://lists.openembedded.org/mt/102365438/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
index ef29116bf9..ddc8a0219a 100644
--- a/meta/recipes-core/systemd/systemd_254.4.bb
+++ b/meta/recipes-core/systemd/systemd_254.4.bb
@@ -534,7 +534,6 @@  FILES:${PN}-container = "${sysconfdir}/dbus-1/system.d/org.freedesktop.import1.c
                          ${exec_prefix}/lib/tmpfiles.d/systemd-nspawn.conf \
                          ${exec_prefix}/lib/tmpfiles.d/README \
                          ${systemd_system_unitdir}/systemd-nspawn@.service \
-                         ${libdir}/libnss_mymachines.so.2 \
                          ${datadir}/dbus-1/system-services/org.freedesktop.import1.service \
                          ${datadir}/dbus-1/system-services/org.freedesktop.machine1.service \
                          ${datadir}/dbus-1/system.d/org.freedesktop.import1.conf \
@@ -543,6 +542,8 @@  FILES:${PN}-container = "${sysconfdir}/dbus-1/system.d/org.freedesktop.import1.c
                          ${datadir}/polkit-1/actions/org.freedesktop.machine1.policy \
                         "
 
+RDEPENDS:${PN}-container = "libnss-mymachines"
+
 # "machinectl import-tar" uses "tar --numeric-owner", not supported by busybox.
 RRECOMMENDS:${PN}-container += "\
                          ${PN}-journal-gatewayd \