diff mbox series

[meta-python,2/4] python3-oletools: add recipe

Message ID 20231102140523.3337713-2-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/4] python3-multivolumefile: add recipe | expand

Commit Message

Leon Anavi Nov. 2, 2023, 2:05 p.m. UTC
Add oletools, Python tools to analyze security characteristics of
MS Office and OLE files. Version 0.60.1 changelog:

- olevba:
  fixed a bug when calling XLMMacroDeobfuscator
  removed keyword "sample" causing false positives
- oleid: fixed OleID init issue
- oleobj:
  added simple detection of CVE-2021-40444 initial stage
  added detection for customUI onLoad
  improved handling of incorrect filenames in OLE package
- rtfobj: fixed code to find URLs in OLE2Link objects for Py3
- ftguess:
  added PowerPoint and XPS formats
  fixed issue with XPS and malformed documents
  added XLSB format
- improved logging with common module log_helper

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-oletools_0.60.1.bb                 | 11 +++++++++++
 1 file changed, 11 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-oletools_0.60.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-oletools_0.60.1.bb b/meta-python/recipes-devtools/python/python3-oletools_0.60.1.bb
new file mode 100644
index 000000000..fbb7955d6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-oletools_0.60.1.bb
@@ -0,0 +1,11 @@ 
+SUMMARY = "Python tools to analyze security characteristics of MS Office and OLE files"
+HOMEPAGE = "https://github.com/decalage2/olefile"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=d7dd4b0d1f7153322a546e89b5a0a632"
+
+SRC_URI[sha256sum] = "67a796da4c4b8e2feb9a6b2495bef8798a3323a75512de4e5669d9dc9d1fae31"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "oletools"
+PYPI_PACKAGE_EXT = "zip"