diff mbox series

[meta-python,1/2] python3-blivet: 3.4.3 -> 3.8.2

Message ID 20231102062924.786081-1-kai.kang@windriver.com
State Under Review
Headers show
Series [meta-python,1/2] python3-blivet: 3.4.3 -> 3.8.2 | expand

Commit Message

Kai Nov. 2, 2023, 6:29 a.m. UTC
From: Kai Kang <kai.kang@windriver.com>

Update python3-blivet 3.4.3 to 3.8.2

* drop 0004-fix-new.roots-object-is-not-iterable.patch which is not
  needed any more
* adjust indent as well

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 ...fix-new.roots-object-is-not-iterable.patch | 28 -------------------
 ...livet_3.4.3.bb => python3-blivet_3.8.2.bb} |  9 +++---
 2 files changed, 4 insertions(+), 33 deletions(-)
 delete mode 100644 meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch
 rename meta-python/recipes-extended/python-blivet/{python3-blivet_3.4.3.bb => python3-blivet_3.8.2.bb} (79%)
diff mbox series

Patch

diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch
deleted file mode 100644
index 526a3b1fb..000000000
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0004-fix-new.roots-object-is-not-iterable.patch
+++ /dev/null
@@ -1,28 +0,0 @@ 
-From 3bb8d08bdec2f79bb13c0a44b81718d26e5bdabc Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Mon, 8 May 2017 16:30:20 +0800
-Subject: [PATCH 04/11] fix new.roots object is not iterable
-
-Upstream-Status: Pending
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
----
- blivet/blivet.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/blivet/blivet.py b/blivet/blivet.py
-index ea08837..91c92b2 100644
---- a/blivet/blivet.py
-+++ b/blivet/blivet.py
-@@ -1206,7 +1206,7 @@ class Blivet(object):
-             p = partition.disk.format.parted_disk.getPartitionByPath(partition.path)
-             partition.parted_partition = p
- 
--        for root in new.roots:
-+        for root in new.roots or []:
-             root.swaps = [new.devicetree.get_device_by_id(d.id, hidden=True) for d in root.swaps]
-             root.swaps = [s for s in root.swaps if s]
- 
--- 
-2.7.4
-
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb
similarity index 79%
rename from meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
rename to meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb
index bd57604f2..52b3aa7dc 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb
@@ -8,7 +8,6 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 SRC_URI += "\
            file://0002-run_program-support-timeout.patch \
            file://0003-support-infinit-timeout.patch \
-           file://0004-fix-new.roots-object-is-not-iterable.patch \
            file://0005-fix-incorrect-timeout-while-system-time-changed.patch \
            file://0006-tweak-btrfs-packages.patch \
            file://0007-invoking-mount-with-infinite-timeout.patch \
@@ -17,16 +16,16 @@  SRC_URI += "\
            file://0010-invoking-mkfs-with-infinite-timeout.patch \
            file://0011-invoking-dd-with-infinite-timeout.patch \
 "
-SRC_URI[sha256sum] = "1b05b77f3ee35d82c7a577a168c9ba0204d3e9a87eb1975e5f9af47700eeff48"
+SRC_URI[sha256sum] = "88d1500c76c4660aec7da9e9aa54f7f574546571b52c07a67e1417883c2cb25b"
 
 inherit pypi features_check systemd setuptools3_legacy
 
 REQUIRED_DISTRO_FEATURES = "systemd"
 
 RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
-                  parted python3-pyparted multipath-tools \
-                  lsof cryptsetup libblockdev \
-                  libbytesize \
+                   parted python3-pyparted multipath-tools \
+                   lsof cryptsetup libblockdev \
+                   libbytesize \
 "
 
 FILES:${PN} += " \